Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Silverjuke sur PI3
#1
bonjour à tous,
mon problème est le suivant, j' ai installé Silverjuk
sur mon pi3 ( Raspbian propre) et lorsque je lance Silverjuke via le
terminal, j' ai le message suivant :
~ $  silverjuke
12:37:33: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8).
Abandon

je ne comprends pas car Silverjuke provient des paquets Raspbian
si une bonne âme peut m' aider...
merci par avance
cdlt
Répondre
#2
Amusant. Il te faut la version 3.0 mais c'est la 3.0 qui est détectée....
A mon avis, tu as sans le vouloir figé C++-dev essayes d'utiliser aptitude pour tout mettre à jour. Ou virer le "figeage de version", je ne me souviens plus de la commande en console.
Répondre
#3
(05-02-2018, 23:52:26)crazycat a écrit : Amusant. Il te faut la version 3.0 mais c'est la 3.0 qui est détectée....
A mon avis, tu as sans le vouloir figé C++-dev essayes d'utiliser aptitude pour tout mettre à jour. Ou virer le "figeage de version", je ne me souviens plus de la commande en console.

merci pour ton intervention,
après un CLEAN, AUTOCLEAN, AUTOREMOVE, UPDATE, UPGRADE ET enfin aptitude install silverjuke,
mon problème persiste Angry .

16:03:26: Warning: Mismatch between the program and library build versions detected. The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8), and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8). Abandon


les ABI 1010 et ABI 1009 ont ils à voir dans mon problème ?

uname -a
Linux raspberrypi 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux

au cas ou....
Répondre
#4
De ce que j'ai lu, c'est wxGTK qu'il faut recompiler. Peut-être que cette page pourra t'aider.
Répondre
#5
Wink 
(06-02-2018, 17:04:51)crazycat a écrit : De ce que j'ai lu, c'est wxGTK qu'il faut recompiler. Peut-être que cette page pourra t'aidj
j' ai suivi ton lien et effectué ceci :
# mkdir -p /etc/portage/patches/x11-libs/wxGTK-3.0.2.0-r2
# cd /etc/portage/patches/x11-libs/wxGTK-3.0.2.0-r2
# wget "https://github.com/wxWidgets/wxWidgets/commit/73e9e18ea09ffffcaac50237def0d9728a213c02.patch" -O wxGTK-gcc6-abs.patch
# emerge -1 =x11-libs/wxGTK-3.0.2.0-r2
la dernière commande (emerge.........) m' a retourné une erreur :   emerge : commande introuvable
comme tu le devines, je suis largué pour le coup Huh
si je je peux abuser encore un peu de ta bienveillance  Wink  je veux bien une aide Idea
cdlt
Répondre
#6
Tu devrais essayer de trouver le how-to pour le faire sous debian et pas sous gentoo Smile
Répondre
#7
après multiples recompilation ( non gentoo ), toujours la même erreur Sad
la colère en moi, monter je sens....Angry
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

A propos de Communauté francophone RPi

Communauté francophone RPi est un forum d'aide et de partage autour du Raspberry Pi et des micro-ordinateurs.