Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

problème de boot sur un raspberry pi 2
#1

Bonjour,
j'ai un raspberry pi 2 et j'ai modifié les paramètre de RAM allouant 16Mo de RAM pour la partie graphique et depuis je ne peux plus allumer mon raspberry pi en interface graphique.
J'ai essayer de reformater la micro SD mais sa n'a servi à rien.
J'ai vu la commande : "sudo raspi-config" mais elle ne marche pas (comme n'importe quel commande sudo).

J'aimerais savoir comment modifié les paramètres (en commandes) pour pouvoir de nouveau utilisé mon raspberry pi.

merci d'avance.
Rémi
Répondre
#2

remid9 a écrit :Bonjour,
j'ai un raspberry pi 2 et j'ai modifié les paramètre de RAM allouant 16Mo de RAM pour la partie graphique et depuis je ne peux plus allumer mon raspberry pi en interface graphique.
J'ai essayer de reformater la micro SD mais sa n'a servi à rien.
J'ai vu la commande : "sudo raspi-config" mais elle ne marche pas (comme n'importe quel commande sudo).

J'aimerais savoir comment modifié les paramètres (en commandes) pour pouvoir de nouveau utilisé mon raspberry pi.

merci d'avance.
Rémi

Salut,
Y a t-il plusieurs partitions sur la micro sd ?
Si tu as à plusieurs partitions utilise l'application bootice (disponible en archive) pour les supprimées et re formater la micro sd (qui n'aura plus qu'une seule partition)

1- Parts Manage
2- Reformat USB Disk
3- Single Partition
Répondre
#3

Justement je n'ai qu'une seul partition
Répondre
#4

remid9 a écrit :Justement je n'ai qu'une seul partition

Quel logiciel de formatage utilises-tu ?
Répondre
#5

J'utilise SD formatter mais j'ai eu "bug" depuis que je n'ai alloué que 16Mo de RAM à la partie graphique (avant sa marché parfaitement)
Répondre
#6

remid9 a écrit :J'utilise SD formatter mais j'ai eu "bug" depuis que je n'ai alloué que 16Mo de RAM à la partie graphique (avant sa marché parfaitement)

OK, je ne sais pas, essaye avec bootice peut etre Big Grin
Répondre
#7

J'ai essayé mais sa à fait exactement la même chose.
Dommage mais c'était une bonne idée
Répondre
#8

La configuration se fait dans le fichier config.txt à la racine de la partition d'environ 50Mo en FAT32 (le reste de la carte est en principe réservé en ext4)

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#9

@rlinete : je ne vois pas le rapport. Tu peux expliquer ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#10

Reformater ta carte et réinstaller Noobs te remet complètement à 0.
Si ça ne fonctionne pas, c'est que tas carte micro SD doit avoir un problème (ou alors ton Raspberry).

A ta place j'essayerai avec une carte micro SD neuve et une nouvelle installation complète de noobs.

A noter : j'ai déjà alloué, pour essayer, 16 Mo de mémoire à la partie graphique, sans que cela ne génère la moindre perturbation de démarrage et de fonctionnement de mon Raspberry.
Le problème me semble donc être ailleurs ....
Répondre
#11

ERRATUM, ce que j'ai déjà fait, c'est d'augmenter la quantité de mémoire utilisée par le GPU, pas la diminuer. Donc, je ne sais pas, mais je continue de penser que repartir à 0 doit forcément régler le problème.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)