Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

problème avec apt-get update ...
#1

Bonjour à tous,
j'ai fait l'acquisition d'un raspberry pi B (sous Raspbian) il y'a 1 mois de cela , je m'amuse bien avec ! seulement j'ai un problème en ce moment.
de puis le jour ou on est passé à l'heure d'été, je n'arrive plus à faire d'apt-get update.

lorsque je le lance, j'ai un message d'erreur et je reste bloqué à 4%

Err http://archive.raspberrypi.org wheezy/main armhf Packages
Quelque chose d'imprévisible est survenu lors de la détermination de « archive.raspberrypi.org:http » (-5 - Aucune adresse associée avec le nom de l'hôte)


En effet , avec la commande "date" je constate que mon raspberry n'a pas la bonne date (2 jours de retard) ni la bonne heure (1h30 environ de retard),,,
j'imagine que ça peut etre dû à ça. problème de synchro ou un truc du genre.
Quelqu'un a t-il déjà eu ce problème ? Ou il y'a t-il une solution pour synchroniser son heure avec une horloge exterieur ??

(sachant que les commande "apt-get install" ne fonctionne pas non plus et que du coup la commande "apt-get install ntpdate" ne peut pas se faire non plus...)

merci d'avance !
Répondre
#2

Essaye de télécharger le paquet sous format .deb (http://pkgs.org/download/ntpdate), de l'envoyer sur le Raspberry et de l'installer via la commande dpkg

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#3

Salut,

Peut-être en réglant manuellement la date et l'heure et refaire un apt-get update après ?
Répondre
#4

J'aimerai bien le faire mais la seule option que j'ai trouvé pour régler l'heure manuellement , c'est la commande ntpdate... je vais essayer ta technique manuelle ce soir Chris , je préviendrai si ca fonctionne . Merci .

PS: via le panneau raspi-config, j'ai beau me mettre sur le fuseau horaire de paris, il reste a coté de la plaque ...
Répondre
#5

Et avec çà :
https://wiki.debian.org/DateTime#Set_the_time_manually
Répondre
#6

haaa! ça m'énerve !!
J'ai réussis à set ma date et mon heure parfaitement. Mais ce n'est visiblement pas la source de mon problème ...
J'ai déja édité plusieurs fois mon interface (dans le dossier Network ) pour me fixer une IP static. j'ai lu pas mal de truc par rapport à la config de tout ça , ça reste toujours legerement obscure pour moi...
Mais je présage que j'ai un problème avec ma Gateway. 9a a dû changé , (ou pas) et je ne sais pas comment je peut le retrouver.
Meme avec un ifconfig, je ne le trouve pas ...

Voici le contenu de mon "etc/network/interfaces"

Citation :auto lo

iface lo inet loopback
iface eth0 inet static

address 192.168.0.15
netmask 255.255.255.0
gateway 192.168.0.1

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
Sachant que j'ai un FreeBox V6 et que l'interface de celle ci est vraiment trééés limitée

De plus en lançant Midori avec mon "startx" (vous comprendrez) je n'arrive pas a afficher la moindre page web. Aucune connection ! Need help. je suis dépité :/
Répondre
#7

Les DNS.... Wink Smile

A mon avis, ton RPi ne résoud pas les noms de domaine !
Fais un :

Code :
[== Indéfini ==]
cat /etc/resolv.conf

Logiquement, tu devrais retrouver l'@ IP de ta box, ainsi qu'éventuellement ceux de ton FAI si tu les as renseignés (pour Free : 212.27.40.240 par exemple)
Heu d'ailleurs, pour une Freebox, c'est normal l'@ IP en 192.168.0.1 ? Ils l'ont changé ? ce n'est plus 192.168.0.254 ? (à moins que ce ne soit toi qui ais choisi cet adressage) -> enfin moi, c'est une v.5, pas v.6, donc c'est peut être comme ça avec la Freebox Revolution... Rolleyes

Si ce n'est pas le cas, tu reédites ton fichier /etc/network/interfaces, et tu y rajoutes la ligne suivante à la suite de l'@ IP et gateway :
Code :
[== Indéfini ==]
dns-nameservers 192.168.0.1 212.27.40.240

Un petit restart du service réseau
Code :
[== Indéfini ==]
sudo service networking restart
et tu devrais pouvoir de nouveau surfer et faire tes mises à jour... (normalement) Wink


EDIT : ah et puis, vu qu'apparemment tu te connectes par câble, je supprimerais le bloc relatif à la config Wifi : ce serait plus "propre" et éviterait d'éventuels conflits.
Répondre
#8

labelette a écrit :Err http://archive.raspberrypi.org wheezy/main armhf Packages
Quelque chose d'imprévisible est survenu lors de la détermination de « archive.raspberrypi.org:http » (-5 - Aucune adresse associée avec le nom de l'hôte)

Je te confirme que ce nom n'existe pas (aujroud'hui).
Tu ne peux donc pas mettre à jour avec le contenu de ton fichier /etc/apt/sources.list

Citation :$ dig archive.raspberrypi.org +short
$


Met dans ce fichier par exemple:
Citation :deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi
deb-src http://archive.raspbian.org/raspbian wheezy main contrib non-free rpi

Puis relance un sudo apt-get update

Citation :$ dig mirrordirector.raspbian.org +short
5.153.225.207
$



Je te confirme également le l'heure systeme, et les mises a jour n'ont pas de rapport.
Répondre
#9

Merci pour votre spontanéité et les réponse si rapide ,c'est vraiment cool ! je vais tenter de faire tout ca ce soir.
Pour la sources.list, je l'ai modifié en rajoutant des sources supplémentaires, croyant que la seule qui y était par défaut , était HS. Mais ça n'as rien changé...

Je vais prendre les sources que tu cite UGGY Wink
Répondre
#10

Bon, pour les sources, j'ai changé, j'ai mis ce que tu m'as conseillé de mettre Uggy, mais je reste bloqué au même endroit.

Hawkeye, J'ai essayé de changé ma conf interface, et ca fait planter mon raspberry... (timeOut
Code :
[== Indéfini ==]
Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
Reconfiguring network interfaces...RTNETLINK answers: No such process
Read from remote host 192.168.0.15: Operation timed out
Connection to 192.168.0.15 closed.
__________________________________

avec la commande
Code :
[== Indéfini ==]
cat /etc/resolv.conf
J'obtiens
Code :
[== Indéfini ==]
nameserver 212.27.40.240
nameserver 212.27.40.241

Je pense en effet que mon probleme viens de mon network/interfaces ... mais je ne vois pas quoi rajouter de plus...

est-ce normal qu'il y ai deux IP diffrente sur la meme ligne dans ce que tu me conseil de mettre

"dns-nameservers 192.168.0.1 212.27.40.240"
??

Quelqu'un aurai une idée d'un commande qui remet par défaut les parametre des networks ?

(quand ce sera fait, je pourrais tester un apt-get avec les nouvelles sources. )

Merci a vous
Répondre
#11

WHOOOHOOOO je vous aime !
En alliant les conseils de chacun de vous , et en rebootant une bonne fois pour toute mon raspi, j'ai pu ENFIN faire mon update, ca fonctionne de nouveau !! Vous allez ensoleiller mon week end Big Grin
Merci encore Tongue
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)