Raspberry Pi :: Communauté francophone
[Help] MCP3008 ne délivre rien. - Version imprimable

+- Raspberry Pi :: Communauté francophone (https://forum.raspfr.org)
+-- Forum : Rapsberry Pi (https://forum.raspfr.org/forumdisplay.php?fid=3)
+--- Forum : Matériel (https://forum.raspfr.org/forumdisplay.php?fid=14)
+--- Sujet : [Help] MCP3008 ne délivre rien. (/showthread.php?tid=2809)



MCP3008 ne délivre rien. - MattTheDrummer - 27-02-2022

Bonjour à tous, 
Je suis étudiant en 2ème année de CPGE scientifique et dans le cadre de mes TIPE qui portent sur la turbidimétrie, j'utilise une raspberry pi 3B et un MCP3008, car mon turbidimètre renvoie un signal analogique. Seulement voilà, lorsque j'effectue les tests avec les programmes python d'Adafruit, même en mettant du 3,3 V sur un des channels du MCP, voici ce que ça me renvoie :
 | 1023 | 1023 | 1023 | 1023 |    0 |    0 |    0 |    0 |
|    0 |    0 |    0 |    0 |    0 |    0 |    0 | 1023 |
| 1023 | 1023 | 1023 | 1023 | 1023 |    0 |    0 |    0 |
|    0 |    0 |    0 |    0 |    0 |    0 |    0 |    0 |
|    0 | 1023 | 1023 | 1023 | 1023 | 1023 | 1023 | 1023 |

Tout ça à l'infini. Je peux même enlever le MCP ça ne change rien, comme s'il n'existait pas. J'ai pourtant vérifié plusieurs fois mes branchements et j'
ai exactement les mêmes que sur le site d'Adafruit.
Est-ce le MCP3008 qui est défaillant ? Les ports GPIO ? Moi-même qui m'y prend mal ? Comment puis-je tester la fonctionnalité des composants ? 
Merci infiniment pour vos réponses !