Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

nginx et erreur 404
#1

Bonjour,
me revoilà avec mes questions "newbie", désolé :8
J'ai installé nginx suivant le wiki ici mais quand je tente d’accéder à une page qui n'existe pas j'ai droit à la page Welcome to nginx!
Voici le fichier que j'ai mis dans /etc/nginx/sites-available/ et que j'ai lié dans /etc/nginx/sites-enabled/ :

Code :
[== Indéfini ==]
[email protected] /etc/nginx/sites-enabled $ ls -l
total 0
lrwxrwxrwx 1 root root 36 mai   19 18:04 firstSite -> /etc/nginx/sites-available/firstSite
Code :
[== Indéfini ==]
server {
        listen 80;
        root /usr/share/nginx/www;
        index index.php index.html index.htm;
        server_name raspweb;
        location / {
                try_files $uri $uri/ /index.html;
        }

        location ~ \.php$ {
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;
        }
}
j'ai créé une page toute bête 404.html que j'ai mis dans /usr/share/nginx/www puis
j'ai rajouté la ligne "error_page 404 /usr/share/nginx/www/404.html;" dans le fichier de conf
mais quel que soit l'endroit où je la mets je n'ai pas l'affichage de la page d'erreur. Quelle est ma boulette ?
Répondre
#2

Essayes ceci :

Code :
server {
        listen 80;
        root /usr/share/nginx/www;
        index index.php index.html index.htm;
        server_name raspweb;
        error_page   404  =  /404.html;
        location / {
                try_files $uri $uri/ /index.html;
        }

        location ~ \.php$ {
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;
        }
}
Répondre
#3

Jeoffrey : +1

Les pages dans le fichier de configuration doivent avoir leur URL et non leur chemin sur le filesytem. Nginx utilise comme base la valeur dans la définition root.

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#4

j'ai du rater un truc, voilà ce que j'ai fais sans succès :
Code :
[== Indéfini ==]
[email protected] /usr/share/nginx/www $ cat /etc/nginx/sites-available/firstSite
server {
        listen 80;
        root /usr/share/nginx/www;
        index index.php index.html index.htm;
        server_name raspweb;
        error_page 404   /404.html;
        location / {
                try_files $uri $uri/ /index.html;
        }

        location ~ \.php$ {
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;
        }
}
[email protected] /usr/share/nginx/www $
[email protected] /usr/share/nginx/www $
[email protected] /usr/share/nginx/www $ sudo /etc/init.d/nginx restart
Restarting nginx: nginx.
[email protected] /usr/share/nginx/www $
Je ne sais pas trop où chercher, j'ai trouvé cela dans /var/log/nginx/access.log :
Code :
[== Indéfini ==]
192.168.0.4 - - [12/Jun/2014:09:30:33 +0200] "GET /trtreterte HTTP/1.1" 200 133 "-" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36"
mais je ne vois pas de log erreur 404 ...

[edit]
apparemment les erreurs devraient se retrouver dans le fichier error.log mais ce fichier est vide ...
Code :
[== Indéfini ==]
[email protected] /usr/share/nginx/www $ sudo ls -l /var/log/nginx/error.log
-rw-r----- 1 www-data adm 0 juin  12 06:25 /var/log/nginx/error.log
[email protected] /usr/share/nginx/www $
Répondre
#5

Tu travailles sur le fichier /etc/nginx/sites-available/firstSite
Tu es certain que tu l'as bien lié dans le répertoire /etc/nginx/sites-enabled ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#6

je pense :
Code :
[== Indéfini ==]
[email protected] /usr/share/nginx/www $ cd /etc/nginx/sites-enabled
[email protected] /etc/nginx/sites-enabled $ ls -l
total 0
lrwxrwxrwx 1 root root 36 mai   19 18:04 firstSite -> /etc/nginx/sites-available/firstSite
[email protected] /etc/nginx/sites-enabled $
Répondre
#7

Quel est l'affichage dans le navigateur lorsque l'URL est fausse ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#8

j'ai le welcome nginx! :
Par exemple si je demande http://192.168.0.252:65430/taratatata qui n'existe pas (je suis depuis l'exterieur d'où le :65430, j'ai changé l'@ IP de l'URL pour ne pas afficher mon @ publique en texte. Le port 65430 est redirigé vers le port 80 du raspberry).
[Image: mini_329449Sanstitre.jpg]

et je vois bien l'url taratatata demandé dans le log d'erreur :
Code :
[== Indéfini ==]
[email protected] ~ $ sudo tail -f /var/log/nginx/access.log
192.168.0.4 - - [12/Jun/2014:14:08:04 +0200] "GET /taratatata HTTP/1.1" 304 0 "-" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36"
^[email protected] ~ $ ^C
J'espère ne pas me tromper dans le code erreur : pour une adresse qui n'existe pas, le serveur devrait bien renvoyer une erreur 404 ?
Répondre
#9

bon, dans /etc/nginx/sites-available/ jai supprimé le lien vers firstSite puis mis un lien vers le fichier default dans lequel j'ai mis root /usr/share/nginx/www;
mais toujours la même chose, pas de message d'erreur. En soi ca ne me dérange pas mais ce n'est pas un comportement normal qui pourrait peut être cacher un pb ?
Répondre
#10

Nginx sait gérer les erreurs HTTP donc ça n'est pas normal. Le fichier par défaut lors de l'install fait cette gestion. J'essaye de regarder ce soir

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#11

Le serveur réponds 304. Peut-être devrais-tu commencer par effacer l'historique de ton navigateur.

Cool
Répondre
#12

Désolé rien n'y a fait : j'ai effacé le cache, l'historique, changé de navigateur, rien n'y fait il me renvoie tjs vers le welcome grrr.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)