Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

mauvaise configuration de ma cle wifi edimax
#1

bonsoir je debute dans l'univers du raspi et malheureusement j'ai du mal configurer les entrées de connections
je ne vois pas apparaitre ma cle wifi dans le menu internet comme cela devrait semble t'il se faire.
j'arrive a me connecter en ethernet mais pas du tout avec la cle wifi
j'ai noté quelques messages qui ont l'air d'etre lié a cette anomalie au demarage du raspberry avec failed en rouge qui m'a interpellé
j'ai noté:
not running dhcpcd because /etc/network/interfaces ....failed
defines some interfaces that will use a dhcp client .....failed
[warn] kernel lacks cgroups or memory controller not availlable not stoking cgroups......warning
[warn] start par Confusedervies skipped program is not configured:dhcp.....warning

quelqu'un peut il m'eclairer sur ces messages et la conduite a tenir svp merci
#2

Bonjour,

Je ne suis pas assez compétent pour comprendre ces messages d'erreur
En revanche, pour la Clé EDIMAX, normalement tu n'as rien à configurer
Tu la connectes, tu allumes ton Raspberry, tu cliques sur l'icône de réseau en haut à droite de la barre de tâches de ton bureau
Là, tu choisis wlan et tu entres ta clé WPA (attention, ça ne marche plus avec un code WEP, il faut que tu configures ton réseau en WPA, ce qui t'apporte une bien meilleure sécurité - paraît-il)
Donc si ton réseau Wifi est protégé par une clé WEP, il faut que tu le modifies pour le passer en WPA.
... Après l'accès à ton réseau Wifi se fait directement, sans autre manoeuvre paticulière (avec une clé EDIMAX).

Je te propose de reprendre une nouvelle carte mico SD et de repartir de 0 sur cette nouvelle carte, ça te donera un système sain et sans alertes au démarrage et te permettra d'avoir une seconde carte en dépannage ...
#3

Peux-tu copier ton /etc/network/interfaces ici ?
#4

pour tes fail, le pi demarre un serveur dhcp et un client !
mais ton pi n'est pas un serveur .

en ssh ou par un clavier relié au pi :

Code :
[== Indéfini ==]
[email protected] ~ $ dpkg -l | grep dhcp
ii  dhcpcd5                               6.7.1-1+rpi1                            armhf        DHCPv4, IPv6RA and DHCPv6 client with IPv4LL support
ii  isc-dhcp-client                       4.2.2.dfsg.1-5+deb70u8                  armhf        ISC DHCP client
ii  isc-dhcp-common                       4.2.2.dfsg.1-5+deb70u8                  armhf        common files used by all the isc-dhcp* packages

si tu as bien le dhcpcd5 alors

Code :
[== Indéfini ==]
[email protected] ~ $ sudo update-rc.d isc-dhcp-server disable
update-rc.d: using dependency based boot sequencing
update-rc.d: error: cannot find a LSB script for isc-dhcp-server
[email protected]berrypi ~ $ sudo reboot

si tes fail persistent alors :

Code :
[== Indéfini ==]
[email protected] ~ $ sudo update-rc.d -f dhcpcd remove
update-rc.d: using dependency based boot sequencing
[email protected] ~ $ sudo reboot

rien a voir avec ta connection wifi .


Pour le wifi ( comme je n'utilise pas le pi en X ) j'ai 2 fichiers :

Code :
[== Indéfini ==]
/etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

et

Code :
[== Indéfini ==]
/etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="mon ssid"
    psk="ma clé secrete"
}


pour voir si ta connection est okay :
Code :
[== Indéfini ==]

[email protected] ~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:4a:07:d7  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:6288 (6.1 KiB)  TX bytes:6288 (6.1 KiB)

wlan0     Link encap:Ethernet  HWaddr 28:10:7b:bd:e0:29  
          inet adr:192.168.1.149  Bcast:192.168.1.255  Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:295778 errors:0 dropped:77737 overruns:0 frame:0
          TX packets:294336 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:379195309 (361.6 MiB)  TX bytes:28719947 (27.3 MiB)
#5

merci pour votre aide en tapant la ligne sudo update-rc.d -f dhcpcd remove comme proposé je n'ai plus de fail je n'ai plus qu'un message [warn] kernel lacks cgroups or memory controller not availlable not stoking cgroups......warning
donc c'est déja ca de reparer
je ne vois toujours pas apparaitre ma cle edimax dans le menu deroulant par contre quand elle est installer et que je veux demarer internet avec le cable ethernet et bien ca ne marche pas je dois absolument enlever la cle pour acces a internet via le cable
#6

concernant ma connection ifconfig me donne ceci
eth0 Link encap:Ethernet HWaddr b8:27:eb:e5:9d:81
inet adr:192.168.0.14 Bcast:192.168.0.255 Masque:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:542 errors:0 dropped:0 overruns:0 frame:0
TX packets:225 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:182910 (178.6 KiB) TX bytes:29757 (29.0 KiB)

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:40 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:3696 (3.6 KiB) TX bytes:3696 (3.6 KiB)
#7

ton /etc/network/interfaces ?
ton /etc/wpa_supplicant/wpa_supplicant.conf
et la commande lsusb ?
#8

[email protected] ~ $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0461:0010 Primax Electronics, Ltd HP Keyboard
Bus 001 Device 005: ID 045e:00d2 Microsoft Corp.
[email protected] ~ $
par contre je n'arrive pas a acceder a
ton /etc/network/interfaces ?
ton /etc/wpa_supplicant/wpa_supplicant.conf
comment avoir ses infos
#9

D’après ton lsusb ça pue !! ta clé est pas vu du tout !
voici le mien ou tu voies clairement la clé :

[email protected]:~ $ lsusb
Bus 001 Device 006: ID 07d1:3303 D-Link System DWA-131 802.11n Wireless N Nano Adapter(rev.A1) [Realtek RTL8192SU] <-- clé
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver <--- clavier
Bus 001 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode) <--- dongle bluetooth
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter <--- RJ
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. <---bus
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub <--- hub usb

pour le reste :

nano /etc/wpa_supplicant/wpa_supplicant.conf
nano /etc/network/interfaces

Mais de toute manière ta clé est crevée ...
#10

la clé n'est pas connecte quand j'ai taper la commande puisque je n'ai pas acces a internet avec cette derniere dois je l'installer et relancer la commande lsusb ?
#11

bah oui, c'est pour savoir si elle est bien reconnue !
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)