Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

make: *** Pas de cibles spécifiées et aucun makefile n'a été trouvé.
#1

J'ai voulu installer SuperTux sur mon raspberry pi, en suivant http://framboisepi.fr/supertux/
Mais au "make", j'ai le message suivant :
Code :
[== Indéfini ==]

[email protected] ~ $ cd /home/pi/Documents/Jeux/SUPERTUX/supertux-0.1.3
[email protected] ~/Documents/Jeux/SUPERTUX/supertux-0.1.3 $ ./configure --disable-opengl
checking build system type... armv6l-unknown-linux-gnu
checking host system type... armv6l-unknown-linux-gnu
checking target system type... armv6l-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for a BSD-compatible install... /usr/bin/install -c
checking for dirent.h that defines DIR... yes
checking for library containing opendir... none required
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for unistd.h... (cached) yes
checking for an ANSI C-conforming const... yes
checking for gprof mode... disabled
checking for debug mode... disabled
checking wether OpenGL should be used... no
checking for sdl-config... /usr/bin/sdl-config
checking for SDL - version >= 1.2.4... yes
checking for Mix_OpenAudio in -lSDL_mixer... no
configure: error: SDL_mixer library required
[email protected] ~/Documents/Jeux/SUPERTUX/supertux-0.1.3 $ make
make: *** Pas de cibles spécifiées et aucun makefile n'a été trouvé. Arrêt.
[email protected] ~/Documents/Jeux/SUPERTUX/supertux-0.1.3 $


Le sujet à peut-être déjà été traité, mais je n'ai pas trouvé d'infos sur Internet, alors je me tourne vers vous.

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#2

pi35 a écrit :
Code :
checking for Mix_OpenAudio in -lSDL_mixer... no
configure: error: SDL_mixer library required

Il te manque une librairie.
#3

Je vais essayer sudo apt-get install libsdl-mixer1.2-dev. Merci de ton aide. En revenche, j'ai une autre question pour toi. J'ai suivi ton tuto pour changer le nom du raspberry, mais cela n'a pas marché (alors que sous mon ancienne config, je l'avais changé). Connais-tu l'origine du problème ???

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#4

pi35 a écrit :Je vais essayer sudo apt-get install libsdl-mixer1.2-dev. Merci de ton aide.

Yep, c'est la commande à faire ;-)
#5

pi35 a écrit :mais cela n'a pas marché
Il y a une erreur en particuliere ?
Il faut un reboot pour prendre en compte la config'.
#6

Je ne sais pas, mais j'ai également un problème avec l'IP statique. Pas de problème detecté avec ifconfig, mais les pages web ne s'affichent pas. Je suis actuellement revenu en DHCP, mais j'aurais bien voulus passer en ip statique, ou alors passer par un DNS.

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#7

Après avoir testé sudo apt-get install libsdl-mixer1.2-dev, j'ai la facheuse surprise que le problème n'a pas disparu. j'ai maintenant droit à un
Code :
[== Indéfini ==]
checking for IMG_Load in -lSDL_image... no
configure: error: SDL_image library required

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#8

pi35 a écrit :
Code :
checking for IMG_Load in -lSDL_image... no
configure: error: SDL_image library required

Faire la même commande que précédemment mais avec la librairie sus-nommé.
#9

Tu as eu la réponse sur le forum officiel : lib sdl *
Comme je te l'ai dit regarde sur le site officiel où tu as téléchargé ton source, il doit y avoir la liste des "requirements", ce dont tu as besoin avant de compiler.

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
#10

OK, merci bien Smile

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)