Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[Résolu] lancer un vpn au démarrage
#1

Bonjour,

Je profite de mon confinement pour mettre un VPN sur ma framboise.
J'ai suivi le tuto sur nordvpn (merci nota bene) pour installer openvpn et se connecter au serveur.
Tous fonctionne très bien et j'aimerai passer à l'étape n°2.

Cela consistera à lancer le vpn automatiquement au démarrage sans que je n'ai besoin d'intervenir (je suis feignant Angel ).

Honnêtement j'ai ma petite idée mais je veux votre avis car je n'ai rien trouvé sur la toile.
Voici l'idée (du siècle?):

je programme un script qui:
                                 - lance le terminal 
                                 - lance openvpn #attendre réponse
                                 - se connecte au serveur choisi #attendre réponse
                                 - renseigner mon identifiant Nordvpn
                                 - renseigner mon mdp Nordvpn

quand c'est fais il faut que ce script se lance automatiquement à chaque boot.

Voilà si vous avez un avis sur mon projet et sa faisabilité car je ne connaît pas vraiment la programmation ainsi qu'un petit coup de main surtout pour programmer...

Merci de votre lecture et restez chez vous Cool
Répondre
#2

Si c'est un openvpn, je pense que ce tutoriel (en anglais) est plutôt bien fait.
Sinon il y a celui-ci (en français) qui est bien plus simple (peut-être à tester en premier)
Répondre
#3

Merci, je n''avais pas vu ces 2 sujets sur mon moteur de recherche!
Je vais tester le tuto de makoto et je te redis  Smile
Répondre
#4

Re!

Du coup j'ai été sur le tuto de l'anglais ( https://www.smarthomebeginner.com/guide-...art-linux/ ) car le français je n'arrive pas à passer la première étape...
Mais là je suis bloqué depuis un moment sur l'étape "Enabling the Linux OpenVPN autostart service"

Je rentre les deux premières commandes au fur et à mesure  mais je n'ai pas de message de la console qui apparaît contrairement à ce que me dis le tuto...
et quand je passe à l'étape d'après j'ai un message d'erreur...je te laisse un screen shot pour que ça te parle plus...


Pièces jointes Miniature(s)
       
Répondre
#5

Est-ce que tu as bien créé le fichier nordvpn dans /etc/init.d/ (à l'étape où il est dit de faire nano /etc/init.d/youVpnProvider, et la suite) ?

Tu peux essayer de faire sudo /etc/init.d/nordvpn start pour voir si tu as une erreur (peut-être que le fichier n'est pas exécutable).
Répondre
#6

Dans la partie automatic connection :

j'ai tapé les 2 premières commandes...ça fonctionne car je constate que mon ip internet change
   
   
   

Et ensuite j'ouvre un nouveau terminal pour faire la seconde ligne.
.pdf script.pdf Taille : 27.8 Ko  Téléchargements : 3


Donc quand je tape nano /etc/init.d/nordvpn ça me donne ceci:
   

Et quand je tape sudo /etc/init.d/nordvpn start :

Et quand je tape sudo /etc/init.d/nordvpn start :

   
Répondre
#7

Essaye un petit sudo chmod 755 /etc/init.d/nordvpn.
Le fichier n'est pas créé avec les droits d'exécution par défaut.
Répondre
#8

ça fonctionne! Merci beaucoup pour ton aide car sans toi j'y serais encore ou pire j'aurais laissé tombé!
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)