Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

ip statiques en eth0 et wlan0
#1

Bonjour à tous , j'ai configuré des ip statiques tant sur eth0 que sur wlan0.....ma liaison en eth0 sur ma freebox fonctionne très bien ....ma liaison wlan0 semble marcher sur mon réseau local privé "wlan0:Associated with XXXXXX" wlan0: Configured 192.168.0.xxx" ......puis "wlan0: Expired 192.168.0.xxx" et "wlan0: Disassociated from XXXXXX" au bout de quelque secondes...pourtant pas le moindre ping possible par wlan0.....j'y perd le peu de latin que je n'avais pas!
Si je pouvais avoir l'aide de quelcun.....merci d'avance ?
Répondre
#2

Problème de gateway ? Est-ce qu'il n'y a pas une tentative d'attendre la gateway du réseau, qui n'est pas trouvée et du coup se déconnecte ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#3

Merci pour votre réponse rapide Chris ....sur le réseau eth0 le routeur cest ma freebox en ....0.254 et là ça marche mais pour le résau wifi j'ai un routeur en ...0.253 et là quand je passe la souris sur l'icone réseau il m'indique bien que tout est correct (depuis hier et aprés modification du wpa_supplicant.conf) je n'ai plus la deconnexion....mais toujours pas d'acces au wifi....pas de ping possible .....wlan0:Associated with XXXXX
wlan0:Configured 192.168.0.54/24

je n'y comprend rien...

Amitiés
Répondre
#4

L'ethernet et le wifi sont bien sur des reseaux differents d'un point de vu IP ?
Peux tu faire un shema ou expliquer de nouveau car je comprends ce que tu veux faire. Ton raspberry doit avoir 2 connexions 1 ethernet et 1 wifi mais le ping est fait sur quelle machine ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#5

Bonjour Chris .....j'aurais voulu que mon raspi puisse être vu et activité en temps que serveur par les 2 réseaux....internet sur eth0 et mon réseau local wlan0 (constitué pour l'essentiel de nanostations en réseau radio)....mais pour que le pi soit accessible par le réseau wlan0 il faut que je débranche le eth0......un serveur identique sur un ordinateur sous Windows10 est accessible lui par les 2 voies.
Dans chaque cas les 2 adresses sont sur le même segment 192.168.0.xxx ça marche bien sous Windows mais pas sur raspi...
Quand les 2 interfaces sont actives sur le raspi seule eth0 fonctionne , il faut débrancher eth0 pour que les ping fonctionnent instantanément sur wlan0.
....Le mystère reste entier mais je dois oublier quelque chose d'essentiel .
Amitiés
Répondre
#6

Sans être expert je me demande s'il ne faut pas créer un "bridge" entre les deux interfaces pour que tout communique.
Qu'est ce que la commande ifconfig -a donne ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)