Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

impossible de démarrer Pi 2
#1

Bonjour,

Je suis confronté à un mystère avec le PI 2 900mhz !


J'ai installé wheezy et jusque là pas de problème
J'ai installé un tas de choses et toujours pas de problème
Le Pi 2 a bien fonctionné pendant 15 jours

et puis j'ai eu une coupure de courant

Lorsque le courant est revenu le PI a re-démarré et tout semblait normal
J'ai alors copié un directory de mon ordinateur vers le PI 2 en ftp
Lors du transfert j'ai remarqué que j'avais des coupures et que le transfert se faisait lentement.
J'ai arrêté le transfert et j'ai fait un reboot du PI 2

Et là plus rien ! la diode verte s'allume brièvement une seule fois et puis plus rien ne se passe....

Afin de tester l'alimentation et la carte je les ai utilisées sur un pi B plus que j'ai. Tout fonctionne !

J'ai alors testé la connexion ethernet, j'ai branché le B plus sur le même câble qu'utilisait le PI 2 et aucun problème.

J'ai essayé de re-démarrer le PI 2 avec d'autres SD. Rien à faire :-(

Je me suis alors dit que peut-être qu'il était tout simplement mort et comme ce n'est pas une fortune j'ai commandé un nouveau PI2 qui est arrivé ce matin.

Le mystère s'épaissit, j'ai exactement le même problème avec le nouveau PI 2 !!!

Tout fonctionne bien, alimentation, carte SD, connexion avec mon PI B Plus
rien de tout cela ne fonctionne sur les deux PI2 !!!

Le symptôme est le même sur les deux, la diode verte s'allume brièvement et se rallume encore brièvement et puis clignote très rapidement une ou deux fois et puis plus rien .... ?????

Vraisemblablement il est difficile de penser, quoique possible, que les deux PI 2 sont en panne, ça parait gros d'autant que l'un d'eux est flambant neuf.

Si quelqu'un a une idée elle sera la bienvenue.
#2

Que se passe-t-il à l'écran ?
#3

magnux77 a écrit :Que se passe-t-il à l'écran ?


Bonjour et merci d'avoir répondu,

Il n'y a pas d'écran, je m'y connecte via vnc ou ssh mais pour cela il faut bien sûr qu'il démarre.

Ce truc me rend fou, tout est correct, la carte, l'alimentation et même le câble ethernet mis sur un B plus et tout fonctionne parfaitement, je remplace le B plus par un des deux PI 2 et plus rien ne marche !
j'ai essayé avec d'autres cartes SD mais même résultat.

J'ai aussi essayé de remplacer le bootcode.bin ayant lu que parfois il pose des problèmes, j'ai téléchargé celui recommandé dans ce cas mais aucun résultat sinon que la led verte est restée allumée sans plus :-(

Ceci dit vous me donnez une idée, je vais essayer de le connecter à un écran hdmi, on ne sait jamais des fois qu'il attendrait bêtement un appui de touche ou donnerait un message d'erreur mais j'en doute fort.
#4

J'ai donc suivi l'idée de le connecter à un écran hdmi et j'ai reçu une bordée d'insultes....

Voici ce que ça donne
http://www.cjoint.com/c/EHBoHQu2YCl

C'est quand même très curieux puisque la même SD démarre sans problème sur le B plus

Là je vais essayer de préparer une SD contenant l'image originale raspbian wheezy du site raspberry, je reviendrai donner le résultat
#5

on4kde a écrit :J'ai donc suivi l'idée de le connecter à un écran hdmi et j'ai reçu une bordée d'insultes....

Voici ce que ça donne
http://www.cjoint.com/c/EHBoHQu2YCl

C'est quand même très curieux puisque la même SD démarre sans problème sur le B plus

Là je vais essayer de préparer une SD contenant l'image originale raspbian wheezy du site raspberry, je reviendrai donner le résultat



J'ai préparé une carte SD avec l'image originale comme dit ci-dessus ... et ... le PI 2 a démarré !

Ouf ça me soulage quand même un peu de savoir qu'il n'est pas en panne. Votre idée de l'écran m'a aidé.

Maintenant je reste quand même dans le problème vu que ma carte orginale (celle qui contient mes programmes et installations) ne démarre pas ni les backups que j'en ai fait !
#6

gare au backup ...
#7

[email protected] a écrit :gare au backup ...


Cela ça me tracasse encore plus, j'ai 4 backups et aucun ne fonctionne et pourtant lorsque je les ai faits le Pi2 fonctionnait bien et démarrait sur la carte sd sans aucun problème :-(

Actuellement le PI 2 démarre sur la carte que j'ai préparée avec l'image téléchargée sur le site de raspberry mais il ne démarre toujours pas avec mes autres cartes qui pourtant ne posent aucun problème sur B Plus.

Je n'arrive pas à comprendre ce truc là.
#8

il m'est arrivé d'avoir des images foirées sur lequel mon rp2 ne fonctionnait pas ...
J'ai reconstruit ma sd et aucun pb ..
#9

on4kde a écrit :Bonjour,

Je suis confronté à un mystère avec le PI 2 900mhz !

... >8

Si quelqu'un a une idée elle sera la bienvenue.


Bonjour,

Je reviens vers vous pour vous donner des nouvelles, ça peut éventuellement servir à quelqu'un d'autre.

Après avoir passé des heures sur les forums anglophones voici ce que j'en ai tiré :

Le PI2 ne peut pas booter sur une carte qui a été préparée avec une version Noobs datant d'avant sa sortie.

Une carte qui fonctionne dans un B Plus ne fonctionnera pas forcément dans un PI 2, tout dépend de la date du système sur la carte.

Pour remédier on peut utiliser sur le B plus équipé de la carte en question :
sudo apt-get update
sudo apt-get upgrade
sudo rpi-update

Ensuite la carte devrait fonctionner dans le PI 2

-------------

Moi c'est un autre problème puisque la carte a bien été préparée avec la nouvelle version et a bien fonctionné pendant un mois.
Actuellement je suis parvenu à démarrer les deux PI 2 avec une nouvelle carte préparée avec le dernier raspbian disponible. C'est déjà un pas, mes PI 2 ne sont pas en panne.

Par contre ils refusent de lire mon ancienne carte et de même pour les backups que j'en avais.

Je suis donc condamné à tout recommencer :-(

Ce qui me tracasse c'est que je n'ai aucune explication. Cela veut donc dire que ça peut recommencer demain...

------------

Ma question maintenant est la suivante : existe-t-il un moyen de récupérer ce que j'avais sur cette carte en la lisant sur un ordi puisque sur PI je ne peux plus.

Pour ceux qui voudraient répondre plus vite que leur ombre, je sais évidemment comme tout quidam qu'on peut lire le directory DOS d'une carte SD venant d'un PI.
Ce que je voudrais c'est la lire comme le fait le PI, voir les répertoires etc... linux ce qui me permettait de copier les fichiers afin de les remettre sur ma nouvelle carte.

Merci d'avance pour toute aide.
#10

tu pourrais peut être essayer un truc ... ( je te dis ca car ca m'est arrivé )
Créer une carte simple raspian, tu installes un truc ou deux bidon ( juste des images dans ton /home/pi/images ).
Tu fais une image de cette carte ( dd if=sdx of=ton_fichier.img )
Puis avec une autre carte tu remets ce fichier ( dd if=ton_fichier.img of=sdx )
Et tu voies .
De mon coté, je ne suis jamais arrivé avec mon pi a le faire demarrer avec mon image sur une autre sd ( même capacité .... )
#11

Pourquoi ne pas lire la carte SD dans le lecteur de cartes d'un quelconque portable sous GNU/Linux ?
#12

magnux77 a écrit :Pourquoi ne pas lire la carte SD dans le lecteur de cartes d'un quelconque portable sous GNU/Linux ?


Si j'avais un ordi sous linux ce serait fait depuis longtemps :-)
#13

j'avais comparé les 2 sd et pas de différence a priori ..
Avec l'une, le pi demarrait, avec l'autre nada ...
#14

on4kde a écrit :
magnux77 a écrit :Pourquoi ne pas lire la carte SD dans le lecteur de cartes d'un quelconque portable sous GNU/Linux ?


Si j'avais un ordi sous linux ce serait fait depuis longtemps :-)
faut pas hésiter ... surtout avec le double démarrage ...
#15

Plus simplement, pour retrouver facilement tes documents, je te proposerais plutôt d'utiliser une Live GNU/Linux. Cela te permettrait de visualiser tes file-systems et tes fichiers très facilement avec le navigateur de fichiers. Une Live GNU/Linux tourne à partir d'un cd ou dvd ou une clé USB et n'installe absolument rien sur ton PC. Personnellement, je te conseille Mageia qui s'adresse aux débutants et est plus respectueuse de ta vie privée que Ubuntu. Tu la télécharges ici, tu la graves, tu rebootes ton PC dessus, tu colles ta carte sd dans le lecteur et roule ma poule...
#16

très bon choix mageia ... hein magnux77 Big Grin
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)