Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

guacamole - invalid login
#1

Bjr à tous,

J'essaye de faire fonctionner guacamole sur raspberry. alors, tomcat fonctionne parfaitement (j'arrive à accéder au port ip:8080) ainsi que guacamole (ip:8080/guacamole). Sauf que quand j'entre mes login il en veut pas et me met "invalid login".

ci dessous mon user-mapping.xml :

Code :
[== XML ==]
<user-mapping>
      
    <authorize username="moi"
           password="mdp">
        <protocol>vnc</protocol>
        <param name="hostname">192.168.0.21</param>
        <param name="port">5900</param>
        <param name="password"></param>
    </authorize>
</user-mapping>

et voici le log :

Code :
[== Java ==]
Jun 03, 2014 9:53:53 AM org.apache.catalina.startup.ClassLoaderFactory validateFile
WARNING: Problem with directory [/usr/share/tomcat6/server/classes], exists: [false], isDirectory: [false], canRead: [false]
Jun 03, 2014 9:53:54 AM org.apache.catalina.startup.ClassLoaderFactory validateFile
WARNING: Problem with directory [/usr/share/tomcat6/server], exists: [false], isDirectory: [false], canRead: [false]
Jun 03, 2014 9:53:55 AM org.apache.catalina.startup.ClassLoaderFactory validateFile
WARNING: Problem with directory [/usr/share/tomcat6/shared/classes], exists: [false], isDirectory: [false], canRead: [false]
Jun 03, 2014 9:53:55 AM org.apache.catalina.startup.ClassLoaderFactory validateFile
WARNING: Problem with directory [/usr/share/tomcat6/shared], exists: [false], isDirectory: [false], canRead: [false]
Jun 03, 2014 9:54:21 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Jun 03, 2014 9:54:21 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 23354 ms
Jun 03, 2014 9:54:23 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jun 03, 2014 9:54:23 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.35
Jun 03, 2014 9:54:23 AM org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor guacamole.xml
Jun 03, 2014 9:54:29 AM org.slf4j.impl.JCLLoggerAdapter error
SEVERE: Unable to load/detect WebSocket support.
net.sourceforge.guacamole.GuacamoleException: /var/lib/guacamole/classpath is not a directory.
    at net.sourceforge.guacamole.net.basic.GuacamoleClassLoader.<init>(GuacamoleClassLoader.java:99)
    at net.sourceforge.guacamole.net.basic.GuacamoleClassLoader.<init>(GuacamoleClassLoader.java:60)

SVP quelqu'un pourrait m'aider ? ou me donner des pistes ?
merci d'avance
Slt
cactus68100
#2

Les logs sont assez clairs, tu as des soucis de dossiers qui n'existent pas... Entre autres.
#3

Ca sent la configuration du classpath mal faite :
Code :
[== Indéfini ==]
net.sourceforge.guacamole.GuacamoleException: /var/lib/guacamole/classpath is not a directory.

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)