Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
dpkg: erreur de traitement du paquet default-java-plugin
#1
Bonjour,
Confused
Suite à installation eclipse CPP j'ai les messages suivants avec "apt-get upgrade"
Il y-a-t-il une solution.
Cordialement.  Huh

Christain

Lecture des listes de paquets…

Construction de l'arbre des dépendances…
Lecture des informations d'état…
Calcul de la mise à jour…
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
12 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
Calcul de la mise à jour…
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
12 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] Paramétrage de ca-certificates-java (20170531+nmu1) ...
Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/server/libjvm.so'.
Please install or use the JRE or JDK that contains these missing components.
dpkg: erreur de traitement du paquet ca-certificates-java (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 4
dpkg: des problèmes de dépendances empêchent la configuration de openjdk-8-jre-headless:armhf :
 openjdk-8-jre-headless:armhf dépend de ca-certificates-java ; cependant :
 Le paquet ca-certificates-java n'est pas encore configuré.

dpkg: erreur de traitement du paquet openjdk-8-jre-headless:armhf (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de openjdk-8-jdk-headless:armhf :
 openjdk-8-jdk-headless:armhf dépend de openjdk-8-jre-headless (= 8u171-b11-1~deb9u1) ; cependant :
 Le paquet openjdk-8-jre-headless:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet openjdk-8-jdk-headless:armhf (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de openjdk-8-jdk:armhf :
 openjdk-8-jdk:armhf dépend de openjdk-8-jdk-headless (= 8u171-b11-1~deb9u1) ; cependant :
 Le paquet openjdk-8-jdk-headless:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet openjdk-8-jdk:armhf (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de openjdk-8-jre:armhf :
 openjdk-8-jre:armhf dépend de openjdk-8-jre-headless (= 8u171-b11-1~deb9u1) ; cependant :
 Le paquet openjdk-8-jre-headless:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet openjdk-8-jre:armhf (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de default-jdk :
 default-jdk dépend de openjdk-8-jdk ; cependant :
 Le paquet openjdk-8-jdk:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet default-jdk (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de default-jre-headless :
 default-jre-headless dépend de openjdk-8-jre-headless ; cependant :
 Le paquet openjdk-8-jre-headless:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet default-jre-headless (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de default-jdk-headless :
 default-jdk-headless dépend de default-jre-headless (= 2:1.8-58+b2) ; cependant :
 Le paquet default-jre-headless n'est pas encore configuré.
 default-jdk-headless dépend de openjdk-8-jdk-headless ; cependant :
 Le paquet openjdk-8-jdk-headless:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet default-jdk-headless (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de icedtea-netx:armhf :
 icedtea-netx:armhf dépend de openjdk-8-jre ; cependant :
 Le paquet openjdk-8-jre:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet icedtea-netx:armhf (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de icedtea-8-plugin:armhf :
 icedtea-8-plugin:armhf dépend de openjdk-8-jre ; cependant :
 Le paquet openjdk-8-jre:armhf n'est pas encore configuré.
 icedtea-8-plugin:armhf dépend de icedtea-netx (= 1.6.2-3.1) ; cependant :
 Le paquet icedtea-netx:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet icedtea-8-plugin:armhf (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de default-jre :
 default-jre dépend de default-jre-headless (= 2:1.8-58+b2) ; cependant :
 Le paquet default-jre-headless n'est pas encore configuré.
 default-jre dépend de openjdk-8-jre ; cependant :
 Le paquet openjdk-8-jre:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet default-jre (--configure) :
 problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de default-java-plugin :
 default-java-plugin dépend de default-jre (= 2:1.8-58+b2) ; cependant :
 Le paquet default-jre n'est pas encore configuré.
 default-java-plugin dépend de icedtea-8-plugin ; cependant :
 Le paquet icedtea-8-plugin:armhf n'est pas encore configuré.

dpkg: erreur de traitement du paquet default-java-plugin (--configure) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour ca-certificates (20161130+nmu1) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...

Error: missing `server' JVM at `/usr/lib/jvm/java-8-openjdk-armhf/jre/lib/arm/server/libjvm.so'.
Please install or use the JRE or JDK that contains these missing components.
E: /etc/ca-certificates/update.d/jks-keystore exited with code 1.
done.
Des erreurs ont été rencontrées pendant l'exécution :
 ca-certificates-java
 openjdk-8-jre-headless:armhf
 openjdk-8-jdk-headless:armhf
 openjdk-8-jdk:armhf
 openjdk-8-jre:armhf
 default-jdk
 default-jre-headless
 default-jdk-headless
 icedtea-netx:armhf
 icedtea-8-plugin:armhf
 default-jre
 default-java-plugin
Répondre
#2
As-tu fait un apt-get update avant de faire l'upgrade ?
Et tu peux aussi tenter de faire un apt-get dist-upgrade (encore une fois, avec un update avant).
Répondre
#3
(05-06-2018, 13:35:36)crazycat a écrit : As-tu fait un apt-get update avant de faire l'upgrade ?
Et tu peux aussi tenter de faire un apt-get dist-upgrade (encore une fois, avec un update avant).

Bonjour crazycat,
Avant l'installation j'ai fait :
sudo apt-get update
sudo apt-get upgrade
et sudo apt-get dist-upgrade

Actuellement :
sudo apt-get update passe sans problème

si je réponds non à
sudo apt-get upgrade

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
12 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] n
Annulation.

si je réponds Oui à
 [i]sudo apt-get upgrade[/i]
J'ai toutes les erreurs (voir message précédent)

Pareil si je fait
[i] [i]sudo apt-get dist-upgrade[/i]
J'ai toutes les erreurs (voir message précédent)[/i]

[i]Je ne sais plus quoi faire.[/i]


Cordialement

Christian
Répondre
#4
Donc, la question suivante est: as-tu installé des packages (comma java ?) à la main plutôt que par apt ?
Tu peux faire un dpkg -a pour tenter une recompilation des packages en faute, mais à mon avis tu devrais virer ceux qui te gênent (apt-get remove --purge paquet) et les réinstaller, voire laisser apt gérer les dépendances.
Répondre
#5
Bonjour, Sad

Merci de vos réponses.

J'ai trouvé enfin la solution sur ce site.

https://raspberrypi.stackexchange.com/qu...-java-8-op

j'ai fait les commandes suivantes :

Code :
sudo apt-get remove openjdk-8-jre-headless openjdk-8-jre
sudo apt-get install ca-certificates-java
sudo apt-get install openjdk-8-jre-headless
sudo apt-get install openjdk-8-jre # Optional, enables Java GUI apps
Code :
sudo apt-get install oracle-java8-jdk

Tout est bon mainetenant.

Cordialement.

Christian Undecided
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

A propos de Communauté francophone RPi

Communauté francophone RPi est un forum d'aide et de partage autour du Raspberry Pi et des micro-ordinateurs.