Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
connexion raspi arduino
#1
Bonjour
J'ai un problème pour connecter un Raspberry pi3B+ avec un Arduino uno par un cable USB.
- coté raspi:
alim 5V 3.0A
le SSH et la liaison série sont enable
câble branché sur port USB
avec la commande "ls /dev/tty*" je vois bien "/dev/ttyACM0"

- Coté Arduino:
outils -->carte = "arduino uno"
outils --> port = seul le port COM1 est visible et impossible à changer (impossible de mettre ttyACM0, il n'existe pas)
Donc la Vérif/compil se passe bien mais le téléversement est en échec.
Si j'installe la carte arduino sur mon PC, la comm devient COM4 et la tout se passe bien.
Qu'est ce qui bloque avec le raspi ?
Merci de votre aide
Cordialement
Répondre
#2
Je pense que tu ne trouveras que des COM sur l'arduino, il n'y a aucune raison pour que tu trouves le même port (tty*) que sur ta framboise.

As tu essayé de suivre ce tutoriel ? L'arduino semble ne connaitre que le serial. Il y a peut-être une étape que tu rates sur la rapsberry pour que le port USB fonctionne proprement.
Répondre
#3
oui j'ai regardé ce tuto.
je n'ai plus qu'un problème de téléchargement (arduino connecté sur raspi).
Je peux télécharger en étant connecté sur un PC (en changeant le port bien sur) et si je reconnecte sur le raspi en COM1 ensuite le test se passe correctement.
Cordialement
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

A propos de Communauté francophone RPi

Communauté francophone RPi est un forum d'aide et de partage autour du Raspberry Pi et des micro-ordinateurs.