Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

blocage du Pi !!
#1

Salut !
Depuis peu, mon Pi déconnait de temps en temps .
Il se plantait grave : plus d’accès ssh / pas de fenêtre graphique ... démarrage a l'arrache
Je l'ai donc configuré pour qu'il démarre en console pour voir ce qu'il disait.
Et, j'arrive là :

[Image: 88618852pi.jpg]


puis c'est tout .
L’accès ssh est okay
Si en ssh je tape un startx okay ...

Une idée ?

dessus, zoneminder , c'est tout .
celui ci fonctionne d'ailleurs très bien .
Répondre
#2

Bonjour,
[email protected] a écrit :...
L’accès ssh est okay
Si en ssh je tape un startx okay ...

Une idée ?

dessus, zoneminder , c'est tout .
celui ci fonctionne d'ailleurs très bien .
Euh, c'est quoi le problème ?!..
- Pas de prompt sur la console ?
- Commande non prise en compte sur la console ?
- Instabilité/Blocage persistant ?
- A compléter
Répondre
#3

le problème :

il reste sur :

My ip adress is 192.168.1.145 ....

Je peux taper ce que je veux, mais ... il s'en fiche ... !

et si l'on peut dire :

- Pas de prompt sur la console
- Commande non prise en compte sur la console
- Instabilité/Blocage persistant
Répondre
#4

Salut,

Il semble quand même se bloquer juste après le démarrage de Zoneminder.
Tu peux faire un contrôle du filesystem sur un ordinateur avec Linux ? Et désactiver le démarrage automatique de Zoneminder (en supprimant le fichier dans la config init.d) ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#5

salut !

Bon, j'avais bien pensé a virer ( déplacer ) le fichier zoneminder du init.d ...
Évidement, plus de zoneminder qui démarre mais toujours pareil ...

Ce qui est drole, si je prend l'option de démarrage en page graphique par le raspi-config, , le bureau se lance bien !
Tout marche ( zoneminder, pcmanfm, epiphany , ... ) jusqu’à ce qu'il se plante ! ( freeze / gele )
J'aimerai bien trouver le pourquoi du comment avant un dd pour ne pas que cela recommence plus tard !...
Répondre
#6

salut,

rien de suspect avec un dmesg?

est-ce que tu arrive à ouvrir une autre console? ctrl+alt+f2 il me semble
Répondre
#7

non, rien de rien ... pas de message nul part ..
J'ai retiré le clavier sans fil, la manette usb .
Le ssh reste okay, je fais tout par mon pc ...
Pas de console par ctrl,...
Répondre
#8

la fin de dmesg :

Code :
[== Indéfini ==]

[    3.104945] usb 1-1.3: new full-speed USB device number 4 using dwc_otg
[    3.224011] usb 1-1.3: New USB device found, idVendor=046d, idProduct=c52b
[    3.234412] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.245136] usb 1-1.3: Product: USB Receiver
[    3.253115] usb 1-1.3: Manufacturer: Logitech
[    3.273101] input: Logitech USB Receiver as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/0003:046D:C52B.0001/input/input0
[    3.345136] udevd[175]: starting version 175
[    3.354743] hid-generic 0003:046D:C52B.0001: input,hidraw0: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-3f980000.usb-1.3/input0
[    3.388758] input: Logitech USB Receiver as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.1/0003:046D:C52B.0002/input/input1
[    3.466001] hid-generic 0003:046D:C52B.0002: input,hiddev0,hidraw1: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-3f980000.usb-1.3/in$
[    3.492789] hid-generic 0003:046D:C52B.0003: hiddev0,hidraw2: USB HID v1.11 Device [Logitech USB Receiver] on usb-3f980000.usb-1.3/input2
[    6.080072] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[    6.350989] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[    7.114507] random: nonblocking pool is initialized
[   11.538433] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   13.270390] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
[   14.852591] cfg80211: Calling CRDA to update world regulatory domain

je suis en rj pas en wifi ...
Répondre
#9

tu dis : Je l'ai donc configuré pour qu'il démarre en console pour voir ce qu'il disait.

quels fichiers as-tu modifié?

qu'y a t-il dans le fichier /etc/securetty?

et verifier dans le /etc/passwd qu'en fin de ligne du user il y ai /bin/bash et pas /bin/false
Répondre
#10

Bon, j'ai ré installé le truc .. et je vais suivre l'affaire .

Pour mieux, m'expliquer sur le probleme precedent, je vais tout dire ...
en 1er lieu, j’étais sur une carte de 8G qui tournait bien ... j'en ai fais une image que j'ai remis sur une 16
en redimensionnant la 16 par la suite !
en 2nd lieu, j'ai eu des pb de nullmailler qui me faisait des erreurs et remplissait le /var/log/
zou, désinstallé .
3 eme lieu, par le raspi-config j'ai demandé a ce que le pi démarre en page graphique / bureau ..
4 eme lieu, j'ai installé pisnes avec quelques rom + une poignée snes usb
jusque là, aucun pb ...
Puis, d'un coup, des freezes du pi ..
J'ai donc fouiné et je me suis dis que le démarrer en texte pour voir si erreur.
et là, je me suis apercu que le pi s'arretait a la ligne " My ip adress .... "

En faite, je voulais pousser le pi a son max pour voir ...
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)