RaspFR :: Forum

Version complète : Problème SqueezePLug et Raspberry B+
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Bonjour,

j'ai depuis 2 jours 2 raspberry B+ que je vais installer et configurer en SqueezeBox.
J'ai téléchargé la dernière version de SqueezePlug ici : http://www.squeezeplug.eu/
puis je copie l'image sur ma carte SD avec win32diskimager.

Une fois un clavier branché en USB ainsi que la sortie HDMI sur mon écran je branche le raspberry et je le vois bien démarrer la phase de boot.

Arrivée au moment de pouvoir saisir le login puis le mot de passe rien ne se passe comme si mon clavier était non reconnu ou désactivé.
Je débranche puis rebranche et regarde un peu la séquence de démarrage et là je me rend compte que tout est bien détecté mais que le raspberry (ou en tout cas la distrib SqueezePlug) désactive tous les ports USB.
Récemment je me me suis même rendu compte qu'il faisait pareil avec la carte réseau.

Du coup je voulais savoir si quelqu'un avait déjà eu ce soucis?
J'ai fait le test avec la dernière version de RaspBian et je n'ai pas eu de soucis donc je dirai que mon problème vient de la distrib SqueezePlug.

Quelqu'un aurait il une solution ou des connaissances qui me permettrait de résoudre ce soucis?

Merci d'avance.
Bonjour à toi,

Je crois que squeezeplug n'est pas construit sur la dernière release de raspbian. Du coup, je crois que le driver qui gère usb/ethernet n'est pas le bon pour le B+. Mais je me souviens plus ou j'ai lu ça...
Peut-être peux-tu malgré tout te connecter en ssh afin de voir les logs : ça doit nécessairement être dedans.

[em]
edit
en même temps, si usb/eth ne fonctionne pas ça va être dur de se connecter via ssh, hein...
[/em]
Je pensais aussi à un soucis de ce genre mais là mes connaissances en la matière atteignent leur limite et je ne vois pas trop comment je vais pouvoir m'en sortir sauf à attendre une nouvelle version?

@gambit : alors rassure toi j'ai passé 4h à scanner mon réseau et à chercher pourquoi je ne trouvais pas mon rasbperry sur mon réseau avant de me rappeler que si le réseau était coupé je ne risquais pas d'avoir une IP...
Big Grin Je suis rassuré!
Il y a un github squeezeplug qui date de mai https://github.com/gabbel/raspberry_pi_squeezeplug.
Ça semble coller, non?
Merci gambit.
Je vais regarder ça se week-end
Salut Teutates,

Je suis face au même problème que toi sur un Raspi B+ avec la dernière release de Squeezeplug. Pas moyen de trouver une solution, t'as réussi à avoir ton adresse IP et/ou connecter un clavier ?

Merci.
Bonjour,

désolé de ne pas avoir pu répondre plus tot mais j'ai du gérer mon déménagement et je n'ai récupéré mon accès à internet que ce week-end.

Pour l'instant je n'ai essayé que la solution trouvé ici :
http://forums.slimdevices.com/showthread...ble/page42

J'ai donc essayé de copier les fichiers trouvés ici :
https://github.com/raspberrypi/firmware/...aster/boot
sur ma carte mémoire toute proprement installé mais avec cette solution je me retrouve avec un raspberry qui ne démarre même plus...

Je pense essayer cette semaine d'installer une raspbian sur ma carte mémoire pour faire un update du firmware de mon B+ et réessayer la technique ci dessus.
gambit a écrit :Il y a un github squeezeplug qui date de mai https://github.com/gabbel/raspberry_pi_squeezeplug.
Ça semble coller, non?

Pour ça j'ai regarder un peu mais ça ne sert qu'à permettre d'utiliser les ports GPIO pour piloter Squeezeplug mais pour ça il faudrait déjà que j'arrive à l'installer ^^
Teutates a écrit :J'ai donc essayé de copier les fichiers trouvés ici :
https://github.com/raspberrypi/firmware/...aster/boot
sur ma carte mémoire toute proprement installé mais avec cette solution je me retrouve avec un raspberry qui ne démarre même plus...


Bonsoir,

Confronté au même problème originel, puis à l'échec de la solution ci-dessus - avec un symptôme identique, à savoir une rpi qui ne démarre pas - j'ai tenté une solution au pif, puisqu'après tout Squeezeplug est basé sur Raspbian, qui finalement a marché :

- télécharger la dernière version de la Raspbian (release 2014-09-09 à l'heure où j'écris) depuis http://www.raspberrypi.org/downloads/
- graver l'image sur une sdcard
- copier dans un dossier quelconque tous les fichiers présents à la racine de la partition /boot (12 en tout)
- démonter la sdcard contenant Raspbian, monter la sdcard contenant Squeezplug
- coller les fichiers à la racine de la partition /boot
- démonter, insérer la carte dans la rpi, démarrer : ouf, ça marche ! Squeezeplug démarre, claviers et souris sont actifs, et le réseau est bien présent.

En espérant avoir aidé et que cette solution sera reproductible, bien cordialement,
Marc
Au pif : c'est pas un nez que t'as. C'est un roc, un pic, un cap, mieux : une péninsule...
J'ai justement pensé à la même chose lundi soir et j'ai essayé pratiquement la même technique mercredi pour voir ce que ça donnerai.
J'ai juste légèrement fait différemment :
- télécharger la dernière version de la Raspbian
- Ecrire l'image de Raspbian sur la SD
- Démarrer le rasp avec la carte SD
- Faire toute les MAJ même de firmware
- Arreter le rasp démonter la sdcard contenant Raspbian, la monter sur mon ordi windows copier les fichier de la partition boot
- Ecrire sur la SD la version de Squeezeplug
- Copier ensuite les fichier de boot du windows sur la carte
- Insérer la carte dans le rasp, démarrer : et ohh miracle!! ça fonctionne!

Maintenant je suis dans la galère de faire fonctionner le Wifi avec la clé USB mais la c'est un autre soucis.

Du coup en parallèle je vais essayer de refaire une image de SqueezPlug qui prend en charge le rasp b+ avec les fichier en provenance de RaspBian