RaspFR :: Forum

Version complète : Pas de connection wifi au démarrage
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Bonjour.
Je suis avec Kodi et OpenElec, connecté en wifi.
Une fois sur deux au démarrage, la wifi n'est pas connecté, je suis obligé de rebooter, et ensuite c'est bon!
Pouvez vous m'aider?
IP fixe ? Si tu utilises un DHCP essaye une IP fixe pour certains ca vient de là (http://www.pihomeserver.fr/2013/01/27/in...-raspbian/)
Est ce que tu t'es connecter au wifi via l'interface de kodi? Moi j'ai du configurer certains paramètre pour pouvoir etre en Wifi
Merci pour vos réponses.
J'ai mis une ip fixe via ma freebox:
Configuration du routeur; DHCP...
J'ai connecté le wifi via l'interface de kodi (Système; paramètres OpenElec; mot de passe...)
Le tuto de http://www.pihomeserver.fr/2013/01/27/i … -raspbian/
est pour raspbian, ça ne marche pas avec kodi:
Code :
[== Indéfini ==]
OpenELEC: ~ # apt-get update Il n'y a pas de travail "apt-get '. 'apt-get' est une commande pour installer, mettre à jour et supprimer les logiciels qui est stocké dans un repo non locale. 'apt-get' ne fait rien alors se connecter à cette repo, télécharge le logiciel, déballe le logiciel, met à jour une grande base de données locale avec tous les chemins de fichiers et d'autres informations sur le logiciel installé ou supprime ou mises à jour des logiciels installés. Avec OpenELEC il est impossible de changer le système pour des raisons de sécurité et de stabilité ainsi même 'apt-get' ne serait pas capable de faire cela. Nous avons également Dont et nous voulons maintenir un tel repo pour diverses autres bonnes raisons. Aussi paquets Ubuntu ou Debian sont souvent obsolètes et non compatible avec OpenELEC Astuce: utilisez le navigateur addon de XBMC pour améliorer votre système OpenELEC
Je ne sais pas pour le reste si c'est valable?
OpenElec ne veut pas que l'installation de package soit possible. L'ip fixe doit etee definie cote raspberry. Si tu le fais cote feeebox c'est via un bail et ca ne change rien pour le pi
Ok;
Mais étrange je ne trouve pas le fichier /etc/network/interfaces.
Que ce soit en explorant les fichiers, ou avec la commande: nano /etc/network/interfaces
Il n'y a pas ce fichier!
Je ceois que openelec protege les fichiers. Mais depuis leur interface tu peux peut etre forcer l'ip de l'interface. Sinon voir dans leurs docs
Dans "paramètre OpenElec"; "service" ; Il y a Avahi zero conf de coché, et aussi Cron activé, peut être est ce du à ça?
Avahi permet la decouverte de la machine par d'autres appareils apple. Cron j'imagine l'utilité de l'option mais sans certitude et ca n'est pas lié au reseau
Oui, ok;
j'ai vu quelques part: https://lafibre.info/adeli-tv/tv-on-raspberry-2/
le fichier /etc/network/interfaces n'existe pas dans l'image système mais est pris en compte quand on le rajoute .
Je ne sais pas trop que faire, faut il que je crée un fichier ?
A voir dans la doc openelec
Oui, il y a ça ici mais je ne comprends pas tout!
Il y a un option d'attente du reseau pour ne pas booter trop vite et ne pas avoir d'ip. Tu pourrais essayer ca
oui, c'est ce que je me dit, et j'avait peur que sans réseau il ne boot plus du tout!