Raspberry Pi :: Communauté francophone

Version complète : [Résolu] LXPanel impossible à afficher
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
J'ai installé une première fois ma RPi et je suis allé jusqu'à la connexion graphique distante : tightvncserver / RPi <--> Tigervnc / GNU/Linux. Tout allait bien, graphiquement parlant.

J'ai réinstallé une deuxième fois la RPi pour faire une partition séparée pour /home (pour conserver mes scripts en cas de réinstall), éliminer le user pi et créer le mien. Nickel !

Sauf que quand je me connecte graphiquement avec Tigervnc depuis le PC, le bureau graphique apparaît, le fond d'écran avec la grosse framboise et l'icône de la corbeille. Et la corbeille descend, un bandeau blanc apparaît pour afficher le tableau de bord ou panel mais rien ne s'affiche, le bandeau disparaît, la corbeille remonte et ceci sans fin.

Je me suis dit que j'avais fait quelque chose qu'il ne fallait pas dans la config de l'interface graphique alors j'ai essayé de modifer quelques fichiers de config : sans succès. Puis j'ai recréé un nouveau /home/user : même problème. Enfin j'ai créé un second user : même problème.

Et je ne sais plus quoi faire avant de réinstaller. Sinon lire vos conseils avisés.

Merci de l'attention portée à mon message.
Ah bon ! Y a person qui répond ?

Je suis allé voir dans le .xsessionerror. Je n'en ai mis que le début, cela continue indéfinilment ainsi. A chaque fois, un process est lancé pour le lxpanel et échoue, quand il s'arrête un autre est lancé.
Code :
Xsession: X session started for jps at jeudi 20 août 2015, 17:26:48 (UTC+0200)
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  109 (X_ChangeHosts)
  Value in failed request:  0x5
  Serial number of failed request:  6
  Current serial number in output stream:  8
localuser:jps being added to access control list
Obt-Message: XKB extension is not present on the server or too old
Obt-Message: Xinerama extension is not present on the server
Obt-Message: XRandR extension is not present on the server
Xlib:  extension "RANDR" missing on display ":1".
Xlib:  extension "RANDR" missing on display ":1".
Xlib:  extension "RANDR" missing on display ":1".
Openbox-Message: La touche demandée « Super_L » n'existe pas pour l'affichage
Openbox-Message: La touche demandée « F13 » n'existe pas pour l'affichage
Openbox-Message: Impossible de trouver un fichier de menus valide  Â«Â /usr/share/lxde/openbox/menu.xml »
** Message: x-terminal-emulator has very limited support, consider choose another terminal
** Message: x-terminal-emulator has very limited support, consider choose another terminal

** (lxpanel:2529): WARNING **: The directory '~/Templates' doesn't exist, ignoring it

** (pcmanfm:2531): WARNING **: The directory '~/Templates' doesn't exist, ignoring it

(lxpanel:2529): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-can-change-accels after class was initialised

(lxpanel:2529): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-popup-delay after class was initialised

(lxpanel:2529): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-popdown-delay after class was initialised

(lxpanel:2529): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-images after class was initialised

(lxpanel:2529): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-label-select-on-focus after class was initialised

(pcmanfm:2531): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-can-change-accels after class was initialised

(pcmanfm:2531): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-popup-delay after class was initialised

(pcmanfm:2531): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-popdown-delay after class was initialised

(pcmanfm:2531): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-label-select-on-focus after class was initialised

(pcmanfm:2531): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-menu-images after class was initialised

(lxpanel:2529): GLib-GObject-WARNING **: Attempt to add property GtkSettings::gtk-button-images after class was initialised

(lxpanel:2529): Gtk-CRITICAL **: IA__gtk_misc_set_alignment: assertion 'GTK_IS_MISC (misc)' failed

(lxpanel:2529): Gtk-CRITICAL **: IA__gtk_misc_set_alignment: assertion 'GTK_IS_MISC (misc)' failed
*sage: Connecting ...
** Message: Status changed to down

(lxpanel:2529): Gtk-CRITICAL **: IA__gtk_dialog_response: assertion 'GTK_IS_DIALOG (dialog)' failed
** Message: Status changed to opened
** Message: Connected to dhcpcd-6.7.1
** Message: Status changed to connected
** Message: eth0: CARRIER
** Message: eth0: Configured 192.168.1.12/24
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL Är_v^P:^A

** (lxpanel:2529): WARNING **: volumealsa: Default ALSA device not valid - resetting to internal
Xlib:  extension "RANDR" missing on display ":1".
** Message: x-terminal-emulator has very limited support, consider choose another terminal
Une idée ?
Une petite recherche rapide Google donne ça : https://www.raspberrypi.org/forums/viewt...66&t=16598
Des messages d'erreur peuvent venir d'une résolution non classique lors de la connexion VNC. Essaye de lancer VNC sans paramètre pour laisser le Raspberry décider par lui même
Merci pour ta réponse. Tu penses bien que j''ai cherché sur ternet mais sans succès.

Je lance sans "tightvncserver" sans paramètre aucun. Je voulais vérifer qu'il ne traînait pas des traces d'un ancien paramétrage quelconque enregistré mais je m'aperçois après une coupure de courant intempestive que je ne peux même plus me connecter par ssh. Et je n'ai qu'un PC pour me connecter, je n'ai pas de clavier usb...
Lassé du problème et snas conseil plus avisé, j'ai réinstallé complètement. Mais avant même toute personnalisation, le problème se reproduit à l'identique !
(Y en a marre...)
ta sd aurait pas une claque ?
Après quelques journées de recherche, sur openbox, lxpanel, récupération de fichiers configs ailleurs (il y en a une foultitude ; et faux car lxpanel y est souvent défini en bas alors qu'il apparaît en haut !), j'ai fini par faire une erreur et lancer X sous root. Et là j'ai bien dû constater qu'il n'y a aucun problème, le lxpanel apparaît correctement en haut et sans clignotement. J'ai pu aainsi cerner l'origine de mon problème. En réalité après install, je supprime le user pi (sécurité oblige) pour créer le mien et, pendant ou après cette création de user, il est probable que quelque chose se loupe dans la création du .config/lxpanel. Donc, si vous lisez l'intégralité de ce post, rectifiez dans mes messages précédents, le problème ne se pose pas après installation standard mais après la création de mon user qui est incomplète.

Je n'ai pas envie de chercher davantage dans tout ce bazar foutraque de paramétrage du GUI.
Soit je récupèrerai la config de root, soit ceux du user pi après une réinitialisation.
Soit je me passe du bureau distant, je me connecte en ssh -X à partir de mon PC et quand je lance un programme avec interface graphique, je le reçois tout simplement sur mon PC GNU/Linux. pcmanfm me suffit.

So long...
je t'ai pas lu sur mageia toi ?
[email protected] a écrit :je t'ai pas lu sur mageia toi ?
For sure my dear. Et toi, sur MLO ton alias possède un "3" en plus, non ?
Smile
Conclusion générale :
J'ai recopié les fichiers de config X de pi sous mon home : même problème.
J'ai resupprimé mon user avec tous ses fichiers mais au lieu de le recréer connement, je lui ai ajouté tous les groupes du user 'pi'. Peut-être (et pour moi sans doute) pas tous utiles je pense. Mais désormais, le lxpanel apparaît bien sagement en haut de l'écran... Enfin !

Ouf !

J'ai une partition /home distincte, un user qui n'est pas 'pi', je peux faire du graphique remote (sans tightvncserver / RasPi et TigerVNC Viewer / PC), je vais pouvoir passer à la suite...

So long buddies.

garret_t

My apologies. Je ne parle pas francais. I believe the problem is related to the volume control in the LXDE panel settings as shown by the error "Default ALSA device not valid." Commenting-out volumealsa setting for the non-pi user in the file ~/.config/lxpanel/LXDE-pi/panels/panel prevents that error message and the X Desktop loads normally. Let me know if it worked for you.

#Plugin {
# type=volumealsa
# Config {
# }
#}

I suspect this is a permissions problem with accessing the volume control.