Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Utiliser les GPIO dans un script de démarrage
#1

Bonjour,

J'utilise une carte PI pour communiquer avec un scanner.

celui-ci a besoin d'une séquence d'initialisation (que je fais grace aux GPIO)
J'ai donc créé 2 scripts, 1 pour l'initialisation et 1 autre pour lire les images.

Les 2 scripts fonctionnent lorsque je les lance "à la main" Smile .

Je souhaite lancer mon premier script au démarrage du PI, et le second via une tâche CRON (toutes les n minutes).

J'ai réussi à lancer mon script en crontab mais pas moyen de faire fonctionner mon premier script au démarrage :/ .
j'ai tenté dans le init.d ou le rc-local mais pas moyen.

Avez-vous une idée ?

Relax62
Répondre
#2

Salut

http://www.pihomeserver.fr/2013/05/27/ra...demarrage/

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#3

Bonjour,

Merci Chris, j'ai déjà tenté cette technique mais sans succès par contre je n'avais pas lu les commentaires (le dernier est particulièrement intéressant).

Je vous tiens au courant.
Répondre
#4

Bonjour,
donc effectivement, la solution est la suivante :

depuis la crontab :
crontab -e
j'ai ajouté les lignes suivantes:
@reboot sudo sh monrepertoire/monscript.sh

Le script se lance au démarrage et les gpio sont fonctionnels Cool

Merci de ton aide Chris Wink
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)