Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[Help] Truc bizarre Framboise - Nginx
#1

Bonjour à tous,
J'ai un truc bizarre depuis quelques jours. Je lance la commande :
Code :
sudo nginx -t
Et j'obtiens :
Code :
nginx: [warn] conflicting server name "localhost" on 0.0.0.0:80, ignored
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
Je ne comprends pas bien la première ligne, le warning.
Quelqu'un a une idée ?
Merci d'avance.
Cordialement
H.
Répondre
#2

En fait, tu dois avoir, malgré toi, plusieurs configurations du serveur localhost dans nginx.
Surement une définition avec server_name _; et une autre avec listen 80 default;

Il faudrait qu'on en sache plus sur ta config nginx.
Répondre
#3

Super rapidité de réponse ! Merci !



J'ai regardé hier soir ma config de Nginx, et je crois que j'ai trouvé quelque chose. J'ai 2 fichiers default, l'un dans sites-availables et l'autre dans sites-enabled. Ils semblent être les mêmes.

Code :
      listen   80;       
    server_name localhost;
        root /var/www;
        index index.php index.html index.htm;

        location / {
                root   /var/www;
                index  index.php index.html index.htm;
        }

        location ~ \.php$ {
                try_files $uri =404;
                fastcgi_pass   unix:/run/php5-fpm.sock;
                fastcgi_index  index.php;
                fastcgi_param  SCRIPT_FILENAME  /var/www$fastcgi_script_name;
                include        fastcgi_params;
        }
}
Mais il a du se passer quelque-chose, car j'avais mis à la main le nom de mon site dans le server name !
Un upgrade qui s'est mal passé ?
Je regarde !
Merci encore
D.
Répondre
#4

C'est tout à fait normal que tu aies les mêmes fichiers: celui dans sites-enabled doit être un lien symbolique vers celui dans sites-availables (tu peux le vérifier en faisant ls -lha /etc/nginx/sites-enabled/).
Que ce soit avec apache ou avec nginx, la logique est de "préparer" les configurations des sites dans sites-availables/ et pour les activer, de créer le lien symbolique dans sites-enabled/. Nginx et Apache analysent le contenu de ce dernier répertoire. C'est pareil avec les modules.

Jette aussi un oeil à /etc/nginx/nginx.conf et (s'ils existent) aux contenus de /etc/nginx/conf.d/*.conf
Répondre
#5

Ouaip !
D'abord, je n'ai rien dans /etc/nginx/conf.d/*.conf, aucun fichier d'aucune sorte.
Par contre, dans sites-enabled, j'ai un fichier default-pluxml ! Du temps où j'avais envisagé un blog auquel j'ai renoncé !
Peut-être par là ? Mais le serveur ne point pas sur un port 80, ni sur un port ouvert !
Je ne sais pas vraiment où chercher ! Si au moins je savais te communiquer les adresses IP pour atteindre directement mon environnement de test !
Je continue à chercher ! Sans désespérer !
Merci encore
D.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)