Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Thunderbird en réseau: partager "/Thunderbird/Profiles" sur le Raspi
#1

Bonjour à tous,

exposer mon souci sur mon petit projet, car je tourne en rond, je cherche depuis plusieurs jours une solution à mon problème. J'ai beaucoup lu, testé, etc.......en vain, il manque un petit quelque chose qui m'échappe. Je m'explique.

Projet:
Ayant deux machines XP et Seven sur le même réseau, sur lesquelles j'utilise quotidiennement Thunderbird, je voudrais mettre mon répertoire ..../Thunderbird/profiles/... sur le Raspberry.

Ce que j'ai fait:
Le rpi tourne sur raspbian, et sur une carte SD partitionnée 50/50 pour Raspbian et pour un répertoire Thunderbird. J'ai partagé (j'essaye!) ce répertoire Thunderbird via Samba. Il est visible sur les machines Windows et pour le moment, il contient 3 fichiers d'essai. Je vois donc ces trois fichiers sur les machines XP et Seven. Je peux lire les fichiers, les exécuter mais pas les ré-écrire, ni en créer d'autres.

Ce qui est en phase avec le résultat de la commande ls- l exécutée dans le répertoire:

Code :
[email protected] /media/SdPartII $ ls -l
total 8
drwxr-xr-x 2 root root 8192 Nov 11 10:46 Thunderbird
[email protected] /media/SdPartII $

et sur les fichiers contenus dans le répertoire:
Code :
[email protected] /media/SdPartII/Thunderbird $ ls -l
total 24
-rwxr-xr-x 1 root root 756 Nov 11 10:46 copie
-rwxr-xr-x 1 root root 756 Nov 11 10:46 copie2
-rwxr-xr-x 1 root root 756 Nov 11 10:46 copie3
[email protected] /media/SdPartII/Thunderbird $

Voici le fstab sur le rpi

Code :
proc            /proc           proc    defaults          0       0
/dev/mmcblk0p1  /boot           vfat    defaults          0       2
/dev/mmcblk0p2  /               ext4    defaults,noatime  0       1
/dev/mmcblk0p3  /media/SdPartII auto,rw noatime 0 0
# a swapfile is not a swap partition, so no using swapon|off from here on, use  dphys-swapfile sw$

Quand j'essaie de changer les droits de cette façon, ça ne change rien coté Windows.
Code :
[email protected] /media/SdPartII/Thunderbird $ chmod -R g+rwX /media/SdPartII/Thunderbird/*

Je dois passer à coté de quelque chose, mais quoi? Vous l'aurez compris, les deux machine Windows doivent avoir tous les droits sur ce répertoire Thunderbird en réseau.

Je vous relirai avec plaisir, car j'ai l'impression de tourner en rond et de ne pas avancer. mais je continue à chercher..

Bonne journée,

Philippe
Répondre
#2

Re, voici le contenu de smb.conf

Code :
GNU nano 2.2.6                 File: /etc/samba/smb.conf

[global]
   workgroup = WORKGROUP
   server string = %h server
   netbios name = Thunderbird
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   security = user
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supda$
   pam password change = yes
   map to guest = bad user
   usershare allow guests = yes
force directory mode = 0755

[Thunderbird]
   path =/media/SdPartII/Thunderbird
   read only = No
writable = yes
   locking = no
   guest ok = yes
        force user = guest
Répondre
#3

Salut
Dans Samba tu as aussi une gestion des utilisateurs.
Ce que j'ai fait chez moi est que j'ai créé un user sur le Raspberry dédié au partage. J'ai mis ce user owner de l'arborescence a partager. Ensuite dans la configuration samba j'ai créé un partage où l'écriture est possible, on force le mode guest (pas de mot de passe demandé) et le user guest (celui créé précédement)
Plus de détail si besoin http://www.pihomeserver.fr/2012/12/09/ra...ler-samba/

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#4

Bonjour Chris,

merci beaucoup pour la réponse, et j'avais bien vu votre page http://www.pihomeserver.fr/2012/12/09/ra...ler-samba/, je m'en étais inspiré. Après avoir posté mon problème, j'ai bien évidemment continué à chercher. Et j'ai résolu mon problème, mais hélas, sans savoir avec certitude comment! Quand j'ai repris mon Rpi pour m'y remettre, mon répertoire Thunderbird avait disparu, ou n'était plus monté. J'ai donc repris cette phase, et j'ai attribué les droits avant de "monter" et c'est ce qui m'a permis de faire fonctionner. Le répertoire est maintenant bien vu des machines Seven et XP. Pour l'instant, j'ai fait des essais de lecture/écriture tout en provoquant du flux audio, tout roule!!

Cet aprem, je fais l'essai d'y mettre mon répertoire "Profiles" de Thunderbird. Je devrais en principe avoir des configurations identiques sur les deux machines.

Je reviendrai donc confirmer cela. Et il faut que je me perfectionne dans les commandes de base et essentielles de Raspbian. Quand je vois les possibilités offertes, ça vaut le coup de se creuser les méninges.

Philippe
Salon de Provence
Répondre
#5

Bonne nouvelle
A voir une fois le Raspberry redémarré si votre montage est toujours en place.
Oui beaucoup de commandes mais qui permettent un réglage pointu. Ca vaut effectivement le coup !

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)