Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Session -X au démarrage de Rpi
#1

Bonjour,

Je possède actuellement une Rpi B+ et je voudrais qu'au démarrage le système se lance avec une session X active, je m'explique je ne veux pas que le système me lance un startx au démarrage (cela je sais comment le régler avec "sudo raspi-config") je voudrais que la Rpi se lance comme dans ce cas :
Code :

Afin de pouvoir lancer des applications graphique comme xeyes sans avoir un environnement du bureau actif.


Merci de m'aider,
Répondre
#2

Bonjour,

Est-ce cela que tu souhaites faire: X11 forwarding en SSH via Putty ?
Répondre
#3

Pas vraiment car j'ai un accès direct à la Rpi je ne veux pas y accèder à distance sinon c'est simple avec ssh de mettre un -X ce que je veux c'est que quand la Rpi se lance (elle est connecté à un écran) elle se lance avec un -X afin que (suivant un script) elle me lance une application graphique. Sans que moi j'ai à intervenir ou à lancer un startx (car je ne veux pas d'environnement de bureau cela ne m'est pas utile);

Sinon merci de ta réponse
Répondre
#4

Ok,

Désolé de ne pas comprendre du 1er coup, mais souhaite-tu que les applications graphiques exécutées sur le Raspberry PI s’affichent ailleurs sous Windows ou autre ?
Si oui, cf. Raspberry PI sans écran au port HDMI avec Putty et X11 Forwarding
Sinon ... à suivre ;-)
Répondre
#5

Et bien c'est un non la Rpi est relié à un écran, je veux juste que la session qui s'ouvre au démarrage soit en -X
Répondre
#6

Bonjour,

Tu peux lancer un serveur X sur une console. Je te donne juste la piste vu que j'ai pas de framboise sous la main pour te confirmer la méthode... Mais j'ai eu l'utilité sur d'autre linux.

Donc lancer un serveur X sur le DISPLAY:3 par exemple, et le mettre en tache de fond avec l'attribut "&" :
Code :
$ sudo X :3 -terminate -a -c &
DISPLAY est le nom de la variable d'environnement que ta console utilise si elle est en mode graphique. Je peux pas t'expliquer pourquoi, mais ton système utilise par défaut :0, :1 et :2. À vérifier.
Après ça, tu peux lancer un programme dans ce serveur :
Code :
$ DISPLAY=:3 monprogramme --avec --ses --paramètres &

Je pense pas que ça fonctionne du premier coup. Notamment parce que X réclame un fichier de configuration dans lequel entr'autres tu peux définir tes screen device. Mais grosso-modo c'est l'idée, hein.Smile

Cool
Répondre
#7

Alors merci !
Donc ce que tu m'as donné ça marche pas ^^
Mais au moins ça m'as donné des pistes de réflexions et maintenant ça marche. Je m'explique :
J'édite le fichier .xinitrc
Code :
sudo vim .xinitrc

J'ajoute :
Code :
xeyes
et je peux lancer simplement xinit pour lancer mon application xeyes en graphique sans lancer de session
Code :
xinit
Après il y a plein d'option dans xinit le man est la pour ça.

Merci de vos réponses, en tout cas
Répondre
#8

Voilà : c'est ça que je disais! Big Grin

Cool
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)