Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Rpi3 wlan 0 n'est pas visible
#1
Bonjour à tous, 
J'ai une raspberry pi 3 Model B
Je suis incapable de faire fonctionner la connexion WiFi. Le logo réseau m'indique "No wireless interface found"
Quand j'affiche la liste des interfaces : wlan0 ne remonte même pas
J'ai essayé de configurer /etc/wpa_supplicant ... Mais rien y fait.
Dans mon raspi-config, impossible de choisir la localisation WiFi, même chose, no wireless interface found.. 
J'ai tout essayé, notamment retélécharger raspbian, etc .. 
Avez vous des conseils, des idées ? 
Merci d'avance ! 
Répondre
#2
Bonjour,

Tu peux commencer par faire un dmesg | grep brcmfmac pour avoir des informations sur l'initialisation (ou pas) de l'interface.

Quelle version de raspbian as-tu installé ? As-tu fait un rpi-update pour mettre à jour le firmware ?
Répondre
#3
Bonjour,
Merci pour ta réponse rapide !
dmesg | grep brcmfmac ne me retourne absolument rien
J'ai la version 4.19.93-v7+
Non je n'ai jamais fait de rpi-update, je viens de lancer la commande, ça ne sera pas pire après tout...
Reboot après le firmware update et... Même chose
Ifconfig me retour :
Enxb827eb74eec8 et lo
Même pas de eth0 ou wlan0
À noter que la connexion filaire fonctionne parfaitement
Merci d'avance !
Répondre
#4
Tu ne trouveras pas de eth0 et de wlan0... Depuis Jessie (de mémoire), les interfaces sont nommées enxMAC (ethernet) et wlxMAC (wifi) où MAC est l'adresse MAC de l'interface.

Essaye de faire sudo modprobe -c | grep brcmfmac pour voir si le module est chargé.
S'il ne l'est pas, fait sudo modprobe brcmfmac

Si ça marche, fais sudo grep brcmfmac /etc/modprobe.d/* pour voir si le module n'est pas blacklisté (ce qui serait étonnant, mais on ne sait jamais). Deux possibilités:
- rien ne ressort: le module n'est pas blacklisté. Reboot un coup pour voir si le module reste chargé
- au moins une ligne ressort: édite le fichier en cause en commente (en mettant un # en début de ligne) la ligne.
Répondre
#5
Bon alors on avance, mais c'est pas encore ca ...

sudo modprobe -c | grep brcmfmac
alias sdio:c*v02D0d4324* brcmfmac
alias sdio:c*v02D0d4329* brcmfmac
alias sdio:c*v02D0d4330* brcmfmac
alias sdio:c*v02D0d4334* brcmfmac
alias sdio:c*v02D0d4335* brcmfmac
alias sdio:c*v02D0d4339* brcmfmac
alias sdio:c*v02D0d4345* brcmfmac
alias sdio:c*v02D0d4354* brcmfmac
alias sdio:c*v02D0d4356* brcmfmac
alias sdio:c*v02D0d4373* brcmfmac
alias sdio:c*v02D0dA887* brcmfmac
alias sdio:c*v02D0dA94C* brcmfmac
alias sdio:c*v02D0dA94D* brcmfmac
alias sdio:c*v02D0dA962* brcmfmac
alias sdio:c*v02D0dA9A4* brcmfmac
alias sdio:c*v02D0dA9A6* brcmfmac
alias sdio:c*v02D0dA9BF* brcmfmac
alias usb:v043Ep3101d*dc*dsc*dp*ic*isc*ip*in* brcmfmac
alias usb:v04B4p0BDCd*dc*dsc*dp*ic*isc*ip*in* brcmfmac
alias usb:v04B4pBD29d*dc*dsc*dp*ic*isc*ip*in* brcmfmac
alias usb:v0A5Cp0BDCd*dc*dsc*dp*ic*isc*ip*in* brcmfmac
alias usb:v0A5CpBD17d*dc*dsc*dp*ic*isc*ip*in* brcmfmac
alias usb:v0A5CpBD1Ed*dc*dsc*dp*ic*isc*ip*in* brcmfmac
alias usb:v0A5CpBD1Fd*dc*dsc*dp*ic*isc*ip*in* brcmfmac
alias usb:v0A5CpBD27d*dc*dsc*dp*ic*isc*ip*in* brcmfmac
alias usb:v13B1p0039d*dc*dsc*dp*ic*isc*ip*in* brcmfmac

sudo grep brcmfmac /etc/modprobe.d/* ne me remontait rien, donc j'ai utilisé sudo nano brcmfmac /etc/modprobe.d/* et j'ai commenté les lignes
blacklist 8192cu et blacklist rtl8xxxu
Reboot
Toujours le même message, j'ai donc voulu vérifier si je pouvais configurer la localisation du wifi via sudo raspi-config
No wireless interface found
Merci d'avance
Répondre
#6
Je viens de tester sur ma framboise et effectivement il semble qu'il y ait un souci avec le wifi.
Lorsque je tente de configurer le wifi avec raspi-config, il n'arrive pas à communiquer avec wpa_supplicant. Par contre mon wifi fonctionne.

As-tu essayé de remplir à la main le fichier /etc/wpa_supplicant/wpa_supplicant.conf ?
Code :
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=FR

network={
        ssid="TON-SSID"
        psk="TON-PASSWORD"
}
Répondre
#7
Bonsoir,
Malheureusement oui j'ai déjà essayé..
Sincèrement j'ai essayé tous les conseils visibles sur internet... À croire que mon module WiFi est mort...
Merci quand même à toi !
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

A propos de Communauté francophone RPi

Communauté francophone RPi est un forum d'aide et de partage autour du Raspberry Pi et des micro-ordinateurs.