Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Résolution d'écran....
#1

Bonjour !
Comment imposer une résolution 1366 x 768 ?
Pour le mment Paspi ne me propose qu'un 1024 x 768 et la détection "auto" reste vaine...
Doit certainement y avoir un moyen... mais je ne sais pas quel tiroir ouvrir !
Merci de vos lumières.

Lenovo Legion Y520 - Debian-10.3 Buster
FreeBox V6  -  RaspBerry Pi4-B+Raspbian Buster
Peintures, Voyages et Photos
Répondre
#2

Bonjour !
La résolution de quoi ? RCA ? HDMI ? Du desktop ? Télé ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#3

D'un moniteur ordinaire connecté au Raspi via câble adaptateur HDMI ---> VGA

Lenovo Legion Y520 - Debian-10.3 Buster
FreeBox V6  -  RaspBerry Pi4-B+Raspbian Buster
Peintures, Voyages et Photos
Répondre
#4

Tu as modifié dans le fichier config.txt le mode HDMI pour voir si ca change ? La détection automatique ne doit pas fonctionner à cause de l'adaptateur.

Pour du 1360x768 en 60Hz :
Code :
hdmi_group=2
hdmi_mode=39

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#5

merci de ta réponse...

Dans le config.text.. j'ai...
Code :
For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
hdmi_safe=0

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=39

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=800

core_freq=250
sdram_freq=400
over_voltage=0

Peut-être modifier selon besoin et activer les lignes
framebuffer_wight (et height) ?

j'ai modifié et activé les lignes
hdmi_group=2
hdmi_mode=39 (se rapprochant le plus de la résolution max de mon moniteur.. (1366 x768)

Lenovo Legion Y520 - Debian-10.3 Buster
FreeBox V6  -  RaspBerry Pi4-B+Raspbian Buster
Peintures, Voyages et Photos
Répondre
#6

Et après reboot ca fonctionne ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#7

Oui tout a fait...
Là où je rencontrais un petit problème, c'est que lorsque j'étais connecté au Raspi en VNC depuis une autre mahine (Mac ou Linux/debian) le bureau qui apparaissait dans l'écran dans la fenêtre VNC débordait de la fenêtre... à gauche et à droite... m'empêchant d'accéder au bouton "menu" placé dans le coin en haut à gauche. Mais les objets sur le bureau était à leur place...
En fait il s'agissait de la largeur du tableau de bord.. En le réduisant en tâtonant la largeur du tableau de bord sur le Raspi "en direct", il apparait correctement dans la fenêtre VNC. Moindre mal.. Mais je n'ai pas compris pourquoi...
Mon moniteur est du type 16:9 (1366 x 768) et la fenêtre VNC sur l'ordi connecté est du type 4:3. Seul le tableau de bord ne rentre pas "dans la boite"

Voir le post http://forum.raspfr.org/viewtopic.php?id=1104

Je viens d'activer et de modifier les lignes
Code :
framebuffer_width=1300
framebuffer_height=768

Pas de changement notable...

Je trouverai bien un jour...
Merci pour ton aide.

Lenovo Legion Y520 - Debian-10.3 Buster
FreeBox V6  -  RaspBerry Pi4-B+Raspbian Buster
Peintures, Voyages et Photos
Répondre
#8

Il suffit de forcer la résolution du serveur VNC quand celui démarre. De mémoire c'est le paramètre geometry. Le bureau prendra alors toute la largeur/hauteur disponible

Pour le framebuffer c'est pour le mode console, le serveur X n'utilisant pas ce mode (de mémoire encore)

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#9

meme en forçant la résolution avec "geometry" les valeurs ne sont pas prise en compte..
et une fenêtre apparait au centre de la fenêtre ramenée à un format 4/3
"GDBUs.Error.orgfreedesktop.PolicyKit1.Error.Failed: An authentifiation agent already exist for the given subject"

?????
Mais je crois que c'est un problème plus "hard" que "soft"... tout au moins non lié aux connexions réseau...
A preuve le fait que le moniteur connecté directement au laptop debian ne restitue que la valeurs h x l définies dans le menu déroulant des propositions de résolution proposées dans "affichage" des préf systeme (soit deux résolutions proposées: 1024 x 768 (4/3), et 800 x 600 (4/3) . la résolution de l'écran requise par le moniteur est 1366 x 768...

J'en conclue (peut-être à tord) que les valeurs de résolution du moniteur ne sont pas lues automatiquement par l'ordi.... Qui plus est, ce moniteur est mentionné dans "affichage" comme "inconnu"...

Lenovo Legion Y520 - Debian-10.3 Buster
FreeBox V6  -  RaspBerry Pi4-B+Raspbian Buster
Peintures, Voyages et Photos
Répondre
#10

avec vncserver sur le Raspberry Pi et un client vmc sur mon Mac je n'ai jamais eu de soucis. Tu es certain que la ligne de commande est bonne ?

Pour l'erreur une simple recherche sur Google :
Go into "Preferences->Desktop Session Settings" and un-check "PolicyKit Authentication Agent"

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)