Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[Résolu] petit problème de compréhension
#1

bonjour

j'instal mon rpi3 avec sa carte sd laquelle à été chargée sans problème avec rasbian
naturellement au démarrage boum écran noir.
Je file dans le config.txt et après plusieurs tentatives, je décommente la ligne hdmi_safe=1

Là mon image apparais mais en 680x460 pour un ecran qui gére le 1920x1080, ya de la marge

j'ai beau lire les tutos du net modifier les options du fichier, rien y fait. La résolution ne change pas

ma question :
est ce que le fait de mettre hdmi_safe=1 met automatiquement le moniteur en basse résolution,
se qui rend inopérant la modification des options.??

si je veux avoir ma résolution maxi, dois-je commenter hdmi_safe=1 et là jouer avec les options
du fichier, jusqu'à l'affichage de l'écran ??

merci a+
Répondre
#2

j'ai réussi à avoir l'image il fallais changer l'option hdmi_drive=2 mettre à 1

maintenant ca scintille il accepte pas le hdmi_mode=16

a+
Répondre
#3

Je ne peux pas tester (RPi sans écran Wink) mais en lisant https://www.raspberrypi.org/documentatio...fig-txt.md :
- il vaut mieux mettre hdmi_safe à 0 pour un affichage avec tes propres réglages
- pour le hdmi_drive, je laisserai à 2 (mode hdmi normal)
- il faut jouer avec les options hdmi_group et hdmi_mode. Si ton écran est une télévision, ce sera plutôt 1 pour hdmi_group, sinon 2. L'utilitaire "tvservice" peut t'aider à trouver les infos utiles.
Pour un moniteur en 1920x1080, les réglages seraient:
Code :
hdmi_group=2
hdmi_mode=82

EDIT

J'ai trouvé un petit how-to sur le net pour trouver les caractéristiques de son écran:
  1. Mettre les réglages hdmi_group=1 hdmi_mode=1 et rebooter
  2. tvservice -m CEA donnera la liste des modes possibles en hdmi_group 1
  3. tvservice -m DMT donnera la liste des modes possibles en hdmi_group 2
  4. tvservice -s pour avoir l'état actuel

Avec ça, tu dois pouvoir trouver le doublet group/mode le plus adéquat pour ton écran.
Répondre
#4

bonjour crazycat

même avec la commande tvservice -m DMT je peux utilise que le mode 47
impossible avec le mode 82 l'écran sautille et il a des raies vertical

a+
Répondre
#5

Essaye p-e avec le custom mode (hdmi_cvt), comme indiqué sur la page que je t'ai donnée, en dessous des tableaux de résolution.
Répondre
#6

bonnjour

cette combinaison ne marche pas : ecran noir

Code :
[== Indéfini ==]
hdmi_group=2
hdmi_drive=2
hdmi_cvt=1920 1200 60 3
hdmi_mode=87

je suis obligé de mettre hdmi_drive=1 pour que l'écran me donne une image, mais ca scintille méchament. Je pense que le cable HDMI ne dois pas passer le son
je testerais cela plus tard.

pour l'instant retour au mode 47

a+
Répondre
#7

salut !
Je viens de verifier sur mon pi 3 .
Chez moi tout est commenté sauf a la derniere ligne :

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
Répondre
#8

bonjour [email protected]

j'ai essayé ta solution et remis comme à l'origine sauf que je suis obligé de mettre hdmi_drive=1 pour que l'écran me donne une image,

l'écran scintille à donf plus ca va et plus je penche sur le cable HDMI qui dois pas être conforme

je vous tiens au courant des avancées

a+
Répondre
#9

ca été plus vite que prévue

j'ai changé mon cable HDMI remis hdmi_drive=2 et decommenté disable_overscan=1 et recommenté toutes les autres options
la hoooo miracle ça marche impec et j'ai la résolution voulue 1900x1200 sans aucuns scintillements

comme quoi même un câble neuf peut être défectueux je l'est remplacé par un même câble impec

ouf a+
merçi de votre aide à tous
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)