Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[Résolu] paramétrage motion.conf pour camera IP + envoi par ftp
#1

Bonjour

Je rame depuis qques jours car je n'arrive pas à paramétrer motion sur mon raspberry.

Il doit accueillir une station météo ws2355 et une camera ip Tenvis.

J'ai commencé par la caméra mais le hic : unable to open video device

En recherche sur le net je trouve toujours des cameras reliées en USB ou la camera rpi.

En configuration :
- Raspberry Pi B+
- 2014-09-09-wheezy-raspbian
- Raspberry relié en wifi à internet, tightvnc et ssh sur mon pc

La caméra est en ethernet sur le 192.168.1.10 (défini dans la livebox)
Fonctionne très bien sur mon pc avec http://192.168.1.10:7780/video/livesp.asp (user et passwd correctement renseignés bien sûr)
Fonctionne également via l'ecran graphique du raspberry
Prise de photos sur un pc XP avec webcamXP fonctionne
Et je souhaite continuer à avoir la camera reliée à la livebox plutot qu'en direct car elle sera en wifi à terme mais toujours sur cette ip.
Le raspberry fonctionnera en mode console.
Le but est de prendre une photo toute les 5 minutes et d'envoyer ça sur le net

Actuellement les photos sont vierges et j'ai donc l'erreur de open device

En config j'ai mis :
videodevice /dev/video0
palette 3 (pour avoir image en jpeg)
netcam_url http://192.168.1.10:7780
netcam_userpass monidentifiantcamera:monpasswdcamera (le login qui me sert à paramétrer la camera)

J'ai testé en enlevant le device video, le port pour le modifier + bas dans le fichier conf, nada.
J'avais fait une manip (que j'ai pas retrouvé) qui consistait à mettre un log et un pass au groupe video, vu sur un site, mais idem sans résultat malgré plusieurs modifs dans le conf.

Merci de votre aide parce que là je sais plus trop quoi tenter.

73 GUG
#2

Bonjour,

J'ai peu utilisé motion, mais :
Ta caméra est sur ton réseau. Pas raccordée au rasp donc /dev/video0 est null --> unable to open video device c'est normal. Donc ne met rien au paramètre videodevice.
Concernant netcam_url, il faut mettre directement une url permettant de retourner un jpeg (ou un stream). Et non pas une page html intégrant une image. Et c'est peut-être le cas chez toi.
Teste ceci dans le terminal du raspberry :
Code :
[email protected] ~ wget http://192.168.1.10:7780/video/livesp.asp?user=tonidentifiant&pwd=tonpassword
Si tu obtiens directement un fichier jpeg, netcam_url http://192.168.1.10:7780/video/livesp.asp
Si tu obtiens un fichier en html, il faut chercher dedans le lien vers le jpeg. Tu peux rechercher ce lien également avec ton navigateur à la même adresse. Si tu cliques droit sur l'image obtenue, tu peux copier le lien (adresse url) de l'image.

N'oublie pas redémarrer le service.

Cool
#3

merci je vais regarder ça, je n'ai pas effectué cette manip donc il y a peut etre une chance hi
Je te tiens au courant et merci de l'idée
#4

En console :

Connexion vers 192.168.1.10:7780...connecté.
requête HTTP transmise, en attente de la réponse...401 Unauthorized
ÉCHEC d'autorisation.

commence mal

avec :
- wget http://192.168.1.10:7780/video/livesp.as...wd=monpass
et
- wget http://192.168.1.10:7780/video/livesp.asp

Mais ça marche toujours quand je suis en mode graphique. J'ai même tenté avec un sudo, sans resultat, je précise que je débute totalement en linux
#5

f4gug a écrit :je précise que je débute totalement en linux
Pas de problème, on y est tous passé.

Ceci dit, ça fonctionne presque, il suffit de trouver la bonne url. Fais-le avec ton navigateur : un clic-droit sur l'image de la caméra, poste le lien ici. On verra la suite en fonction.

Cool
#6

je ne peux pas puisque ce n'est pas une image mais une video, c'est peut etre pour ça que ça ne fonctionne pas en mode console.

petite surprise j'ai pas réussi à lancer motion :
[email protected] ~ $ [0] Exit motion, cannot create process id file (pid file) /home/pi/motion/motion.pid: Permission denied
#7

Bon ça fonctionne mais c'est bizarre, je n'ai pas de pid pour motion, je ne sais pas si c'est normal

J'ai piqué le lien sur webcamXP5 de mon pc windows :
netcam_url http://192.168.1.10:7780/media/?action=stream
netcam_userpass login:pass

EN tout cas merci pour l'aide, j'aurai pas pensé à ça, j'etais resté sur la ligne au dessus. Me reste les réglages à faire puis l'install du logiciel météo

73 GUG


Edit:
Petit souci : la détection de mouvement, je veux la supprimer car il y a une antenne dans le champs de vision et de toute façon je n'en ai pas l'utilité. J'ai trouvé que c'etait threshold 1500 je pense mais si je l'inhibe j'ai peur de faire une betise et je n'ai pas encore trouvé d'autres idées
#8

Citation :petite surprise j'ai pas réussi à lancer motion :
[email protected] ~ $ [0] Exit motion, cannot create process id file (pid file) /home/pi/motion/motion.pid: Permission denied
Euh, comment as-tu installé motion?

Cool
#9

avec cette page : http://www.epingle.info/?p=2682
#10

A la réflexion, je vois pas trop à quoi te sert motion si tu ne souhaites pas faire de détection de mouvement. C'est un peu l’intérêt de ce programme, non?

Cool
#11

j'ai juste besoin d'uploader une image toutes les 5 minutes, je sais qu'il existe d'autres programmes mais je ne sais pas lequel est le mieux. Suis ouvert à toute idée.
#12

Il a l'air bien ce tuto. Mais comme c'est indiqué au début, c'est pour transformer une bête webcam usb en webcam IP en utilisant un raspberry.
Toi, tu disposes déjà d'une caméra IP. Du coup, je vois plus trop l’intérêt. Mais bon, pourquoi pas.

Cool
#13

je vais regarder si je trouve mieux dans les tutos, effectivement j'ai pas besoin de détection de quoi que ce soit, ni de la méthode usb

Edit :
A premiere vue j'ai pas trouvé qque chose d'uniquement dédié à ça, j'ai modifié threshold 1500 à 1500000 et ça ne detecte plus rien, en esperant que le calcul ne surchage pas le rasp.
De tooute façon j'ai encore le ftp et le logiciel meteo à installer donc beaucoup de betises en vue. Quand ça sera opérationnel, je pourrai reprendre les programmes un par un et faire une sd propre.
En tout cas merci du coup de main
#14

j'ai presque réussi, juste une derniere erreur de création de répertoire :

si ça peut servir à d'autre, on peut envoyer par ftp directement de motion :
source http://www.raspberrypi.org/forums/viewto...4&p=454426

On_picture_save wput -Bq --remove-source-files ftp://utilisateur:[email protected]_FTP %f
#15

Donc gambit tu avais raison, motion n'est pas adapté : 70 à 75% de la cpu de prise, alors que open2300 et wu2300 me prennent 5% max.

Je vais voir autre chose comme prog pour la cam
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)