Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[Résolu] Impossible d'exécuter une commande avec sudo
#1

Bonjour Smile

lorsque je tente d'exécuter une commande avec sudo, je rencontre l'erreur suivante :

Code :
[== Indéfini ==]
-bash: /usr/bin/sudo: Aucun fichier ou dossier de ce type

Tout fonctionnait jusqu'à ce que je tente de désinstaller apache en exécutant un :

Code :
[== Indéfini ==]
sudo aptitude purge apache2

... dont voici le rapport ...

Code :
[== Indéfini ==]
Les paquets partiellement installés suivants seront configurés :
  libc6{b} multiarch-support
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
libc6 : Dépend: libgcc1 mais il ne sera pas installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :
1)     libc6                        
2)     multiarch-support            



Accepter cette solution ? [Y/n/q/?] Y
Les paquets suivants seront ENLEVÉS :
  libc6{a} multiarch-support{a}
0 paquets mis à jour, 0 nouvellement installés, 2 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 9 197 ko seront libérés.
Voulez-vous continuer ? [Y/n/?] Y
Subroutine File::Spec::Unix::canonpath redefined at /usr/share/perl/5.20/XSLoader.pm line 92, <DEBCONF_CONFIG> chunk 3.
Subroutine File::Spec::Unix::catdir redefined at /usr/share/perl/5.20/XSLoader.pm line 92, <DEBCONF_CONFIG> chunk 3.
Subroutine File::Spec::Unix::catfile redefined at /usr/share/perl/5.20/XSLoader.pm line 92, <DEBCONF_CONFIG> chunk 3.
(Lecture de la base de données... 408 fichiers et répertoires déjà installés.)
Suppression de multiarch-support (2.19-18+deb8u1) ...
Suppression de libc6:armhf (2.19-18+deb8u1) ...
dpkg (sous-processus) : impossible d'exécuter script post-removal installé (/var/lib/dpkg/info/libc6:armhf.postrm): Aucun fichier ou dossier de ce type
dpkg: erreur de traitement du paquet libc6:armhf (--remove) :
le sous-processus script post-removal installé a retourné une erreur de sortie d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
libc6:armhf
E: Sub-process /usr/bin/dpkg returned an error code (1)
E: Problem executing scripts DPkg::Post-Invoke '/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 4 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null'
E: Sub-process returned an error code
Failed to perform requested operation on package.  Trying to recover:

Je précise que ma RasPi est chez moi, branchée en ethernet sur ma box SFR et que j'y accède à distance en SSH (pour les commandes ci-dessus).

Si quelqu'un à une idée pour me dépatouiller, je suis preneur Smile

Merci d'avance
Répondre
#2

Salut
Très bizarre c'est comme si sudo avait été désinstallé. Le soucis c'est que pour l'installer il faut sudo pour exécuter apt-get. Sauf si tu as un compte root ....

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#3

tu as essayé :

s
s -

?
Répondre
#4

[email protected] :
Ce sont des commandes... ? "s", "s -"... Ou je n'ai pas bien saisi ce que tu voulais dire.

Chris57100,m :
En effet, ça ressemble à ça. Et d'ailleurs, tout mon répertoire /usr/bin/ était vide... Enfin, presque... Il restait seulement X11. Bizarre comme tu dis.

Étant un peu coincé, j'ai tout réinstallé ! Je n'avais pas de sauvegardes mais j'avais mis mon RasPi en marche que depuis ce week-end Smile

Merci à vous.

Je mets en Résolu
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)