Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

RaspiSMS - Reboot régulier nécessaire pour envoyer et recevoir SMS
#1

Bonjour,
J'ai installé la distribution raspiSMS ssur mon raspberry.
J'ai connecté une clef GSM achetée sur ebay (UNLOCKED 3G HUAWEI E176 HIGHSPEED USB STICK HSDPA 7.2 Mbps * MICRO SD * CRC 9 *)
J'ai mis une carte free à 2€

Tout fonctionne correctement et je peux envoyer et recevoir les sms depuis et vers les portables.

Seul hic, pour une raison que je n'arrive pas à comprendre, au bout d'une certain temps, RaspiSMS ne reçoit plus et n'expédie plus de SMS.
Par contre, si je reboote mon raspberry, tout remarche, les sms s'envoie au reboot et les sms en attente de réception sont bien reçus.

Malgré plusieurs essais, je ne sais pas au bout de combien de temps le soucis arrive, cela à l'air aléatoire.
Sur le raspberry, je n'ai rien d'autres que la distrib raspiSMS.

Actuellement je gère cela en faisant un reboot toutes les heures, mais ce n'est pas satisfaisant, je voulais utiliser les commandes via SMS mais s'il faut attendre une heure pour qu'elle s'active, ....

Auriez-vous une idée ?
Une piste ou des logs que je pourrais regarder ?
J'ai trouvé peu de doc sur RaspiSMS mis à part celle officielle : http://raspisms.raspbian-france.fr/documentation/


Merci de votre aide.
David
Répondre
#2

tu peux deja voir dans /var/log/ si tu as des erreurs .
Répondre
#3

euh ...
Je ne suis pas un pro unix :-(

Il faudrait que je cherche quoi et dans quel fichier ?

Voici le ls -l de /var/log/

-rw-r--r-- 1 root root 48956 avril 10 19:39 alternatives.log
drwxr-x--- 2 root adm 4096 avril 13 06:25 apache2
drwxr-xr-x 2 root root 4096 févr. 26 02:02 apt
-rw-r----- 1 root adm 1625955 avril 13 09:55 auth.log
-rw-r--r-- 1 root root 292042 févr. 26 02:02 bootstrap.log
-rw------- 1 root utmp 3072 avril 12 15:17 btmp
-rw-r----- 1 root adm 1472250 avril 13 09:42 daemon.log
drwxr-xr-x 2 root root 4096 avril 10 19:29 dbconfig-common
-rw-r----- 1 root adm 72605 avril 13 09:13 debug
-rw-r----- 1 root adm 31 févr. 26 02:00 dmesg
-rw-r--r-- 1 root root 742702 avril 11 10:54 dpkg.log
-rw-r--r-- 1 root root 24024 mars 14 16:16 faillog
-rw-r--r-- 1 root root 2288 févr. 26 03:03 fontconfig.log
drwxr-xr-x 2 root root 4096 févr. 26 02:00 fsck
-rw-r----- 1 root adm 1438601 avril 13 09:13 kern.log
-rw-rw-r-- 1 root utmp 292292 avril 13 09:25 lastlog
drwx--x--x 2 root root 4096 févr. 26 03:20 lightdm
-rw-r----- 1 root adm 1712827 avril 13 09:55 messages
drwxr-s--- 2 mysql adm 4096 avril 13 06:25 mysql
-rw-r----- 1 mysql adm 0 mars 14 16:16 mysql.err
-rw-r----- 1 mysql adm 0 avril 13 06:25 mysql.log
drwxr-xr-x 2 ntp ntp 4096 nov. 2 05:31 ntpstats
-rw-r--r-- 1 root root 544 févr. 26 03:20 regen_ssh_keys.log
drwxr-x--- 2 root adm 4096 déc. 28 22:52 samba
-rw-r----- 1 root adm 249933 avril 13 09:55 syslog
-rw-r----- 1 root adm 88 févr. 26 03:21 user.log
-rw-rw-r-- 1 root utmp 208896 avril 13 09:25 wtmp
-rw-r--r-- 1 root root 6875 mars 14 16:10 Xorg.0.log
Répondre
#4

Peut être un problème de gestion d'énergie des ports USB (ca arrive pour certaines clés Wifi)

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#5

j'ai un hub alimenté, je vais essayer avec.
Merci de l'aide
David
Répondre
#6

J'ai mis le hub alimenté.
Toujours pareil, RaspiSMS met une plombe avant de traiter le sms.
Pas vraiment de cohérence sur les réceptions (pas de logique de traitement toutes les x minutes).
Voici mes différents tests :
Heure émission - Heure réception - délai
08:25 - 08:44 : 00:19
07:59 - 08:16 : 00:17
22:03 - 22:29 : 00:26
20:15 - 20:37 : 00:22
18:07 - 18:45 : 00:38
18:33 - 18:45 : 00:12
17:12 - 17:49 : 00:37
15:06 - 15:30 : 00:24
10:03 - 10:17 : 00:14
17:30 - 17:52 : 00:22


Y a t'il un support pour RaspiSMS à qui s'adresser ou dois-je directement écrire à [email protected] ?

David
Répondre
#7

Je continue mes tests et essais.

J'ai donc envoyé à des utilisateurs (environ 60) un sms pour qu'ils me disent : la date/heure de réception de mon sms et de répondre à ce sms en m'indiquant la date/heure de leur envoi.

Les SMS envoyés par RaspiSMS sont reçus par les utilisateurs comme s'il y avait 1 SMS envoyé par RaspiSMS toutes les 30 minutes
Les SMS envoyés par les utilisateurs sont mis dans la BD RaspiSMS en moyenne 30 Minutes après l'émission de celui-ci.

Les 30 minutes sont trop bien identifiés et je vois bien un traitement fait par RaspiSMS toutes les 30 minutes.

Si j'ai pas des nouvelles de Raspbian, je me plongerais dans le code ....

David
Répondre
#8

Je pense que le souci n'est pas dans RaspiSMS mais dans la configuration de gammu.
Si j'ai bien compris la doc, tu devrais jeter un oeil à /etc/gammu-smsdrc (cf https://wammu.eu/docs/manual/smsd/config.html)
Répondre
#9

CrazyCat a écrit :Je pense que le souci n'est pas dans RaspiSMS mais dans la configuration de gammu.
Si j'ai bien compris la doc, tu devrais jeter un oeil à /etc/gammu-smsdrc (cf https://wammu.eu/docs/manual/smsd/config.html)

Merci pour l'aide.

En efet, je dédouane RaspiSMS (désolé de l'avoir suspecté :8 ).

Avec tes docs, j'ai pu aller plus loin et voir que les SMS envoyés étaient bien mis dans /var/spool/gammu/outbox/ très rapidement par RaspiSMS.
Mais gammu mettait une plombe pour les envoyer.

Maintenant je vais creuser un peu plus pour savoir pourquoi cela se passe comme cela ......

David
Répondre
#10

Je pense avoir trouvé.

En fait mon fichier /etc/gammurc contenait 2 dongles (2 fois le même), un sur le SUB0 et un sur le USB1
J'ai modifié le fichier pour en garder un seul
j'ai envoyé 3 sms depuis mon Rasp vers mon portable
3 sms depuis mon portable vers les rasp
=> Les 6 ont été reçus dans les 10 secondes suivantes ....


Je me dis que mon premier soucis a été que je n'alimentais pas ma clef et que cela posait des soucis
alors j'ai mis un hub qui a résolu mon soucis d'alim mais a rajouté un nouveau dongle qui a apporté un nouveau soucis ...

Là maintenant je repars dans une série de tests pour bien valider que tout fonctionne.

Désolé d'avoir cru que raspiSMS était suspects !

David
Répondre
#11

De ce que j'ai vu, c'est un souci récurrent sur gammu, il semblerait qu'il faille jouer avec les timeout.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)