Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Raspi' et 433mhz
#1

Bonjour à tous, je viens solliciter votre aide car je bute depuis quelques jours, malgré mes recherches sur internet et le forum je n'ai pas eu de réponse satisfaisante pour résoudre cela.
Dans le cadre d'un de mes projet je souhaiterai utilisé un émetteur et récepteur 433 mhz pour faire communiqué un détecteur PIR et notre fameux bijou (oui le raspberry :p)

Le but étant de branché la patte "out" du PIR (Passive infrared sensor) sur l'émmeteur pour qu'il envoi un signal au raspberry, qui aura sur GPIO 7 le "out" du récepteur. (Bien sur je comprend qu"il faudra au final ajouter un Micro contrôleur pour qu'elle puisse envoyé tout ça correctement)

J'ai suivi plusieurs tuto' notamment l’excellent tutoriel de idleman : http://blog.idleman.fr/raspberry-pi-10-c...par-radio/

Et je suis bloqué au niveau de l'envoi.

Je m'explique, lors du test du récepteur, je reçois en permanence des 0 et des 1, sans aucun sens (à mes yeux^^), certains me dirons que c'est normal, et que cela vient du bruit ? (De plus habitant en ville et en face de la gare cela n'aide surement pas)

Disons que je souhaiterai envoyé par exemple 010101 (pour faire simple) et une fois ce code détecté par la framboise (oui oui toujours notre Raspberry Big Grin) il actionne un script, sauf que je ne sais pas vraiment comment m'y prendre, beaucoup de tutoriel bien que très détaillé sont pour le arduino :

http://faitmain.org/volume-1/dispositifs.html
http://tiptopboards.free.fr/arduino_foru...hp?f=2&t=9

Comment envoyé un code sur la patte out de l'emmeteur et comment l'intercepter sur le raspberry. Je suis actuellement en train de testé tout sur le raspberry :

Envoyé sur GPIO x ---> 010101 , puis recevoir ce signal sur GPIO y (l'intérêt est uniquement de bien voir que cela fonctionne avant de la mettre en production) plus tard j'utiliserai surement un Micro contrôleur ATmega 328-pu avec bootloader pour traiter correctement l'envoi depuis les PIR

Peut être que quelqu'un parmi vous à déjà commencé à travaillé sur le sujet et serais prêt à me donner son aide Smile

Merci d'avance à vous tous
Répondre
#2

Bonjour,

comme tu l'as constaté, il y a bien trop de bruit pour pouvoir exploiter directement le signal du capteur PIR sur l'émetteur RF. Il faut obligatoirement utiliser un protocol de communication. Je te propose l'article suivant qui met justement en oeuvre une communication Arduino=>RPi. Le protocole est géré par la librairie RCSwitch, dispo pour Arduino et RPi !
http://www.homautomation.org/2013/09/21/...pberry-pi/
Répondre
#3

Merci pour ta réponse, je me penche sur ton lien en rentrant Smile
Répondre
#4

Yaug (présent sur ce forum) travaille avec une équipe sur le sujet..
http://www.ydle.fr/
http://forum.ydle.fr/
Répondre
#5

Cool merci Big Grin
Répondre
#6

Présent ! Big Grin

Serial Organisateur d'aPIro
Bloggeur Bidouilleur
Ydle, domotique DIY basée sur un raspberry pi
Répondre
#7

Hello Yaug, peut être pourrais tu m'aider concernant mon projet ? Smile
Répondre
#8

Je peux essayer de te guider, mais je ne fais pas le service après vente d'idleman (remarque il ne le fait plus non plus Big Grin)

Quel est le pb actuellement ?

Serial Organisateur d'aPIro
Bloggeur Bidouilleur
Ydle, domotique DIY basée sur un raspberry pi
Répondre
#9

Merci de me proposer ton aide.
Le but est que je place une PIR à un endroit et que dès qu'elle s'active elle envoi un signal sur l'emmetteur et que le raspberry l’interprète et lance un script.
En gros imaginons un scénario:
La PIR détecte une personne, donc la sortie "out" envoi du courant, un microcontrôleur (ou autre) enverra un signal disons par exemple "0101010111" le raspberry reçoit ce signal, l’interprète et exécute le script qui myscript.py.
Actuellement je reçoit plein de 0 et de 1 et c'est indéchiffrable. Encore merci penses tu pouvoir m'aider ?
Répondre
#10

t'aider, je pense pas avoir le temps
te guider, oui.

Tu as fait le tuto d'idleman en entier?
Car c'est de là que j'ai commencé avec la radio.
Alors au début on en chie, mais ça permet de comprendre pas mal de chose.
J'aurais tendance à te conseiller de réussir à envoyer / récupérer une info bidon avec son tuto ou le mien.
Mais dans un premier temps, réussi un de ces tutos.

Serial Organisateur d'aPIro
Bloggeur Bidouilleur
Ydle, domotique DIY basée sur un raspberry pi
Répondre
#11

Merci pour ta réponse, oui le mot serait plus guider , et cela me suffira amplement venant de toi Smile
J'ai fais le tuto d'idle man , mais n'ayant pas d'équipement en 433 mhz j'ai voulu le simuler, mais pour l'instant en vain.
Je vais faire ton tutoriel aujourd'hui n'ayant pour l'instant pas d'arduino, je vais voir comment faire.
Merci encore
Répondre
#12

c'est sur quand sans le matériel c'est compliqué :lol:

Serial Organisateur d'aPIro
Bloggeur Bidouilleur
Ydle, domotique DIY basée sur un raspberry pi
Répondre
#13

J'ai commandé l'arduino, je devrais le recevoir mercredi, je vous tiendrais au courant Smile
Répondre
#14

bonjour , j ai moi meme fais les differents tuto d idle mais je n arrive pas a lire les infos de mes telecomandes 433
quand je lance rfsnifer rien ne s affiche ou le radio emission d idle rien non plus, j ai mis une led entre le data et le gnd et la led reste allumé constament.
si quelqu un peut m aidé
merci
Répondre
#15

Salut Nathan, j'avais le même problème que toi, j'ai acheté un arduino UNO et j'ai fais ce TUTO :

http://www.homautomation.org/2014/03/02/...-receiver/

ca marche nikel Smile
Répondre
#16

Pourquoi ça ne fonctionne pas chez moi?
Répondre
#17

La LED s'allume s'est normal il y a énormément de bruit, c'est pour ca que j'ai utilisé arduino c'est plus simple
Répondre
#18

merci pour ton aide , j ai recu mon arduino uno et ca fonctionne
mais je capte les capteurs de mouvement chez moi mais rien avec les prises chacon ni la telecommande de mes vollet rolant ?
Répondre
#19

Ils sont en 433 mhz aussi ?
Tu as la doc technique quelque part ?

Serial Organisateur d'aPIro
Bloggeur Bidouilleur
Ydle, domotique DIY basée sur un raspberry pi
Répondre
#20

Oui il sont en 433 aussi les prise sont des chacon dio les volet sont des 433 de marque dooma acheter chez automatisme passion
Répondre
#21

Non je n ai pas de d'oc mais les volet sont bien en 433,92 mhz
Répondre
#22

Les prises chacon DIO, j'arrive à les faire tourner sans aucun problèmes avec le tuto d'idleman
Quand tu dis "rien sur les prise et les volets" il faut donner plus d'infos par contre ...
- Comment as tu testé ?
- Qu'est ce que tu obtiens au juste ? (et rien n'est pas une réponse Big Grin)

Serial Organisateur d'aPIro
Bloggeur Bidouilleur
Ydle, domotique DIY basée sur un raspberry pi
Répondre
#23

merci pour ta reponse ,quand j appuie sur la telecommande de la prise chacon, j ai pas le code qui s affiche sur le moniteur serie .
les capteurs de mouvement sont bien detecter (protocole 1, code1556.... code 24bits )
tu tape quoi dans la case code de yana-server juste un code (12356824) j arrive a les faire fonctionner avec la telecommande
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)