Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Raspi en relais wifi et Motioneye
#1

Bonjour,

Je suis en train de faire un réseau de caméra avec des raspi, motion et motioneye.

le problème est le suivant:

un bâtiment se trouve entre les caméras et l'endroit où est le réseau principal.

J'ai fait un relais wifi avec un raspi et deux clés wifi.(AP Raspi)


Dans l'idée, j'aimerais faire un réseau de trois raspi + webcam reliées à un AP.

Cet AP(wlan0, 10.0.0.1) est en liaison avec le réseau principal par le biais d'une autre clé wifi(wlan1, 192.168.1.80) qui pointe sur le routeur-wifi.

[Image: reseau10.jpg]

En gros :
  • si le raspi + webcam pointe sur le routeur, le laptop sur le routeur j'accède à la vidéo (192.168.1.74:8081) ou a la console motioneye (192.168.1.74:80) en tapant l'adresse dan mon navigateur.
  • si le raspi + webcam pointe sur l'AP, le laptop sur le routeur, pas d'accès à la vidéo, accès à internet depuis le laptop
  • si le raspi + webcam pointe sur l'AP, le laptop sur l'AP, pas d'accès à la vidéo, j'ai internet depuis le laptop


en changeant l'adresse ip de l'AP en 192.168.1.100 :
  • si le raspi + webcam pointe sur l'AP, le laptop sur l'AP j'accède à la vidéo (192.168.1.74:8081) ou a la console motioneye (192.168.1.74:80) en tapant l'adresse dan mon navigateur. Pas d'accès internet depuis le laptop
  • si le raspi + webcam pointe sur l'AP, le laptop sur le routeur, pas d'accès à la vidéo, pas d'accès à internet depuis le laptop


Le desktop n'a jamais la vidéo, mais toujours un accès internet.

J'ai pas de pare-feu sur mon routeur et pas de règles particulières.

J'ai essayé de changer les règles iptables, les ip de chaques modules pour être strictement sur le même réseau. Mais je n'arrive pas à faire traverser ce ¢¬πø¡≠°}Ω|†}|][]Ç€#∑ serveur motioneye ou ce flux vidéo à travers cet AP.

Une semaine que je cherche.... et là je sèche.

Suivant vos demandes je mettrai le contenu des fichiers interfaces, iptables et conf.

Auriez-vous une idée de ce qui cloche ?
Répondre
#2

Du nouveau...

Après avoir lu cet article, j'ai changé les hostnames de chaque raspi du réseau. (Le wifi avec Jessie)

Depuis, si le laptop est sur l'AP j'arrive à me connecter sur la console et la vidéo de cette façon : http://[hostname].local/

Par contre toujours pas de connexion depuis le réseau principal.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)