Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[Raspberry PI 2] [Alfa AWUS036AC-Wireless adaptater] [KALI 2-0-1]
#1
Bonjour ,


J'essaie désesperément d'utiliser mon Alfa AWUS036AC (Wireless adaptater) avec Linux KALI 2-0-1 et mon Raspberry PI 2.
J'utilise un hub USB alimenté pour connecter mon Alfa AWUS036AC à mon Raspberry PI.

[email protected]:~/Desktop# iwconfig
lo no wireless extensions.
eth0 no wireless extensions.
[email protected]:~/Desktop# uname -a
Linux kali 3.18.16-v7 #1 SMP PREEMPT Thu Aug 13 11:35:22 CDT 2015 armv7l GNU/Linux
[email protected]:~# lsusb
Bus 001 Device 012: ID 04d8:xxxx Microchip Technology, Inc.
Bus 001 Device 011: ID 0461:xxxx Primax Electronics, Ltd
Bus 001 Device 010: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter
Bus 001 Device 009: ID 0a81:xxxx Chesen Electronics Corp. Keyboard
Bus 001 Device 008: ID 0835:xxxx Action Star Enterprise Co., Ltd
Bus 001 Device 007: ID 0835:xxxx Action Star Enterprise Co., Ltd
Bus 001 Device 006: ID 13fe:xxxx Kingston Technology Company Inc. Flash drive
Bus 001 Device 005: ID 0835:xxxx Action Star Enterprise Co., Ltd
Bus 001 Device 004: ID 0835:xxxx Action Star Enterprise Co., Ltd
Bus 001 Device 003: ID 0424:xxxx Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:xxxx Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:xxxx Linux Foundation 2.0 root hub
[email protected]:~#
[email protected]:~/Desktop# airmon-ng
PHY Interface Driver Chipset
[email protected]:~#
[email protected]:~# sudo apt-get install linux-headers-$(uname -r)Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-headers-3.18.16-v7
E: Couldn't find any package by regex 'linux-headers-3.18.16-v7'
[email protected]:~#


J'ai tout essayé pour utiliser mon Alfa AWUS036AC avec Raspberry PI 2 mais sans succès.

J'ai essayé ceci :
http://hackthistv.com/blog/alfa-awus036a...for-linux/
ou ceci : https://github.com/gnab/rtl8812au
ou cela : https://forums.hak5.org/index.php?/topic...6ac/page-2
ou ca ; http://askubuntu.com/questions/98416/err...e-in-place


Merci pour vos conseils ,
Répondre
#2
Salut
Il y a un module pour le kernel 3.12.22 mais possible qu'en recompilant les sources ça fonctionne pour ton noyau 3.18
https://www.raspberrypi.org/forums/viewt...55#p570255
Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

A propos de Communauté francophone RPi

Communauté francophone RPi est un forum d'aide et de partage autour du Raspberry Pi et des micro-ordinateurs.