Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[RESOLU]Un password Mysql récalcitrant ?
#1
Bonjour!
Je me suis lancé un projet sur Raspberry de serveur et comme je suis débutant, j'ai préféré la solution LAMP, la plus simple? (Linux Apache Mysql Php).
Il existe de nombreux tuto quasi identiques sur la toile mais mon soucis est survenu vers la fin la du processus et de mon point de vue il me semble très bête..
Lors de l'installation de mysql-server , on me demande donc d'entrer un mdp pour lequel j'ai pris un certains soins à rendre complexe avec des symboles, majuscules et .. Une parenthèse!
C'est donc lorsque que je dois fournir à nouveau le mdp une fois l'installation terminée que les ennuis commencent ..
Code :
[== Indéfini ==]
[email protected]:~ $ mysql --user=root --password=xxx)x
-bash: erreur de syntaxe près du symbole inattendu « ) »

Est-ce que je comprend bien que les parenthèses doivent être bannis des mdp en ligne de commande? Dans mes recherches j'ai pu lire que n'importe quel symbole pouvait être utilisé pour un root mdp mysql mais ça vaut ce que ça vaut..

Ce que j'ai fait:
-stop et restart mysql-server
-réinstaller mysql-server (mais les données sont resté stockées comme je m'y attendait)
-[En cours] Upgrades ( "sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y dist-upgrade" )
Ce que je n'ai pas réussis à faire:
-repartir de rien en donnant un nouveau mdp lors d'un setup tout neuf.
-changer le root password.

D'autres part, j'ai ensuite installé Phpmyadmin en utilisant le même mdp root avec cette parenthèse sans message d'erreur mais lorsque je tente de vérifier son fonctionnement sur http://<iprasberry>/phpmyadmin --> 404 Not Found !

Voilà, j'espère avoir exposé cette bêtise de mdp clairement.. ^^'
Merci beaucoup à tous et à très vite! :)
TaTaD
Répondre
#2
Essaie avec :

Code :
[email protected]:~ $ mysql --user=root -p

A ce moment-là, le mot de passe te sera demandé après avoir validé la commande. Quand tu le saisiras, aucun caractère n'apparaîtra, c'est normal.

L'autre problème ne me semble pas lié. Ca vient peut-être de ta configuration d'apache, mais comme ça, je ne peux pas en dire plus.
Répondre
#3
Pour ton accès à phpmyadmin, un souci de casse ? regarde dans /etc/phpmyadmin/apache.conf comment est écrit phpmyadmin dans la ligne commençant par Alias
Tu as une chance sur deux pour avoir à utiliser http://<iprasberry>/phpMyAdmin
Répondre
#4
Bonjour!
Merci beaucoup pour votre aide, j'ai réussis à m'identifier sur mysql-server :D
En effet les deux soucis n'étaient pas liés, pour phpmyadmin j'ai vérifié le fichier apache.conf:
Code :
[== Indéfini ==]
# phpMyAdmin default Apache configuration

Alias /phpmyadmin /usr/share/phpmyadmin
Je pensais résoudre le soucis en relançant son installation mais voilà ce que ça a donné:
Code :
[== Indéfini ==]
[email protected]:~ $ sudo aptitude install phpmyadmin
E: dpkg a été interrompu. Il est nécessaire d'utiliser « sudo dpkg --configure -a » pour corriger le problème.
W: Impossible de verrouiller le fichier cache : cela est en général dû à une installation simultanée de paquets avec dpkg ou un autre outil comme APT. Ouverture en mode lecture seule : AUCUNE des modifications de l'état des paquets que vous pourrez faire ne sera conservée.
E: dpkg a été interrompu. Il est nécessaire d'utiliser « sudo dpkg --configure -a » pour corriger le problème.
J'ai peut-être fait une bêtise.. :/
Je m'arrête pas de chercher ! ^^
TaTaD
Bonne journée
Répondre
#5
Bon, il y a diverses choses là Smile

Tout d'abord, ton souci apt. Est-ce que tu n'aurais pas un autre process qui fait du apt ? un sudo ps auxf | grep apt devrait te le(s) montrer.

Ensuite, refaire l'installation n'est pas la solution, c'est souvent le dernier recours. Si ton fichier est présent, le souci est ailleurs.
Première question idiote: as-tu relancé apache après avoir installé phpmyadmin ?
Seconde question idiote: qu'obtiens-tu en faisant sudo ls -lha /etc/apache2/conf.d ?
Répondre
#6
Pour la commande sudo ps auxf | grep apt , les deux premières lignes que me renvoie le terminal débutent par pi puis des chiffres, la deuxième contient énormément de thermes mais je ne vois apt inscrit qu'une seul fois; à la première ligne
Code :
[== Indéfini ==]
\_ grep --color=auto apt

Je ne pense pas avoir relancé apache2.. Mais je commence à prendre l'habitude de voyager dans les dossiers via le terminal et je ne pense pas avoir ce fichier conf.d !
Code :
[== Indéfini ==]
[email protected]:/etc $ cd apache2
[email protected]:/etc/apache2 $ ls
apache2.conf  conf-available  conf-enabled  envvars  magic  mods-available  mods-enabled  ports.conf  sites-available  sites-enabled
Même avec -lha :
Code :
[== Indéfini ==]
[email protected]:/etc/apache2 $ sudo ls -lha /etc/apache2/conf.d
ls: impossible d'accéder à /etc/apache2/conf.d: Aucun fichier ou dossier de ce type
Le tuto m'avais proposé pour installer apache de:
(droits admin)
-sudo aptitude update
-sudo aptitude upgrade

-sudp aptitude install apache2
(donner des droits au dossier apache)
-sudo chown -R pi:www-data /var/www/html/
-sudo chmod -R 770 /var/www/html/
Puis j'avais bien vérifié qu'apache fonctionnait. (guide)
TaTaD
Répondre
#7
Tout d'abord, redémarre apache pour voir si ça ne fonctionnerait pas (sudo service apache2 restart)

Si ça ne marche pas, j'ai compris le souci: tu as une version (peut-être celle de raspbian est comme ça) où tu as 2 répertoires de conf, conf-available et conf-enabled.
L'installation de phpMyAdmin n'est peut-être pas bien adaptée, fais un ls -lha /etc/apache2/conf-available/ et ls -lha /etc/apache2/conf-enabled/

Si dans aucun des deux tu ne vois un phpmyadmin.conf, il faut que tu le fasses à la main:
Code :
sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-enabled/phpmyadmin.conf
Ensuite, tu peux redémarrer apache et ça devrait fonctionner
Répondre
#8
Bonjour, et bonne semaine! ^^

Eh bien ce lundi pluvieux s'annonce comme une réussite! Malgré le petit avertissement Warning: Unit file of apache2.service changed on disk, 'systemctl daemon-reload' recommended., tes instructions m'ont permis d'accéder à cette fameuse page Phpmyadmin, merci beaucoup @CrazyCat!
Même si je pense tomber sur de nouvelles difficultées prochainement, je considère ce topic comme résolu histoire que cela reste clair si un autre internaute venais à rencontrer la même difficulté que moi.. : ) (J'ai bien cherché sur le web avant de poster!)

Merci encore d'avoir passé du temps pour un débutant tel que moi!
TaTaD
Répondre
#9
Content que ça ait marché.

Par contre, je me rends compte que je t'ai fait faire ça d'une manière pas bien orthodoxe pour apache, il aurait fallu faire:
Code :
sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo a2enconf phpmyadmin
Le résultat est exactement le même en pratique, mais ça te permet de facilement désactiver phpmyadmin si tu le désirais en faisant ensuite sudo a2disconf phpmyadmin.

Mais bon, ce sont les règles de l'art, rien de bien extraordinaire et tant que phpmyadmin ne sera pas adapté à cette nouvelle version des configuration apache, ça ne sert à rien de s'embêter avec ça, il faudra chaque fois bricoler.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

A propos de Communauté francophone RPi

Communauté francophone RPi est un forum d'aide et de partage autour du Raspberry Pi et des micro-ordinateurs.