Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[RESOLU] :) :) OpenElec sur Rpi2, et pb avec tuner avermedia A850
#1

Bonjour,

Comme annoncé dans ma présentation, je reviens vous solliciter.

J'ai un Rpi2, j'ai installé OpenElec 6.0.0 - Kodi 15.2
J'ai aussi un tuner USB Avermedia A850, qui fonctionne bien avec d'autres ordinateurs sous ubuntu ou mint en utilisant MeTV ou Kaffeine.
Maintenant je voudrais utiliser mon tuner directement sur le Rpi2.

Après avoir branché le tuner sur un usb du Rpi2, lorsque je me connecte depuis un autre ordi à mon RPI en ssh, j'obtiens
Code :
OpenELEC:~ # dmesg
...
[    5.625285] usb 1-1.5: dvb_usb_v2: found a 'AverMedia AVerTV Volar Black HD (A850)' in cold state
[    5.661587] usb 1-1.5: dvb_usb_v2: downloading firmware from file 'dvb-usb-af9015.fw'
[    5.736891] usb 1-1.5: dvb_usb_v2: found a 'AverMedia AVerTV Volar Black HD (A850)' in warm state
[    6.122252] usb 1-1.5: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[    6.122435] DVB: registering new adapter (AverMedia AVerTV Volar Black HD (A850))
[    6.202226] i2c i2c-3: af9013: firmware version 4.95.0.0
[    6.203720] usb 1-1.5: DVB: registering adapter 0 frontend 0 (Afatech AF9013)...
[    6.270066] MXL5005S: Attached at address 0xc6
[    6.276262] usb 1-1.5: dvb_usb_v2: 'AverMedia AVerTV Volar Black HD (A850)' successfully initialized and connected
[    6.276426] usbcore: registered new interface driver dvb_usb_af9015

Pour autant, quand je vais depuis l'accueil de Kodi dans système > Informations Système , le menu montre "Enregistreur Vidéo" en grisé, comme s'il n'y en avait pas.

J'ai installé et activé plusieurs clients PVR (MythTV PVR Client, VDR VNSI Client) que j'ai paramétrés avec comme nom d'hôte VDR ou adresse IP : localhost.
Et j'ai activé la fonction TV dans Système > Paramètres > TV . Mais malgré tout ça, je n'ai toujours pas de nouveau menu TV/Radio qui apparaît sur le menu d'accueil, et dans l'info matérielle, "enregistreur vidéo" reste grisé.

J'ai aussi installé l'extension vidéo MythBox, mais elle plante avec comme message: "Connect to MySQL failed..." . Mais bon je l'ai essayé en désespoir de cause, je préfèrerai ne pas m'en servir si ça marche directement dans kodi.

Quelqu'un a-t-il une idée de ce que je fais mal?

A bientôt j'espère.
Xavier.

Modif du 08/01/16 : passage en résolu (trop content).
#2

Bonjour

Sous OE6/kodi tu dois activer 2 extensions pour faire fonctionner le tuner :

- le frontend (le client) : par exemple "VDR VNSI Client" comme tu as fais
- la backend (le serveur) : c'est lui qui pilote le tuner tu dois activer l'extension correspondant au frontend (VDR) choisi ci-dessus. Donc sous kodi aller dans parametres/extensions/depuis le dépot/OpenELEC Mediacenter OS Add-ons / services et activer "VDR PVR Backend"

Ensuite il te faudra configurer le backend "VDR PVR Backend" via le menu configurer de l'extension (scan des chaines...)

J'ai la même configuration mais avec un double tuner TNT sony play TV...pour l'instant je n'arrive pas à scanner les chaines de mes 2 tuners (uniquement un tuner est visible sous kodi...je continue de chercher...).

a+
#3

Merci, c'est génial, j'y suis arrivé :lol: :lol: :lol:

Comme quoi un boulet + une communauté ça peut faire des trucs biens.

Bon maintenant faut que j'aille acheter un ampli de signal parce que la qualité est un peu faible, mais sinon je vais enfin pouvoir justifier auprès de ma chère et tendre toutes ces couillonnades que j'achète (raspPI, tuner TV usb, alim, boîtier, câbles réseaux, dongle wifi et bluetooth,...) et tous ces câbles derrière la télé Smile .

Parce jusque là, j'étais pas très crédible avec mes "Tu vas vois, ça va marcher, c'est une super solution, ..."

Donc merci beaucoup à toi, conduisant (ouais je me répète, mais c'est sincère).

Et si quelqu'un veut mon témoignage pour s'en sortir dans une situation similaire, pas de souci.

A plus,
Xav.
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)