En raison de spams récurrents, les messages des nouveaux inscrits sont modérés a priori. Ne vous inquiétez pas si vous ne voyez pas apparaitre votre message immédiatement sur le forum. (November 04, 2021) x

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

RAID5 avec mdadm
#1

Bonjour,

j'essaie de monter un NAS avec ma Raspbian.
Pour ceci j'utilise un Quad sata hat tel que celui-ci : https://shop.allnetchina.cn/collections/...berry-pi-4

il existe un bug de reconnaissance des disques, j'ai donc appliqué un correctif que voici :
# JMicron drive fix
KERNEL=="sd*", ATTRS{idVendor}=="1058", ATTRS{idProduct}=="0a10", SUBSYSTEMS=="usb", PROGRAM="/root/serial.sh %k", ENV{ID_SERIAL}="USB-%c", ENV{ID_SERIAL_SHORT}="%c"
J'ai corrigé les idVendor et idProduct qui ne sont pas les bon et évidement créé le serial.sh associé.

Je ne pense pas que ce soit lié, mais je le précise.

L'idée est donc de monter une pile RAID5.

Hors RAID mes 4 disques sata sont bien reconnus et surtout bien nommés (/dev/sda /dev/sdb /dev/sdc /dev/sdd)
Tant que je n'essaie pas de créer le RAID cela ne bouge pas.

Lorsque j'essaie de créer mon RAID5 via mdadm la pile RAID5 se monte correctement.
Mais au bout de quelques minutes, les disques "changent de nom" sda devient sde et sdb devient sdf.
un peut plus tard, j'ai réguliérement sdc et sdd qui prennent le nom sda et sdb.

Tant que je ne monte pas le RAID, les disques semblent garder leur nom.

Enfin j'ai déjà essayé de monter le raid en utilisant leur PARTUUID au lieu du sdX
Le RAID se monte bien, mais rapidement (au moment du changement de nom/chemin) il tombe de nouveau.

Quelqu'un aurait il déjà rencontré ce cas ou aurait-il une piste s'il vous plait ?


Par avance merci pour toute aide ou tout conseil Wink
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)