En raison de spams récurrents, les messages des nouveaux inscrits sont modérés a priori. Ne vous inquiétez pas si vous ne voyez pas apparaitre votre message immédiatement sur le forum. (November 04, 2021) x

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Pygame 2 sur Raspberry Buster
#1

Bonjour,

Je cherche à installer Pygame 2 sur un Raspberry Buster. J’utilise la version 5.10.11 de l’OS.

Visiblement il faut mettre à jour le SDL pour qu’il soit compatible avec Pygame 2.

Quelqu’un connaitrait-il le process de mise à jour du Raspberry pour que Pygame 2 fonctionne ?

Grand merci par avance
Répondre
#2

Bêtement je dirais sudo apt-get install libsdl libsdl-dev après avoir fait sudo apt-get update et sudo apt-get upgrade

https://www.pygame.org/wiki/GettingStarted#Compilation te donnera peut-être des infos plus fiables
Répondre
#3

Pour Pygame 2 ?
Tu as essayé ?
Répondre
#4

Non, je n'utilise pas pygame, je n'ai fait que lire la page et donc bêtement émettre une idée.
Sans savoir ce que tu as tenté, l'état de ton système ni rien d'autre, il est difficile de t'aider. Si l'installation échoue, les logs peuvent être utiles et donner de précieuses indications.
Répondre
#5

Merci beaucoup. Je comprends.

L'installation n'échoue pas, mais elle est incomplète. Il faut dire que je l'ai faite avec un simple "ip install --upgrade pygame"

Je vais tenter un " apt-get install python3-pygame " ça sera peut-être plus efficace
Répondre
#6

Finalement, j'ai réussi à installer SDL2 et Pygame 2.

Mon code tourne mais il est terriblement lent. J'ai essayé de l'optimiser mais ça ne change rien. Ca ne vient pas de là. Par contre, si je reviens à Pygame 1.9.6, le jeu retrouve sa vitesse normale.

J'ai abandonné. Je pense que Pygame 2 n'est pas fait pour un Raspberry 3. :(
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)