Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Problème lightdm sur une installation astroprint astrobox
#1

Bonjour a tous,
après avoir installé une version astroprint 0.8 sur un raspberry pi B+, et installé un afficheur LCD 7" tactile avec succès, je suis passé sur un raspberry pi3, j'ai installé la version 0.9 d'astrobox avec succès, mais mon problème intervient au passage en mode desktop (mode terminal fonctionne bien).
Dans raspi-config, on peux choisir soit mode terminal (normal ou autolog), et mode desktop (avec autolog).
Lorsque je choisi desktop avec autolog, il me dit d'installer le packet lightdm.
J’installe donc lightdm, puis fais un update.
Je resélectionne desktop + autolog.
Au démarrage, j'arrive sur le bureau, avec les cases login et mot de passe, je tape donc login:pi/pass:raspberry.
l'écran passe au noir, puis reviens a ces mêmes cases.
Je suis bloqué a ce point d'autologin, je pense que le souci vient de lightdm mais je n'ais plus d'idée.

Pouvez vous m'aider?
merci de votre aide

@ bientot
Répondre
#2

Salut
As tu regardé les logs dans /var/log. Il doit y avoir un fichier pour lightdm sinon pour la partie serveur X qui doit donner plus d'information
Question con : tu es certain pour le mot de passe ? Genre le a est un q ...

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#3

Bonjour, merci de ta reponse, je vais regarder ce fichier log.
Le clavier est bien configuré, car en mode terminal j'arrive à me connecter avec pi/raspberry, et le clavier à été bien configuré dans raspi-config
Répondre
#4

bon ben pour le moment, je ne trouve rien dans le log qui me fasse avancer.
Si quelqu'un veux tester l'image: https://www.astroprint.com/downloads et réussit a avoir le bureau, qu'il me fasse signe Smile

Je pense que les développeurs d'astrobox on du retirer trop de packets, ce qui bloc le démarrage du bureau.

Merci a vous Smile
Répondre
#5

Je rejoins malgré tout l'avis de Chris, le terminal et lightdm n'utilisent pas forcément le même clavier.
Cherche un fichier qui serait /etc/X11/xorg.conf.d/10-evdev.conf (ou approchant) et qui contient une section:
Code :
Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
    Option "XkbLayout" "us"
EndSection
Remplace dans la dernière ligne le "us" (ou ce qu'il y a) par "fr".

Et si ça ne marche pas, copie ici ton fichier /etc/lightdm/lightdm.conf

(source: https://bbs.archlinux.org/viewtopic.php?id=186550)
Répondre
#6

Donc, apres beaucoup de recherche, et avec un ami maitrisant linux, rien a voir avec le clavier.
En faite la nouvelle version d'astroprint pour pi3 est totalement dépourvue de bureau.
Il a donc fallu installer LXDE (ou autre) pour avoir quelque chose, cependant, pour le moment, ce n'est pas du tout optimisé, ca ram autant que sur le pi B+.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)