Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Problème d'installation écran 2.2" Serial SPI TFT LCD
#1

Bonjour à tous,

Je demande votre aide car je n'arrive pas à faire fonctionner mon écran 2.2" Serial SPI TFT LCD sur ma raspberry pi.
Au démarrage il clignote blanc assez rapidement.

Le lien de mon écran :
2.2" Serial SPI TFT LCD


Et voici ma config :

/etc/modules
Code :
modprobe fbtft dma
fbtft_device name=tm022hdh26

/boot/config.txt
Code :
dtparam=spi=on

/boot/cmdline.txt
Code :
dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=noop rootwait fbcon=map:10 fbcon=font:VGA8x8

dmesg
Code :
[   12.506498] fbtft_device:  SPI devices registered:
[   12.513466] fbtft_device:      spidev spi0.0 500kHz 8 bits mode=0x00
[   12.522022] fbtft_device:      spidev spi0.1 500kHz 8 bits mode=0x00
[   12.530580] fbtft_device:  'fb' Platform devices registered:
[   12.538382] fbtft_device:      bcm2708_fb id=-1 pdata? no
[   12.545845] fbtft_device: Deleting spi0.0
[   12.555200] fbtft_device:  GPIOS used by 'tm022hdh26':
[   12.576394] fbtft_device:    'reset' = GPIO25
[   12.582811] fbtft_device:    'dc' = GPIO24
[   12.596340] fbtft_device:    'led' = GPIO18
[   12.602493] fbtft_device:  SPI devices registered:
[   12.610305] fbtft_device:      spidev spi0.1 500kHz 8 bits mode=0x00
[   12.619055] fbtft_device:      fb_ili9341 spi0.0 32000kHz 8 bits mode=0x00
[   13.651261] graphics fb1: fb_ili9341 frame buffer, 240x320, 150 KiB video memory, 16 KiB DMA buffer memory, fps=20, spi0.0 at 32 MHz
[   19.488953] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[   23.432972] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   30.797270] Adding 524284k swap on /var/swap.  Priority:-1 extents:13 across:2744316k SSFS
[   31.541807] ip_tables: (C) 2000-2006 Netfilter Core Team
[   31.787855] nf_conntrack version 0.5.0 (6960 buckets, 27840 max)


Pour finir, je me suis inspiré de se tutoriel notamment pour le branchement.
En ce qui concerne le nom du fbtft_device je ne suis pas sûr à 100% qu'il s'agisse de celui-ci.


Merci aux personnes qui prendrons le temps de me lire et de me répondre.
Répondre
#2

Citation :En ce qui concerne le nom du fbtft_device je ne suis pas sûr à 100% qu'il s'agisse de celui-ci.
on lit fb_ili9341 dans ton log : c'est pas le chips de ton écran, tu dois avoir raison.

Cool
Répondre
#3

Bonjour,

Merci pour votre réponse.
Une idée de comment je pourrais avoir le nom du fbtft_device ? Smile

Edit : En fait je suis pas sûr, parce que sûr le lien dans la description j'ai trouvé ceci :

Driver IC: ILI9341
Répondre
#4

Pourquoi tu n'utilises pas adafruit22a?
Code :
    .name = "adafruit22a",
.spi = &(struct spi_board_info) {
.modalias = "fb_ili9340",
.max_speed_hz = 32000000,
.mode = SPI_MODE_0,
.platform_data = &(struct fbtft_platform_data) {
.display = {
.buswidth = 8,
.backlight = 1,
},
.bgr = true,
.gpios = (const struct fbtft_gpio []) {
{ "reset", 25 },
{ "dc", 24 },
{ "led", 18 },
{},
},
}
}

Cool
Répondre
#5

Nos post se sont croisés. Pour répondre à tes questions
Non, il faut essayer différents modules. Mais ton lien ebay indique bien un écran avec un chips ili9340, non?
Avec modprobe -c, tu devrais avoir la liste des modules, ainsi que leurs alias.
Avec modinfo nomDuModule, les principales info du module qui t'intéresse.
Et n'oublie pas man, d'où je tire ces infos.
Autres pistes, tu regardes dans les sources du dépot git : fbtft/fbtft_device.c. Là, tu as tous les .name des modules, leurs alias et leur config.

Cool
Répondre
#6

Oki merci bien l'ami ça marche pour moi Smile

J'ai refais le câblage à tête reposé...et j'ai constaté que j'avais également une inversion au niveau de celui-ci.

Edit : je suis nouveau, j'ai encore une petite question le statut résolu se trouve où ?
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)