Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Problème HDMI et WIFI [résolu]. Un peu d'aide ou des conseils ?
#1

Bonsoir,

Qui pourrait me passer un petit coup de main pour un débutant avec Raspberry Pi (RP) nouvelement acquis.
Deux problèmes.

1)
Première installation sur une carte SD 8Go Raspbian Wheezy, câble ethernet, clavier, souris, câble HDMI sur la TV, affichage graphique : ok quoique pas fameux (mais je m'en fous), accès en SSH à partir d'un autre poste : pas de Pb.
Pour avoir un peu plus de place, je veux réinstaller sur une autre carte SD 16 Go dans les mêmes conditions. Démarrage, configuration. Lors de la définition du clavier français, je me trompe => à la place des caractères : des carrés blancs. Je reformate la carte pour y recopier l'image afin de recommencer l'install et la config comme la première fois. Message sur la TV : "Aucun signal..." malgré le câble HDMI branché comme avant. ???. J'éteins TV et RP. Je remets l'ancienne carte SD 8 Go (qui marchait) : "Aucun signal..."
J'ai beau faire diverses tentatives avec les cartes SD, les câbles (dans un sens puis dans l'autre). Maintenant il n'y a plus d'image sur la TV (pourtant configurée avec source HDMI).
Gros mystère ! Quelqu'un a-t-il une idée ou un test à faire pour vérifier quelque chose ?

2)
Avec Wimimage j'ai fait une image de la carte SD 8 Go pour la copier sur la 16 Go. Branchement (sans écran, donc mais avec câble réseau sur RJ45). Accès en SSH : Ok. Un petit "raspi-config" pour que le système occupe les 16 Go. C'est Ok.
J'avais acquis une clef WIFI USB (ThePiHut 802.11n sur Amazon avec tout le reste d'ailleurs). Quand elle est branchée sur un port USB, elle est reconnue :

wlan0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

J'ai suivi les indications de chris57100 (msg du 25-07-2013 12:29:57) qu'il mentionne sur son site (http://www.pihomeserver.fr/2013/01/27/in...-raspbian/). Je n'ai pas eu à installer wpasupplicant, c'était déjà installé et "wpa_passphrase mon_ssid" a créé le psk comme indiqué dans le tuto (d'ailleurs, je ne sais pas ce que veut dire psk. Si quelqu'un savait... Smile). Modification du fichier /etc/network/interfaces comme indiqué, shutdown, reboot : pas d'obtention IP sur la clef WIFI. Un petit "ifconfig wlan0 up" ne change rien.

Pour info:
Mon routeur mentionne dans sa configuration pour les options de sécurité WIFI et ça vient peut-être de là (???) :

( ) Disable
(o) WEP
( ) WPA-PSK
( ) WPA-802.1x

Je n'ai pas de mot de passe WPA mais une clef WEP de 26 digits hexadécimaux.

Quelqu'un a-t-il des infos sur la configuration avec une clef WEP car je n'ai pas envie de devoir changer la config de TOUS les appareils qui sont connectés sur le routeur par WIFI-WEP ?

Merci beaucoup pour votre aide.
Répondre
#2

Bonsoir,

1- je n'ai pas d'info, désolé.

2- j'ai été confronté tout à l'heure à un problème du même genre : je n'arrivais pas à avoir l'@IP fixe que je souhaitais (alors que je n'ai jamais eu de souci sur d'autres systèmes !?). Par contre je suis en WPA, mais qu'importe.

Au passage, PSK = Pre-Shared Key, qui n'est rien d'autres que la clé de cryptage prédéfinie par tes soins (ou ceux de ton fournisseur) et fonctionne effectivement de paire avec le WPA.

Pour le WEP (qui est bien dépassé, voire obsolète aujourd'hui), la manipulation reste la même, seule les configurations changent et c'est là que tu as à mon avis un problème.
Je serais tenté de te dire d'essayer quelque chose dans ce style :

Code :
[== Indéfini ==]
network={
  ssid="nom-de-ton-reseau-wifi"
  key_mgmt=NONE
  wep_key0=ta-cle-de-26-digits
  wep_tx_keyidx=0
}
Répondre
#3

Je suis du même avis que Hawkeye.
1- Pas trop d'idée
2- Le WEP est très facilement cassable. Il est donc possible de rentrer très facilement dans ton réseau.Tu devrais passer immédiatement en WPA.
Si tu restes en WEP, tu changes avec ce que t'a donné Hawkeye, soi tu changes sur ton routeur pour mettre WPA (et tu ne changes donc pas coté Rasp)
Répondre
#4

Tout d'abord merci beaucoup pour vos réponses même si je ne suis pas encore parvenu à mes fins.
Mon problème est peut-être dans la syntaxe. Je ne vois pas où ni comment écrire "network={ ...bla bla bla...}".
Dans mon fichier /etc/network/interfaces original, c'est rédigé comme ceci :

Code :
[== Indéfini ==]
[email protected]:/etc/network# cat interfaces.orig
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
[email protected]:/etc/network#

En me basant sur les indications de Hawkeye (et après l'avoir sauvegardé, bien sûr) j'ai modifié ce fichier tel que :

Code :
[== Indéfini ==]
[email protected]:/etc/network# cat interfaces
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp
ssid="mon_SSID"
key_mgmt=NONE
wep_key0=15D2CCB59A0BC45D63F4E7FF51
wep_tx_keyidx=0
iface default inet dhcp
[email protected]:/etc/network#

ifconfig après sauvegarde ou ifconfig après un "ifconfig wlan0 up" donne le même résultat suivant:
Code :
[== Indéfini ==]

[email protected]:/etc/network# ifconfig
eth0    Link encap:Ethernet  HWaddr 23:1b:ce:51:d9:7f
          inet adr:192.168.0.47  Bcast:192.168.0.255  Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:525 errors:0 dropped:0 overruns:0 frame:0
          TX packets:663 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:47316 (46.2 KiB)  TX bytes:77198 (75.3 KiB)

lo        Link encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:1052 (1.0 KiB)  TX bytes:1052 (1.0 KiB)

wlan0   Link encap:Ethernet  HWaddr 5e:f3:18:9d:4e:6a
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Et après un reboot, je n'accède même plus en SSH. Obligé de réécrire l'image de départ (8 Go sur 16 Go) et re-étendre la partition... Sad

NB:
- les HWaddr, inet adr, ssid et wep_key0 ont été modifiés.
- Je cherche d'abord une solution qui marche avec WEP (pour ne pâs être obligé de changer tout le reste). Si c'est bon, je vais essayer de suivre le conseil de Uggy en utilisant la protection WPA au lieu de WEP.
Répondre
#5

Pour tes problèmes HDMI, je te conseil de modifier le config.txt dans le répertoire boot, il contient les différentes options (Option vidéo) .
Perso je commencerais par mettre :
Code :
[== Indéfini ==]
hdmi_force_hotplug=1
hdmi_drive=2
hdmi_group=2
Si ça marche pas ajoute la ligne ci-dessous (1024x768 60Hz):
Code :
[== Indéfini ==]
hdmi_mode=16
Puis augemente la résolution au fur et à mesure.
Répondre
#6

Merci @sdelporte, je vais essayer (pour HDMI)...

Pour ce qui concerne le WIFI, j'ai trouvé la solution à http://jeffskinnerbox.wordpress.com/2012...pberry-pi/

Originalement, /etc/network/interfaces contient :

Code :
[== Indéfini ==]
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Il a été modifié comme suit pour accès avec protection WEP et non WPA-PSK :

Code :
[== Indéfini ==]
auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wireless-essid arthur
wireless-key 15D2CCB59A0BC45D63F4E7FF51
iface default inet dhcp

J'avais configuré le routeur pour attribuer une adresse bien précise pour toute demande d'attribution IP émanant de telle adresse MAC (celle de la clef WIFI-USB : ThePiHub, 802.11n).
Ça a marché du 1er coup.

Code :
[== Indéfini ==]
[email protected]:/etc/network# ifconfig
eth0      Link encap:Ethernet  HWaddr 23:1b:ce:51:d9:7f
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:1052 (1.0 KiB)  TX bytes:1052 (1.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 5e:f3:18:9d:4e:6a
          inet adr:192.168.0.100  Bcast:192.168.0.255  Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:434 errors:0 dropped:0 overruns:0 frame:0
          TX packets:427 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:51100 (49.9 KiB)  TX bytes:46008 (44.9 KiB)

NB: Toutes les adresses (matérielles, IP), les noms et clefs mentionnés ici sont factices.

Merci à @Hawkeye pour avoir donné une direction de recherche.
Au moins, ça marche. Alors je vais maintenant essayer de sécuriser avec WPA-PSK plutôt qu'avec WEP.
Merci.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)