En raison de spams récurrents, les messages des nouveaux inscrits sont modérés a priori. Ne vous inquiétez pas si vous ne voyez pas apparaitre votre message immédiatement sur le forum. (November 04, 2021) x

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[Résolu] Pi 3 qui se met en veille ???
#1

Bonjour à tous.

Je débute avec le Raspberry donc désolé si je pose des questions qui peuvent paraître idiotes. [Image: icon_mrgreen.gif]

Déjà je vais expliquer brièvement mon projet :

Le Rasp doit démarrer à une heure donnée, se connecter à un site internet via Firefox, y effectuer une action automatique (via une extension Firefox dédiée), puis s'éteindre automatiquement après un laps de temps défini.
Avec un écran + clavier + souris, mon système fonctionne.

En revanche, avec uniquement le minimum (alim + câble réseau) ça ne fonctionne pas. [Image: icon_cry.gif]

J'ai branché un gadget LED en USB pour contrôler son fonctionnement sans écran et au bout d'environ 1min30 (ce qui correspond au temps de boot + démarrage Firefox) après allumage le rasp semble s'éteindre (coupure de la led usb et de la led verte ACT).
J'ai ajouté une souris pour voir mais même résultat.

Faut-il absolument un périphérique HDMI de branché pour que le Raspberry effectue correctement les commandes ? ça me paraît curieux.
Ou ais-je un truc mal configuré ?

Il tourne sous Raspbian à priori dernière version (update effectuée il y a 3 jours).
Répondre
#2

Un raspberry avec une interface graphique a peut-être besoin d'un écran, sans quoi l'absence de sortie visuelle peut faire planter: il ne trouve pas les infos pour adapter la taille de l'écran.

Peut-être qu'avec un export de serveur X ça peut fonctionner, mais je ne maitrise pas du tout le sujet.

Sinon, selon les opérations que tu dois faire avec firefox, tu peux trouver une alternative sans GUI, avec curl ou wget. Pour ma part, j'ai un système qui a besoin d'accéder à des sites et j'utilise des scripts en tcl pour cela (ce qui me permet la gestion des cookies pour m'identifier en tant qu'utilisateur du site).
Répondre
#3

Merci pour cette réponse CrazyCat.

Je vais approfondir la question de l'écran.

Autrement je me demande si ce n'est pas une sécurité liée à la chaleur. Pour mes tests j'ai laissé la carte sur ma Freebox qui chauffe pas mal.

Si ça se trouve c'est juste ça.
Répondre
#4

Bon alors je pense que mon problème provient de la commande que j'ai placé dans rc.local :

sudo shutdown -h +8 & (lance l'arrêt 8 min après le démarrage)

ça fonctionnait, en tout cas en testant via l'interface graphique, mais l'arrêt semble ainsi trop brutal.
Puisqu'au démarrage suivant j'ai aperçu un message : Broadcast message from [email protected]
The system is going down for poweroff now !

Où alors le +8 n'est pas pris en compte dans rc.local.


J'ai testé l'arrêt par Crontab mais ça ne fonctionne pas. Il faut l'activer quelque part ?
Répondre
#5

Je ne pense pas que tu aies besoin du sudo dans ton rc.local, par contre utilises le chemin complet: /sbin/shutdown --poweroff --no-wall +8 &
Et le lancer par crontab me semble bizarre, à moins que tu ne saches exactement à quelle heure tu dois faire le shutdwon.

Je ne sais pas du tout comment réagit le système si tu lances d'autres choses après ton shutdown, il faudra que je fasses des tests la dessus.
Répondre
#6

Bon, j'ai solutionné tous mes problèmes !

En fait c'était bien un problème de syntaxe car l'argument "+8" n'était en fait pas pris en compte.
Du coup le Raspberry ne se mettait pas en veille mais exécutait simplement la commande shutdown au démarrage...

Par contre, la commande "Shutdown -h 8" fonctionne parfaitement.
Je l'ai de plus basculé dans l'autostart de LXDE et ça fonctionne mieux. Via rc.local c'était parfois aléatoire.

Et j'ai laissé tomber Firefox pour Chrome qui est plus malléable pour ce que je veux faire.
merci quand même pour l'aide.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)