Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

PB activation wifi et eth en même temps
#1

Bonjour,
Je souhaite que ma connexion wifi et mon port ethernet soient actifs dès la mise sous tension.
voici ma config des interfaces:

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
address 192.168.1.70
netmask 255.255.255.0

auto wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Avec cette config, le wifi se coupe si je connecte l'ethernet et il revient si je déconnecte le câble. Or je me sers du wifi pour me connecter à une box et de l'ethernet pour me connecter sur un serveur web.

Il y a un souci dans ma config mais lequel?
Pouvez-vous compléter?
Merci
Répondre
#2

Bonjour lolo64,

Pas trop compris ton besoin.

Pourquoi tout ne transite pas par "un seul" équipement actif, à savoir l'ethernet ? Quel est l’intérêt d'avoir le Wifi actif ?
Répondre
#3

Tu as 2 équipements réseaux actifs, et une seule IP (vu que tu déclare en static et manual, mais une seule IP).

Dans la section wlan0, en dessous de manual (? ça fonctionne ? J'utilise static dans les 2 cas, moi), tu déclare une autre IP non prise sur ton réseau (ex: 192.168.1.71). OU ta ligne dhcp est mal placée, car tu as déjà ton wlan0 manual plus haut.

Perso, j'ai déjà fait, ça fonctionne, la machine répond à 2 IP.

Ta machine est donc joignable sur 2 Ip différentes, mais sur le même réseau. Ou un réseau différent, tout dépend ta config. Mais si tu force une ip statique, faut le faire pour les 2 équipements.
Répondre
#4

Bonsoir et merci d'essayer de répondre à ma question,
Tout est dans le même réseau. J'ai laissé wlan en DHCP car c'est la box qui me donne l'adresse. L'autre adresse côté ethernet doit être fixe.
Je vais essayer de tout mettre en statique.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)