Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[Nginx + wordpress] ip local
#1

Bonjour à tous !

Voilà, j'essaye de me monter un serveur web avec nginx et wordpress.
Après avoir suivit de multiples tuto et galéré pas mal, j'y suis enfin arrivé... Enfin c'est ce que je croyais.

En effet, si je veux acceder a mon site web en dehors du réseau, la page d'accueuil est super longue à charger et aucune image ni aucun css n'est chargé et aucun lien ne marche.
Et pour causes : tous les liens sont écris avec mon ip local. Donc forcément quand on est pas en local, ca ne peut pas marcher.
En gros si je fais afficher le code source il va y avoir pleins de : href 192.168.x.x au lieu de mon ip publique.

Avez vous une idée ?


Mon fichier de configuration :

server {
listen 80;
server_name xxx.xxx.xxx.xxx; # ip publique
rewrite ^ https://$server_name$request_uri? permanent; # enforce https
}

server {
listen 443 ssl;
server_name xxx.xxx.xxx.xxx; # ip publique
ssl_certificate /etc/nginx/cert.pem;
ssl_certificate_key /etc/nginx/cert.key;
root /usr/share/nginx/www;
index index.php index.html index.htm;
client_max_body_size 1000M; # set maximum upload size
autoindex off;

# default try order
location / {
try_files $uri $uri/ /index.php;
}

# enable php
location ~ \.php$ {
fastcgi_split_path_info ^(.+\.php)(/.+)$;
# NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini

# # With php5-cgi alone:
# fastcgi_pass 127.0.0.1:9000;

# # With php5-fpm:
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_index index.php;
include fastcgi_params;
fastcgi_param HTTPS on;
fastcgi_read_timeout 600;
}
}


Est-ce que ca pourrait venir du fait que j'ai installer wordpress en etant avec mon ip privé ?

Merci d'avance !
#2

Bon je viens de tout réinstaller et ca marche !

Je pense que c'est parce que j'avais utiliser mon adresse local quand j'ai appeller la page wp_install.php de wordpress

Desolé pour le déarangement !
#3

Salut
Je confirme. L'IP locale n'étant visible que depuis la machine 'locale' si dans les pages générées il y a du 127.0.0.1 alors le browser voudra accéder au poste client et non au serveur

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)