Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Mplayer et lecture des vidéos du RPI en console
#1

Bonjour,

Dans le but de me faire un écran multi-caméras, je rejoue un peu avec la RaspiCAM, j'ai testé quelques petites choses sympas (server HTTP Motion, flux VLC, etc...).
Mais dans tous les cas, je me dois d'avoir une interface graphique sur le PC client (en l'occurrence Linux Mint) afin que cela fonctionne bien.

En suivant des tutos sur le blog de Nicolargo, j'ai essayé de créer des flux RTSP ou HTTP sur le Raspberry, puis de m'y connecter avec un Ubuntu qui n'a pas de serveur X...

Lorsque je parviens à me connecter depuis la machine sans serveur X, ce n'est qu'avec VLC (ou la commande cvlc aussi), et toujours avec la vidéo reproduite en ASCII-ART....


J'ai lu qu'il est possible de lancer une vidéo en console (locale du moins, non ssh), avec mplayer également. Mais même avant d'essayer de créer un flux, celui-ci refuse déjà de lire les vidéos du RPI, qui sont en H.264 je crois.. J'ai même essayé de compiler les codecs X264, puis de compiler mplayer, mais j'ai eu pas mal d'erreurs...

Le point que je n'arrive pas à creuser : Lorsque l'on lance une vidéo sur un écran HDMI avec le RPI, celle-ci s'affiche en bonne qualité, ET en console sans serveur X ! Pourquoi ?

Parfois, je cherche dans les scripts des commandes, mais là evidemment, la commande raspivid est un binaire...
Auriez-vous par hasard plus d'infos ?

Merci Wink
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)