Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Lecteur de carte multiformat
#1

Bonjour

j'ai besoin d'installer un lecteur de carte SD,.... sur un port USB hors quand je branceh le mien sur ma Raspberry il n'est pas toujours détecté. J'i fait un test sur mon PC et tout fonctionne.
D'où celà peut il venir ?

lecteur ALLinOne Amarina pour 6 types de cartes.

merci par avance.
Répondre
#2

Bonjour,

Après branchement que retourne la commande lsusb et la commande dmesg ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#3

Bonjour

après le branchement du lecteur

lsusb
Protocol spec without prior Class and Subclass spec at line 17406
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. SMC9512/9514 USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 004: ID 3207:0300

la dernière ligne correspond au lecteur de carte.

la fin de dmesg
[ 60.534402] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[ 60.635615] usb 1-1.2: New USB device found, idVendor=3207, idProduct=0300
[ 60.635654] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 60.635672] usb 1-1.2: Product: 816820090226
[ 60.635688] usb 1-1.2: Manufacturer: 816820090226
[ 60.635704] usb 1-1.2: SerialNumber: 816820090226
[ 60.642841] usb-storage 1-1.2:1.0: USB Mass Storage device detected
[ 60.654377] scsi host0: usb-storage 1-1.2:1.0
[ 60.686488] usbcore: registered new interface driver uas
[ 61.656402] scsi 0:0:0:0: Direct-Access FNK TECH USB CARD READER 1.00 PQ: 0 ANSI: 0 CCS
[ 61.664065] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 61.714992] sd 0:0:0:0: Attached scsi generic sg0 type 0

L'insertion de la carte ne fait rien je ne vois pas de /dev/sda1 qui devrait être ma carte.
Répondre
#4

Il dit qu'il y a bien quelque en /dev/sda. Pas dit qu'il y a un auto mount de la carte, c'est peut être à faire manuellement.

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#5

Le lecteur est vu, pas la carte. Pour preuve je viens de rebooter et un ls /dev/sd* donne

/dev/sda /dev/sda1

qui me permet alors de monter la carte via mount /dev/sda1 /media et de voir le contenu de la carte.

De plus l'extraction de la carte n'enlève pas le /dev/sda1 même si l'emplacement n'est pas monté.



un sudo update-usbids ne modifie rien non plus.

Ce qui est curieux c'est que l'introduction de la carte dans le lecteur ne semble pas déclencher quoi que ce soit au niveau de raspbian.
Répondre
#6

Par contre il semble que ceci fonctionne :

introduction de la carte dans le lecteur puis
sudo partprobe /dev/sda

après je vois ma partitiion

/dev/sda1

après retrait de la carte je dois a nouveau faire un

sudo partprobe /dev/sda

C'est curieux que ceci ne soit pas automatique, bon je ne connais pas le fonctionnement de ce partprobe.

Merci
Répondre
#7

Effectivement, assez bizarre qu'il faille faire une commande en ligne pour la mise à jour ...
Une solution pourrait être l'installation du package udisks et de lancer la commande (syntaxe à vérifier) lors du boot :
Code :
udisks --poll-for-media /dev/sda

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#8

Merci

effectivement ceci semble fonctionner a merveille.

la syntaxe est la bonne

Code :
udisks --poll-for-media /dev/sda
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)