Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Lancement auto d'un logiciel à la mise en route
#1
Bonjour
j'ai testé le serveur Kodi qui tourne parfaitement sur le raspberry pi3...
J'ai adapté un interrupteur "olive" sur le câble d'aliimentation du raspi pour ne pas avoir à brancher et débrancher l'alim sur la petite prise... et risquer de la détériorer à force d'usage
Déconnecté d'un écran devenu superflu, et avec un disque dur externe alimenté secteur contenant mes médias, il me sufffirait simplement d'allumer l'interrupteur Olive et de disposer du serveur kodi sans aucune manip...
Mais je n'ai pas trouvé où je peux paramétrer le lancement automatique de kodi à la mise en route
Merci de vos luumières
Debian 10 buster sur LENOVO LEGION Y520 8 Go
Raspberry Pi 4 B... sous Raspbian buster
Vieux PC sous LMDE3 (Linux Mint Debian Edition 3)
Répondre
#2
salut !
Dans home/pi/.config tu as un autostart .
Dedans tu créés un script qui lance kodi
Répondre
#3
Ah ok.. merci... je vais aller voir.

Décidement...
et comment je dois faire pour afficher le fichier ".config" dans bin, et qui doit être invisible...?
ensuite je dois l'ouvrir en ligne de commande...?
(nano etc.. ou autre éditeur..)

(19-12-2018, 09:47:56)redelap a écrit : Ah ok.. merci... je vais aller voir.

Décidement...
et comment je dois faire pour afficher le fichier ".config" dans pi, et qui doit être invisible...?
ensuite je dois l'ouvrir en ligne de commande...?
(nano etc.. ou autre éditeur..)

(19-12-2018, 09:47:56)redelap a écrit : Ah ok.. merci... je vais aller voir.

Décidement...
et comment je dois faire pour afficher le fichier ".config" dans pi, et qui doit être invisible...?
ensuite je dois l'ouvrir en ligne de commande...?
(nano etc.. ou autre éditeur..)

Oups.. j'ai trouvé..
Pas habitué.
Désolé.

j'ai trouvé le dossier ".config" mais je ne vois pas dedans l'autostart dont tu parles ?
Là je suis aux limites de ma faible compétence.
Debian 10 buster sur LENOVO LEGION Y520 8 Go
Raspberry Pi 4 B... sous Raspbian buster
Vieux PC sous LMDE3 (Linux Mint Debian Edition 3)
Répondre
#4
autostart n'existe pas par défaut, il faut le créer puis faire un lien symbolique de ton executable Kodi dans ce répertoire:
Bash
mkdir -p ~/.config/autostart
ln -s /usr/bin/kodi ~/.config/autostart


Si tu lis l'anglais, tu as tout sur https://kodi.wiki/view/HOW-TO:HOW-TO:Aut..._for_Linux
Répondre
#5
je pense que tu as compris que les lignes de commandes sont un peu du chinois pour moi (tout comme l'anglais)
Vu pour le répertoire autostart
Le lien symbolique sera donc placé dans ce dossier autostart...
Mais comment créer ce "lien sylmbolique" ? Se lancera t'il uniquement à la mise en route ? Ne faut t'il pas le préciser dans la 2e ligne ?
Largué...

J'ai créé un dossier autostart , pas en ligne de commande, mais directement avec le gestionnaire de fichiers en faisant afficher les dossiers caché.

Maintenant je vais voir comment réaliser ce lien symbolique.
Debian 10 buster sur LENOVO LEGION Y520 8 Go
Raspberry Pi 4 B... sous Raspbian buster
Vieux PC sous LMDE3 (Linux Mint Debian Edition 3)
Répondre
#6
Le lien symbolique (équivalent ou presque du raccourci sur windows), je ne sais pas le faire autrement qu'en ligne de commande (la plupart de mes machines sont headless).
Le plus simple est de le faire en ligne de commande (ln -s ...)
Répondre
#7
J'en comprends le principe... Mais si je tape cette ligne "ln -s....". dans le terminal comment la conserver dans le dossier autostart..
je suis nul...
je recherche sur le net ... et ne veux pas t'em... bêter...
Debian 10 buster sur LENOVO LEGION Y520 8 Go
Raspberry Pi 4 B... sous Raspbian buster
Vieux PC sous LMDE3 (Linux Mint Debian Edition 3)
Répondre
#8
Si tu tapes cette ligne de commande dans ton terminal, ça va créer le lien symbolique (le raccourci). Tu n'as plus rien à faire ensuite.
C'est comme quand tu crées un raccourci sous windows, une fois qu'il est créé il est là jusqu'à ce que tu le supprimes volontairement.
Répondre
#9
Ok.. mais il me faut d'abord être dans le répertoire autostart avant de taper cette commande ? C'est ça que je ne pige pas.

J'y suis arrivé.. il y a bien maintenant un fichier type "raccourci" dans le dossier autostart..
Après reboot, kodi ne s'est pas lancé... Sniff
Debian 10 buster sur LENOVO LEGION Y520 8 Go
Raspberry Pi 4 B... sous Raspbian buster
Vieux PC sous LMDE3 (Linux Mint Debian Edition 3)
Répondre
#10
Il y a bien un fichier kodi de type "raccourci" dans le dossier autostart
D'ailleurs ce fichier doublecliqué lance bien Kodi
Donc l'autostart ne fonctionne pas.
Sad
Debian 10 buster sur LENOVO LEGION Y520 8 Go
Raspberry Pi 4 B... sous Raspbian buster
Vieux PC sous LMDE3 (Linux Mint Debian Edition 3)
Répondre
#11
Vérifies (ou fait) tout ce qui est indiqué sur la page que je t'ai donnée plus haut.
Le souci est certainement l'autologin
Répondre
#12
Oui je pense ...aussi
Mais...
Pas facile avec le traducteur en plus (deepl.com)... je ne parle pas l'anglais...
J'ai bien été cherché le fichier "lightdm.conf" et modifié sous nano la ligne autologin-user = kodi
Mais il y a deux lignes de ce type, une avec PI et lautre avec kodi...
J'ai mis kodi dans les deux lignes
Du coup au reboot, il me demande le pass d'accès à pi à l'ouverture..
et kodi ne se lance toujours pas..

Le 2e fichieir à créer (50-myconfig.conf) a aussi été créé, avec la ligne autologin-user = kodi..
Mais faut-il recopier TOUT le fichier lightdm.conf dedans ?
Encore perdu..
Debian 10 buster sur LENOVO LEGION Y520 8 Go
Raspberry Pi 4 B... sous Raspbian buster
Vieux PC sous LMDE3 (Linux Mint Debian Edition 3)
Répondre
#13
Complètement déboussolé et perdu
En cherchant je trouve ceci
http://www.siloged.fr/docs/raspberry/ind...uboot.html


Qui croire... Aucune explication... du pourquoi d'une autre méthode..

je sais que on arrive à tout résoudre avec les lignes de commandes..
Mais pour une action à obtenir,; moi qui n'y connaît rien, j'y passe la journée

Une interface graphique ou une oprtion qq part résoudrait le problème en 2 minutes

Sad Sad Sad Sad Angry Angry Angry
Debian 10 buster sur LENOVO LEGION Y520 8 Go
Raspberry Pi 4 B... sous Raspbian buster
Vieux PC sous LMDE3 (Linux Mint Debian Edition 3)
Répondre
#14
Le problème, c'est que tu veux lancer un programme qui a besoin d'une interface graphique (et donc de faire un login auto et un startx).

La méthode la plus simple (imho) aurait été d'installer OSMC et de le configurer pour activer la partie serveur (je me demande même si c'est pas fait par défaut).
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

A propos de Communauté francophone RPi

Communauté francophone RPi est un forum d'aide et de partage autour du Raspberry Pi et des micro-ordinateurs.