En raison de spams récurrents, les messages des nouveaux inscrits sont modérés a priori. Ne vous inquiétez pas si vous ne voyez pas apparaitre votre message immédiatement sur le forum. (November 04, 2021) x

Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[Résolu] Interface WiFi non cliquable
#1

Bonjour à tous,

J'ai un problème avec mon Raspberry Pi 3 Model B+, j'essais de me connecter à un réseau universitaire (eduroam), mais l'interface en question n'est pas cliquable bien qu'elle soit detectée par le RPi. 

[Image: 5yiv.png]

Quelqu'un saurait-il m'aider ?
 
Merci à vous, bonne journée,
Cordialement,

SnowEdy_
PS: je suis débutant sur RPi désolé pour mon incompétence.
#2

Bonjour,

Arrives-tu à connecter un autre appareil (par exemple un GSM) ? Et peux-tu nous dire quel système d'exploitation et quelle interface graphique tu utilises afin que nous comprenions la signification des symboles ?

Et peut-être que https://raspberrypi.stackexchange.com/qu...grayed-out t'apportera la solution, il est justement question d'eduroam :
Citation :There are many solutions in the internet that require modifying the wpa_supplicant configuration manually and similar, but this is pretty complex, hard to get right and inflexible when the configuration changes. The "greyed out" issue is because the PIXEL desktop in Raspbian comes with its own simple network managing service that does not support more complex WiFi setups used in enterprise and university networks (especially eduroam).

There is a simple way to fix this though that I haven't found mentioned anywhere else so far: Instead of the Raspbian integrated one you use NetworkManager, which is what's used in most Desktop Linux environments.

Bash
sudo apt install network-manager network-manager-gnome
sudo systemctl disable --now dhcpcd
sudo systemctl enable --now network-manager
 
nm-applet # to show the tray icon without reboot



You have to disable dhcpcd because it conflicts with NetworkManager, otherwise you get a "device not ready" message instead of a list of wifi networks.

This should now show a new tray icon where you can connect to any network like eduroam.

The setup for the enterprise wifis is the same as on any desktop linux (e.g. Ubuntu). For example, for eduroam you use PEAP (Protected EAP) instead of Tunneled TLS, leave anonymous identity domain empty, get the CA certificate depending on your university or set it to "no ca required", PEAP version automatic and inner auth MSCHAPv2.

After a reboot it should auto-connect correctly.

If you do not have a Ethernet cable to install new software before setting up WiFi, you need to look up how to install the network-manager package offline or simpler connect your phone with USB and enable "USB tethering" which works without any setup.
#3

(22-02-2022, 14:57:10)CrazyCat a écrit :  Bonjour,

Arrives-tu à connecter un autre appareil (par exemple un GSM) ? Et peux-tu nous dire quel système d'exploitation et quelle interface graphique tu utilises afin que nous comprenions la signification des symboles ?

Et peut-être que https://raspberrypi.stackexchange.com/qu...grayed-out t'apportera la solution, il est justement question d'eduroam :
Citation :There are many solutions in the internet that require modifying the wpa_supplicant configuration manually and similar, but this is pretty complex, hard to get right and inflexible when the configuration changes. The "greyed out" issue is because the PIXEL desktop in Raspbian comes with its own simple network managing service that does not support more complex WiFi setups used in enterprise and university networks (especially eduroam).

There is a simple way to fix this though that I haven't found mentioned anywhere else so far: Instead of the Raspbian integrated one you use NetworkManager, which is what's used in most Desktop Linux environments.

Bash
sudo apt install network-manager network-manager-gnome
sudo systemctl disable --now dhcpcd
sudo systemctl enable --now network-manager
 
nm-applet # to show the tray icon without reboot



You have to disable dhcpcd because it conflicts with NetworkManager, otherwise you get a "device not ready" message instead of a list of wifi networks.

This should now show a new tray icon where you can connect to any network like eduroam.

The setup for the enterprise wifis is the same as on any desktop linux (e.g. Ubuntu). For example, for eduroam you use PEAP (Protected EAP) instead of Tunneled TLS, leave anonymous identity domain empty, get the CA certificate depending on your university or set it to "no ca required", PEAP version automatic and inner auth MSCHAPv2.

After a reboot it should auto-connect correctly.

If you do not have a Ethernet cable to install new software before setting up WiFi, you need to look up how to install the network-manager package offline or simpler connect your phone with USB and enable "USB tethering" which works without any setup.

Merci pour votre aide mais c'est bon j'ai résolu mon problème. J'explique la démarche que j'ai suivi:
- Installé network manager.
- Reboot
- sudo systemctl stop NetworkManager
- sudo killall wpa-supplicant
- sudo systemctl start NetworkManager

Et là les réseaux grisés deviennent cliquables !

Merci encore,

Cordialement,

SnowEdy_
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)