Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Instal defectueuse ou matériel défecteux ?
#1

Alors voilà, çà y est, j'ai reçu mon RPi B+ et ses compléments
parmis ceux-ci il est des plus utile de signaler la MicroSD avec Raspbian (ou Noos ou les deux?) préinstallés dessus
Plutot content donc mais assez vite déçu (aprés branchements)

j'ai tout branché (Carte microSD, clavier, souris, ... pas la sortie son, pas indispensable pouyr le moment)

Ayant un moniteur sans prise HDMI je suis allé acheter et j'ai branché aussi le cable de 2 m envison HDMI (RaspB) et DVI coté écran
(à l'arrière de mon moniteur emachine -Sony je rois me rappeller; il y a 2 prise: VGA utilisée mauis que je peux utiliser en débranchant, pas important... et à coté une DVI non utilisée -jammais utilisée)
... et en dernier je branche l'alimentation

- L'écran noir n'affiche que 'pas de signal'
- La RPi affiche deux diodes, rouge et verte, allumées en permanence...

Au premier abord, mais je ne suis pas spécialiste, mes premières pistes / impressions vont vers :
- entrée DVI moniteur ou cable défectueux -ou non adhéquant
- Carte mini SD non conforme aux attentes
etc...

* Question 1:
Comment puis-je vérifier laquelle de ces pistes semble la bonne ?

* Q2:
Autres pistes plus sérieuses ?

* Q3:
Pour eux qui n'ont que des moniteurs VGA il existe-t-il des adaptateurs ou des cordons adaptateurs pour pouvoir utiliser le HDMI founi avec mon pack RasBerry ?

* Q4:
Jeoffroy, bien reçue mon adhésion au club ? ;-)



Bon ça sera tout pour cette fois, enfin ... pour le moment

Merci d'avance

Teo
#2

Salut

A l'allumage, la diode rouge doit s'allumer en rouge fixe (alimentation). Puis la verte doit clignoter rapidement pour indiquer les accès à la carte. Elle deviendra ensuite fixe si je ne me trompe pas.
As tu bien tout copié sur ta carte SD ? Deux partitions sur la carte : une FAT32 et une ext4 (deuxième visible dans les outils système de Windows uniquement)

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
#3

Merci, ta réponse me donne un espoir et sans doute une première piste (sérieuse ?):

1 ma micro carte SD est d'origine, avec le logo framboise (bien sur, sur l'adaptateur + gros qui, je le sais, est inutile), comprise dans mon Kit/Pack
Je suppose donc qu'elle inclu tout le nécessaire pour booter dessus, non ???

2 la diode verte et la diode rouge s'alument en même temps ET restent allumées sans clignoter, à aucun moment
'- La RPi affiche deux diodes, rouge et verte, allumées en permanence...'

je renvoi mon RPi, le delai est court, ou la carte est une piste sérieuse ?
NB: j'ai un PC windows 7; je peux y vérifier le contenu de ma carte (je ne crois pas puisqu'elle devrait être, sauf erreur de ma part, en FAT32)

J'ai essayé de mettre la carte dans l'autre sens... le doute

- peut-tu me présiser son sens
- ou puis-je éventuellement acheter, commander, une nouvelle carte (SI elle te semble fautive) avec Rspbian Noos déjà d'installés...

plutot urgent car le délai pour le renvoi approche

Merci pour ta réponse et ta future réponse aussi

Par peur de fausse manoeuvre j'attends vos réponses au lieu d'improviser selon mon inspiration...

(Dois-je changer le titre de mon message afin que d'autres s'y interessent ? SOS)

Merci

Teo
#4

As tu une télé avec un HDMI pour faire le test ? sinon sur ton écran, dans les menus tu as bien choisie l'affichage DVI et pas VGA ? Pour ma part je m'orienterais la dessus car s'il te dit 'pas de signal' c'est qu'il ne voit pas le Rpi de branché.
#5

Essaye la manip de Dormeur au cas où.

Sinon pour la carte il doit y avoir un détrompeur. Avec quel outil tu as fait l'installation ?

Quelle alimentation utilises tu : est-ce bien supérieur à 700mA ?

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
#6

Bonjour,

...Si tu n'as pas d'écran avec HDMI :

Tous les écrans ne sont pas correctement détectés par le raspberry B ou B+ sur la sortie HDMI. Particulièrement vrai lorsque tu utilises un câble HDMI>DVI.
Si tu as une sd avec noobs, tu peux taper sur les touches 1 ou 2 de ton clavier pour forcer les différents modes HDMI dans les 10s qui suivent le boot. Et il est préférable d'avoir l'écran allumé et non en veille.
1 default HDMI mode
2 safe HDMI mode
autre modes :
3 PAL
4 NTSC

As-tu branché un cable ethernet sur ton B+? Auquel cas, as-tu de l'activité sur les leds correspondantes?

Cool
#7

Bonne idée le cable ethernet !!

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
#8

Mes réponses, regroupées : Lisez les toutes avant d eme répondre, une réponse peut aider une autre personne

* Dormeur :

- J'ai aussi fait le test sur ma TV pourvue d'HDMI, j'avais oublié de vous le dire car plus récent =
idem deux diodes s'alument en FIXE: verte et rouge
La prise HDMI de la Télé me sert et fonctionne (avec un petit décodeur TNT, je l'ai débranché) j'ai branché RPi et même résultat ide,tique (ecran pas de signal et les mêmes diodes)

- sur mon moniteur 'ordi' j'e n'ai rien changé ni paramétré: j'ai implement éteint, débran,ché le RSA, Branché le cable adaptaeur dans la prise HDMI alumé l'écran et RPi
IL faut faire un réglage ? L'HDMI n'eets pas détecté automatiquement si le RSA n'envoi rien et le cable HDMI oui ?

* Chris :

- 'un détrompeur' ? Ma micro SD est arrivée dans un adaptateur SD avec le logo framboise, j'ai enlevé la micro de l'adaptateur et l'ai ùmise dans le RPi

- 'Avec quel outil as tu fait l'instal ?..' aucun, j'ai cru comprendre et je pense (vu le logo fra,mboise) que la micro SD inclu les logiciels de lancement necessaires (ou ai-je mal lu/compris)

- L'alim doit être trés ok, j(ai choisi une 2000 ma 2A max.

* Gambit :

- je n'ai pas encore pu essayer ta proposition d eboot spécial (touche 1 ou 23 du clavier) désolé, j'essaierai sur...

- tu parles apparemment de mon écran ordi (Prise RSI avec cable adatateur)... ou possible aussi sur l'écran TV 'prise HMDI' , ou à essayer sur les deux ?

- Non je n'ai branché ni l'ethernet ni le son... Pour ethernet suffit-il, pour quil soit détecté, que je le branche (= 'détection physique') ou doit-il être alimenté par le CoDec ('Modem' 'box' ... Alice/free) = détection élecvtrique/electronique ?
#9

Pour ma part, ...je te parle de tes deux écrans : ta TV en HDMI, ton moniteur en DVI avec ton cable adaptateur.
Le cable ethernet doit nécessairement être raccordé à ta box modem, routeur, ce que tu veux. Si noobs est correctement démarré, tu devrais avoir un led verte allumé/clignotant (vers le port ethernet du B+ je crois...) lorsque tu raccordes le cable ethernet (RJ45).

Ceci dit, si j'ai bien tout compris ce que tu nous as exposé, c'est un pack B+ avec une carte sd préinstallée. Pourrais-tu vérifier que tu disposes de la bonne version de noobs sur ta carte sd. (ça serait comique, n'est ce pas?)
Pour ce faire, sur ton ordinateur avec window 7 (merci à ceuce qui utilise w7 de corriger):
* plugge ta sd sur ton lecteur de carte (je suppose que tu en as un, au besoin avec l'adapteur fourni dans le pack). La carte devrait être montée automatiquement
* sur la partition fat32 de la carte, tu devrais avoir un fichier qui s'appelle BUILD-DATA.
* ouvre ce fichier avec notepad par exemple. Voilà ce que tu devrais obtenir :
Code :
Build-date: 2014-09-12
NOOBS Version: v1.3.10
NOOBS Git HEAD @ 9f0d7a7eac162d60346cb5f83a6822085c53b300
rpi-userland Git HEAD @ 0cbcb3a67f39b0522e4413207481906595b3591b refs/heads/master
rpi-firmware Git HEAD @ 53d1ae311226b5cd7ea1277832139b74b2bb0f90 refs/heads/master
Ça c'est pour la dernière version de noobs, ..., qui fonctionne avec B+.

Cool
#10

Merci de tous vos efforts et réponse (j'en espère d'autres, bien sur)

1 j'ai essayé aujourd'hui, mais je réessaierai demain par sécurité :
... elle ne semble pas formatée puisqu'il m'a proposé de la formater et que je n'ai pas pu voir son contenu

* çà semble une bonne piste, interessante, non? ... à confirmer

2 confirme moi: SI le cable 'modem' n'est pas branché au RPi il ne démarera pas
ou je puis me passer de le connecter pour résoudre mon problème

3 (un peu anecdotique) je viens de recevoir (en plus du cable que j'avais) ma commande d'un adaptateur direct (tout court, sans cable) que je met dans la prise femelle DVI du moniteur et me fournit maintenant une sortie femelle HDMI;
Je pourrai y tester sirectement avec le cable HDMI HDMI

4 Je renouvelle ma question:
puis-je acheter qq part ou à un particulier, une carte mini SD ayant SUR déjà ce quil faut (au moins le minimum nécéssaire) à l'intérieur

J'espère pouvoir résoudre le problème au maximum ce week end, je veux dire Samedi aprem car dimanche pas possible avant le soir (bien sur la mini SD ne me parviendra pas à temps.... sauf coup de pot, voisinage par exemple (66000 Perpi) ...


Merci de tous vos efforts et réponse (j'en espère d'autres, bien sur)

NB: (autre 'anecdotique') étrange je ne reçois pas le courrier elect. d'avertissement quant vous me répondez, alors que la case prévue à cet effet est bien cochée par défaut (comme je le vois ci dessous quand j'écris ces lignes à 'continuer à suivre cette discussion')
#11

Si tu as une carte SD que tu n'utilises plus (512Mo) minimum et un cable réseau, tu fais une installation rapide :
1) Tu formates ta carte en FAT32 avec 1 seule partition. Sous Windows facile
2) Tu installes ensuite la distribution Raspbian par réseau (info ici) sans brancher d'écran. Tu verras les lumières de la prise réseau clignoter si tout va bien.
3) Tu attends 20 minutes si tout va bien.

Tu pourras ensuite ton écran soit pendant l'install soit après
Et tu pourras toujours dans un premier temps te connecter en SSH

Ca réglera les histoires de démarrage qui marche ou pas, si ca vient de la carte ou autre

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
#12

Ca a marché avec la carte faite comme tu indiqué Chris... Merci
TRES bon signe donc...

bien que au final (10-15 mn puis éteint et relancé) ça fonctionne TB jusqu'à arriver (2-3 mn)
au login root et mot de passe (attention, ne PAS tenir compte de ce qui s'ecrit à l'écran; taper raspbian c'est bon même si à l'écran on n'a pas le 'a' mais autre chose ou si ce qu'on écrit est ... invisible.
.0.. question de langue et clavier évidemment) et de sécurité sans doute (BON à savoir, quand même, avant...)

* puis au final sur une ligne de commande # (je ne me rappelle plus quoi) qui attend apparemment un ordre...

1 Lequel ? Je fais quoi ? ?

2 (re) du moment et en supposant que le problème soit résolu, puisje alimer mon Rpi sans le cable 'modem' de branché ? (bien dur sans accés internet)



Je vais bien sur profiter des acfhats ce matin, minutes disponibles n(?) pour acheter et faire une nouvelle carte qui boote en mode 'graphique' pour permettre de choisir entre les options et paramètres possibles (langues, clavier, souris ... surtout)

D'avance merci pour vos réponses

Teo
#13

Pour la saisie du mot de passe c'est normal de ne pas voir ce que tu tapes (ni * ou autre caractère). C'est le fonctionnement sous UNIX
Ce que tu peut faire maintenant c'est charger la dernière version Raspbian sur le site officiel du Raspberry, suivre les intructions pour copier cette image (avec win32disk machin truc) et tu auras la partie graphique intégrée.
Le cable réseau n'alimente pas mais était là pour te donner accès Internet et surtout pour voir grâce aux lumières qu'il y avait bien de l'activité sur le Raspberry.

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
#14

Merci chris, mais comment ?, sachant que

'* puis au final sur une ligne de commande # (je ne me rappelle plus quoi) qui attend apparemment un ordre...
1 Lequel ? Je fais quoi ? ?'

*** En priorité, dés que je pourrai (5 a 20 mn ou plus de libre je suppose) je voudrai configurer mon clavier (et langue) et voir si souris et affichages graphique sur le moniteur sont ok

Teo
#15

Le prompt c'est la ligne de commande. Tu connais le monde UNIX ?
Si tu ne sais pas quoi y taper alors il vaut mieux passer par la partie graphique une fois l'image installée sur la carte SD. Et tu pourras configurer ton clavier

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
#16

Bon
* j'ai donc :
- un(e) RPi b+ en état de fonctionner (installation par réseau réussie et résultat concluant de ce point de vue) et
- 2 microSD 16 Go formatée FAT32 (formatage fait via windows7, çà ira?)
- NOOBS_v1_3_10.zip dézipé (il ressemble à un dossier windows)
et
- 2014-09-09-wheezy-raspbian dézippé (c'est un .img)
qui n'attendent que moi (et moi vous... par sécurité)

* Questions (merci d'avance) :

1) Le formatage FAT 32 que j'ai fait en passant par windows 7, c'est ok, pas de problème ? (pas moyen d'installer SDFormatterv4.zip) ou
Dois-je utiliser LinuxLive USB Creator 2.8.30 (que j'ai récupéré et dézipé)

Comment savoir et choisir si
Je peux copier entre plusieurs options théoriques (?) :

1) je met les deux (NOOBS 'dossier' + Rapsbian 'img') sur une seule micro SD ?
Ou je puis faire :

2) une micro SD avec NOOBS 'dossier'?)
et
l'autre microSD avec Raspbian img?

Tout est possible (tant 1) que 2) ? Le plus Utile/Inutile ?

Teo
#17

whaou

Cool
#18

Whaouu ? J'interprête que je dois résumer:
1)Pour commencer vraiment: Que dois-je - ou puis-je, si c'est utile- mettre sur une (au moins) OU mes 2 cartes miniSD

- QUE NOOBS (avec son dossier ?) ?
- NOOBS + Raspbian ? (chacun dans son dossier ?)
- QUE Raspbian ? (Dans son dossier ?)
?

2) je peux le faire (copier coller) sous windows ?

3) NOOBS ressemble (vu de windows) à un dossier: c'est normal ?

4) Raspbian est un dossier avec dedans 2014-09-09-wheezy-raspbian.img (me parait + normal, on a des à priori qd on débute, beaucoups, sans doute trop...) ... c'est normal ?

C'est mieux ;-) ?

Teo
#19

Je t'invite a aller voir ceci ==> NOOBS pour l'instalation de noob
#20

Merci pour ce qui me semble être un bon ou TB résumé

Je l'ai imprimé sur le champ avant même de le lire en détail
J'espère qu'il répondra à qq unes de mes questions
peut-être pas toutes

es-ce que je peux formater en FAT32 directement sous windows
esce que je peux faire le copier coller avec les dossiers ou juste l'intérieur
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)