Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Impossible de déporter l'affichage avec vnctightserver: erreur 10061
#1

Salut! Je viens vous reveiller pendant la sieste parce que je m'arrache les cheveux depuis quelques jours et il ne m'en reste plus trop la...

Donc, je n'arrive pas a deporter l'affichage de mon pi (wheezy) sur mon pc (w7).

J'arrive a SSH apres plusieurs tentatives, mais avec vnc j'obtiens toujours l'erreur" connection refused 10061.

D'apres mes recherches sur google, cette erreur provient en general d'un probleme d'ouverture du port dédié(5900).
J'ai donc ouvert le port 5900 du routeur (freebox v5) interne, externe, TCP et UDP. Mais bon, same same.

J'avais attribué des ip fixes pour mes appareils wifi, mais j'ai remis les reglages par défaut étant donné que ca ne donnait rien de plus.

Je suis conscient que tout ca n'est pas tres clair....Le but de ce message, justement, c'est qu'on m'aide a parametrer ca correctement en reprennant les choses des le début.
Evidemment, avant de venir ici, j'ai lu trente deux tutos, et éclusé quelques gigas de pages Google.Bref, a l'aide!!! Et merci d'avoir pris le temps de me lire.

Amicalement, 20syl
Répondre
#2

Si ton Rasp et ton PC sont tous les 2 dans ton réseau local, il n'y a pas a configurer ton routeur / freebox .

1- Savoir si ton VNC est en écoute sur le port 5900.
sudo netstat -ntaupe | grep 5900

2- Si oui faire un telnet vers le rasp sur le port 5900 et voir ce que ca donne.

L'utilisation de VNC est déconseillée.
Répondre
#3

Salut,

J'ai pas windows mais j'ai quand même une question :
Est-ce que le port 5900 de Windows est ouvert ?
Il y a un firewall d'activé ?
Répondre
#4

Alors, d'abord merci a tout les deux.
@Uggy,sympa les tuyaux(!)...je teste ca des que je rentre.VNC est déconseillé? Mais boooooohh j'ai besoin de x moi....pas de porno hein!

@Nekrophage,dans le pf windows, j'ai ajouté une exception pour vnc viewer et crée une regle specifique pour le port 5900, ouvert dans les deux sens ,je vais tenter de me reconnecter dans quelques minutes...faut que je file a l'ecole avec mes monstres.
Répondre
#5

Au pire, désactive quelques minutes le firewall Windows, et tu sauras vite si ça vient de là Wink.
Répondre
#6

Bon eh ben voila....IT'S ALIVE!!!!!
Le probleme venait de l'ouverture du port 5900 dans le pare-feu de windows, et d'un petit :1 que j'aurais du ajouter a la fin de l'adresse ip du pi dans vnc viewer.
Plus besoin de me prendre la tete avec plein de souris et des claviers un peu partout...Merci les gars
Répondre
#7

20syl a écrit :Le probleme venait de l'ouverture du port 5900 dans le pare-feu de windows
Etrange si tu "deportait l'affichage de ton pi (wheezy) sur ton pc" car cela sous entend que c'est le windows qui accedait au Rasp..
(et non l'inverse) mais bref.. l'essentiel c'est que ca fonctionne Smile

(mais VNC c'est mal Wink )
Répondre
#8

20syl a écrit :Mais boooooohh j'ai besoin de x moi

Ok.. pourquoi ? vu que ton interface graphique est aussi ton windows Smile
Rien n'est faisable par une interface web par exemple ? (peut etre , c'est juste pour savoir)

Sinon essaye xming ? au moins X sera tunnelisé dans du SSH.
Répondre
#9

Uggy a écrit :sudo netstat -ntaupe | grep 5900

L'utilisation de VNC est déconseillée.

Merci pour l'info du netstat, en fait chez moi il est sur le port 5901, car je dois rentrer "adresse IP":1 pour me connecter en VNC

Par contre déconseillé pourquoi, pour la sécu ?

car moi j'utilise ( sous ubuntu ) un tunnel SSH, ( j'ai changer le port par défaut du SSH du RPI ), et ensuite je crée un lanceur avec:
Code :
ssh adresseIP -l pi -p 2200 -L 5901:adresseIP:5901

ensuite dans SSL/SSH VNC Viewer, comme connexion HostBig Grinisplay, je lui met localhost:1

Soucis, pour l'instant, je n'arrive pas à l'atteindre de l'extérieur, soucis vraisemblablement de redirection de port.
Si vous avez une idée.

Normalement, de cette manière, le ssh crypte la liaison, non ?


PS
Heu
je viens de réessayer, et plus rien ne fonctionne, je me demande si je n'ai pas merdouillé, et choisis la connexion sans SSL ni SSH de SSL/SSH VNC Viewer... :8
En résumé, je croyais que ça fonctionnais, mais ça pas l'air d'être le cas.
En tout cas je pense que vous comprenez ce que je voudrais faire, et si vous pouviez me tuyauter dans ce sens {)

RPI B
XP Pro/7 64/(L)Ubuntu
Répondre
#10

Pour info j'avais utiliser ce lien là

RPI B
XP Pro/7 64/(L)Ubuntu
Répondre
#11

après re-re-essais :
je fais ma liaison ssh avec adresse IP du RPI dans mon réseau
sur port 2222
Code :
ssh 192.168.1.21 -l pi -p 2222 -L 5901:192.168.1.21:5901
puis je lance SSL/SSH VNC Viewer avec comme connexion HostBig Grinisplay, je lui met localhost:1
comme cryptage je lui met "none"

et ça fonctionne.

Par contre pour l'instant je n'arrive pas à faire la liaison SSH sur mon adresse IP extérieure.

RPI B
XP Pro/7 64/(L)Ubuntu
Répondre
#12

changement:
je lance directement SSL/SSH VNC Viewer ( sous ubuntu )
je mets :
VNC HostBig Grinisplay -> localhost:1
VNC Password -> mon mot de passe VNC
Proxy/Gateway -> [email protected]_RPI:2222

avec AdresseIP_RPI, l'adresse IP "interne" du RPI
2222, le port SSH que j'ai modifié ( dans /etc/ssh/sshd_config ) du RPI

et dans Options/Advanced/Additional Ports Redirs (via SSH) de SSL/SSH VNC Viewer j'ai mis
-L 5901:AdresseIP_RPI:5901

tout ceci pour supprimer la commande SSH que je faisais avant en mode console.
Mais j'ai toujours le même soucis d'accès depuis l'extérieur.

RPI B
XP Pro/7 64/(L)Ubuntu
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)