Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

[Help] Impossible de PING avec OpenWRT
#1

Bonjour à tous comment allez-vous ?

J'ai un projet à réaliser avec mon école mais malheureusement je suis bloqué au début de ce dernier.
Mon projet est de réaliser une sorte de standard téléphonie (VoIP) avec un RPI 4 B. 

Mon prof m'a demandé en premier lieu d'installer OpenWRT ce que j'ai reussis à faire sans soucis.
Je me connecte donc à OpenWRT avec Putty sous l'adresse 192.168.1.1. Mais je suis chez free et donc l'adresse IP de ma box est en 192.168.0.1. 
J'ai donc modifié dans le fichier /etc/config/network quelques lignes mais après ces modifications je n'arrive rien à PING.
Je pense que cela vient du DNS mais en fait je ne suis pas hyper calé dans ce domaine, je vous transmet si dessous ma config : 


/etc/config/network


Citation : a écrit :config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdfd:5f98:debf::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.0.1'
        option dns '192.168.0.1'
        option ipaddr '192.168.0.11'


/etc/config/dns

Citation : a écrit :config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'


Résultat de ifconfig

Citation : a écrit :br-lan    Link encap:Ethernet  HWaddr DC:A6:32:CB:A9:F8
          inet addr:192.168.0.11  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::dea6:32ff:fecb:a9f8/64 Scope:Link
          inet6 addr: fdfd:5f98:debf::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6787 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1318 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:552706 (539.7 KiB)  TX bytes:99833 (97.4 KiB)

eth0      Link encap:Ethernet  HWaddr DC:A6:32:CB:A9:F8
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10074 errors:0 dropped:2 overruns:0 frame:0
          TX packets:2388 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:968988 (946.2 KiB)  TX bytes:192654 (188.1 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3496 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3496 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:329046 (321.3 KiB)  TX bytes:329046 (321.3 KiB)
 

Résultat PING google
Citation : a écrit :ping: bad address 'google.fr'



PS: une fois que cela fonctionnera, je devrait installer asterisk sur mon RPI4 B

Merci à tous pour votre aide!   [Image: biggrin.png]
Répondre
#2

J'ai juste un doute: la box free en 192.168.0.1 ? Habituellement, c'est plutôt 192.168.0.254
Répondre
#3

(11-03-2021, 15:45:18)CrazyCat a écrit :  J'ai juste un doute: la box free en 192.168.0.1 ? Habituellement, c'est plutôt 192.168.0.254

Ah oui c'est possible j'ai vu ça sur internet, je suis un peu perdu j'admet. Quoi qu'il en soit je doit quand même modifier l'adresse IP en 192.168.0.x non ?  Huh
Répondre
#4

Tout à fait, mais il faut que tu renseignes bien ta gateway et le serveur dns (qui doivent être ta freebox).

Tu peux vérifier ces infos depuis ton PC avec un ipconfig (si tu es sous windows) pour savoir quelle est ta passerelle
Répondre
#5

(11-03-2021, 18:29:16)CrazyCat a écrit :  Tout à fait, mais il faut que tu renseignes bien ta gateway et le serveur dns (qui doivent être ta freebox).

Tu peux vérifier ces infos depuis ton PC avec un ipconfig (si tu es sous windows) pour savoir quelle est ta passerelle

Ok j'ai bien changé du coup mon DNS et ma gateway en: 192.168.0.254 (comme affiché avec ipconfig) et rien ne change j'ai la même erreur lors du ping.


Citation :config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.0.254'
        option dns '192.168.0.254'
        option ipaddr '192.168.0.11'

[email protected]:~# ping google.fr
ping: bad address 'google.fr'
[email protected]:~#

Je ne comprend pas...  Undecided  
Répondre
#6

Est-ce que au moins tu peux pinger ta box (via son IP) et un serveur dns de google (8.8.4.4 ou 8.8.8.8) ?
Répondre
#7

(12-03-2021, 09:58:00)CrazyCat a écrit :  Est-ce que au moins tu peux pinger ta box (via son IP) et un serveur dns de google (8.8.4.4 ou 8.8.8.8) ?

Non, vraiment je n'arrive à rien PING..

Citation :[email protected]:~# traceroute openwrt.org
traceroute: NO OPT x!
[email protected]:~# ping 192.168.0.254
PING 192.168.0.254 (192.168.0.254): 56 data bytes
^C
--- 192.168.0.254 ping statistics ---
431 packets transmitted, 0 packets received, 100% packet loss
[email protected]:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes

--- 8.8.8.8 ping statistics ---
2 packets transmitted, 0 packets received, 100% packet loss
[email protected]:~# ping 8.8.4.4
PING 8.8.4.4 (8.8.4.4): 56 data bytes
^C
--- 8.8.4.4 ping statistics ---
4 packets transmitted, 0 packets received, 100% packet loss
[email protected]:~#
Répondre
#8

Donc ta gateway (et ton dns) ne sont pas bon.

Je pense que tu devrais refaire la configuration réseau en partant de 0 (ou presque) en deux étapes:
1. faire attribuer une IP par ta boxe:
Bash
uci set network.lan.proto=dhcp
uci commit
/etc/init.d/network restart


Une fois que tu as eu une IP dynamique, tu vérifies ton ifconfig pour avoir tes infos de base

2. prendre une IP qui te convienne et la fixer:
Bash
uci set network.lan.ipaddr=192.168.1.199
uci commit
/etc/init.d/network restart


En remplaçant bien sûr 192.168.1.199 par une IP libre sur ton réseau
Répondre
#9

(12-03-2021, 12:13:21)CrazyCat a écrit :  Donc ta gateway (et ton dns) ne sont pas bon.

Je pense que tu devrais refaire la configuration réseau en partant de 0 (ou presque) en deux étapes:
1. faire attribuer une IP par ta boxe:
Bash
uci set network.lan.proto=dhcp
uci commit
/etc/init.d/network restart


Une fois que tu as eu une IP dynamique, tu vérifies ton ifconfig pour avoir tes infos de base

2. prendre une IP qui te convienne et la fixer:
Bash
uci set network.lan.ipaddr=192.168.1.199
uci commit
/etc/init.d/network restart


En remplaçant bien sûr 192.168.1.199 par une IP libre sur ton réseau


Du coup j'ai réinstaller OpenWRT, et directement utilisé la commande que tu m'as donné. Du coup ça m'a automatique deconnecté du RPI mais en fait j'arrive pas à trouver la nouvelle @IP de OpenWRT pour m'y connecté. Dans ipconfig y'a "IPv4: 169.254.54.119 Masque: 255.255.0.0" en connexion ethernet mais ce n'est pas ça.
As-tu une autre technique pour trouver la nouvelle @IP de OpenWRT ?
Merci pour toutes tes réponses.
Répondre
#10

Si tu as cette IP, c'est que ton RPi n'arrive pas à se connecter à ta box, ce qui est assez étrange.
Il est bien connecté en ethernet sur ta box ?

Il y a bien longtemps que je n'ai pas utilisé ce soft et à l'époque je le gérais par son interface web (matériel distant et SSH bloqué), je vais essayer de trouver d'autres infos.
Répondre
#11

(12-03-2021, 14:51:15)CrazyCat a écrit :  Si tu as cette IP, c'est que ton RPi n'arrive pas à se connecter à ta box, ce qui est assez étrange.
Il est bien connecté en ethernet sur ta box ?

Il y a bien longtemps que je n'ai pas utilisé ce soft et à l'époque je le gérais par son interface web (matériel distant et SSH bloqué), je vais essayer de trouver d'autres infos.


Ah non non le RPI est connecté à mon PC. Pour faire ce que je veux faire j'ai commencé à suivre un tuto ou le mec dit de connecté le RPI au pc, de changer manuellement l'@IP et ensuite de le connecté au routeur (une fois que opkg est installé). Mais je ne peux pas installé OPKG vu que je n'arrive rien à PING :'(.


lien du site: https://objnux.1s.fr/index.php?post/2019...ec-OpenWrt
Répondre
#12

Le site devait être hébergé chez ovh à Strasbourg, il est down.

Mais clairement, quelle absurdité. Ce genre de logiciel ne s'installe pas en étant coupé de tout, ton PC ne fait ni dhcp ni routeur, il est donc impossible pour ton RPi de sortir.
Il y a un mini-tuto chez Korben: https://korben.info/openwrt-raspberry-pi.html, sinon tu peux lire le mini-howto qui est à https://forum.openwrt.org/t/rpi4-step-by...lp/75184/2
Répondre
#13

(12-03-2021, 16:30:31)CrazyCat a écrit :  Le site devait être hébergé chez ovh à Strasbourg, il est down.

Mais clairement, quelle absurdité. Ce genre de logiciel ne s'installe pas en étant coupé de tout, ton PC ne fait ni dhcp ni routeur, il est donc impossible pour ton RPi de sortir.
Il y a un mini-tuto chez Korben: https://korben.info/openwrt-raspberry-pi.html, sinon tu peux lire le mini-howto qui est à https://forum.openwrt.org/t/rpi4-step-by...lp/75184/2

Ok alors j'ai réussis. Pour ceux qui aurait le même problème que moi je vais expliqué ce que j'ai fait : 

J'ai tout remis à 0 (reboot avec OpenWRT de base pour RPI4B), j'ai mis dans /etc/config/network en adresse IP : 192.168.0.51 (pour freebox) et gw : 192.168.0.254 (ip freebox).
Une fois tout les paramètres inscrits, j'ai tout relancé (uci commit && /etc/init.d/network restart) et j'ai connecté mon RPI à ma box.
J'ai ensuite pu me connecté à mon RPI (192.168.0.51) mais je ne pouvais uniquement PING que 8.8.8.8. 
J'ai donc rajouté la ligne : "nameserver 8.8.8.8" dans /etc/resolv.conf et maintenant tout fonctionne.

Merci encore CrazyCat pour le temps que tu m'as donné ! Big Grin
Répondre
#14

De rien.
Dans ton /etc/resolv.conf, tu n'as que le 8.8.8.8 ? Pas la freebox aussi ? Si tel est le cas, je te conseille de l'ajouter, ça économisera légèrement ta bande passante et sera plus réactif, la freebox faisant alors office de proxy dns.

C'est pas grand chose, mais sur un firewall, la réactivité est très importante. Et la différence de ping entre un serveur DNS local et un serveur DNS externe peut jouer fortement. Dans mon cas, je passe de 0.5ms (freebox) à 40ms (google), et 85ms pour opendns...
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)