Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Erreurs lors de l'installation de PHP5
#1

Bonjour,

Je souhaite simplement installer PHP5 sur ma RasPi qui tourne sous Raspbian Jessie, mais je rencontre un tas d'erreurs... 8.(
Voilà ce que j'obtiens :

Code :
[email protected]:/ $ sudo apt-get install php5
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  libapache2-mod-php5 libonig2 libperl4-corelibs-perl libqdbm14 lsof php5-cli php5-common php5-json php5-readline
Paquets suggérés :
  php-pear php5-user-cache
Les NOUVEAUX paquets suivants seront installés :
  libapache2-mod-php5 libonig2 libperl4-corelibs-perl libqdbm14 lsof php5 php5-cli php5-common php5-json php5-readline
0 mis à jour, 10 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0 o/5 025 ko dans les archives.
Après cette opération, 18,6 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Subroutine File::Spec::Unix::canonpath redefined at /usr/share/perl/5.20/XSLoader.pm line 92, <DEBCONF_CONFIG> chunk 3.
Subroutine File::Spec::Unix::catdir redefined at /usr/share/perl/5.20/XSLoader.pm line 92, <DEBCONF_CONFIG> chunk 3.
Subroutine File::Spec::Unix::catfile redefined at /usr/share/perl/5.20/XSLoader.pm line 92, <DEBCONF_CONFIG> chunk 3.
Sélection du paquet libonig2:armhf précédemment désélectionné.
(Lecture de la base de données... 124152 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libonig2_5.9.5-3.2_armhf.deb ...
Dépaquetage de libonig2:armhf (5.9.5-3.2) ...
Sélection du paquet libperl4-corelibs-perl précédemment désélectionné.
Préparation du dépaquetage de .../libperl4-corelibs-perl_0.003-1_all.deb ...
Dépaquetage de libperl4-corelibs-perl (0.003-1) ...
Sélection du paquet lsof précédemment désélectionné.
Préparation du dépaquetage de .../lsof_4.86+dfsg-1_armhf.deb ...
Dépaquetage de lsof (4.86+dfsg-1) ...
Sélection du paquet libqdbm14 précédemment désélectionné.
Préparation du dépaquetage de .../libqdbm14_1.8.78-5+b1_armhf.deb ...
Dépaquetage de libqdbm14 (1.8.78-5+b1) ...
Sélection du paquet php5-common précédemment désélectionné.
Préparation du dépaquetage de .../php5-common_5.6.14+dfsg-0+deb8u1_armhf.deb ...
Dépaquetage de php5-common (5.6.14+dfsg-0+deb8u1) ...
Sélection du paquet php5-json précédemment désélectionné.
Préparation du dépaquetage de .../php5-json_1.3.6-1_armhf.deb ...
Dépaquetage de php5-json (1.3.6-1) ...
Sélection du paquet php5-cli précédemment désélectionné.
Préparation du dépaquetage de .../php5-cli_5.6.14+dfsg-0+deb8u1_armhf.deb ...
Dépaquetage de php5-cli (5.6.14+dfsg-0+deb8u1) ...
Sélection du paquet libapache2-mod-php5 précédemment désélectionné.
Préparation du dépaquetage de .../libapache2-mod-php5_5.6.14+dfsg-0+deb8u1_armhf.deb ...
Dépaquetage de libapache2-mod-php5 (5.6.14+dfsg-0+deb8u1) ...
Sélection du paquet php5 précédemment désélectionné.
Préparation du dépaquetage de .../php5_5.6.14+dfsg-0+deb8u1_all.deb ...
Dépaquetage de php5 (5.6.14+dfsg-0+deb8u1) ...
Sélection du paquet php5-readline précédemment désélectionné.
Préparation du dépaquetage de .../php5-readline_5.6.14+dfsg-0+deb8u1_armhf.deb ...
Dépaquetage de php5-readline (5.6.14+dfsg-0+deb8u1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.0.2-5) ...
Paramétrage de libonig2:armhf (5.9.5-3.2) ...
Paramétrage de libperl4-corelibs-perl (0.003-1) ...
Paramétrage de lsof (4.86+dfsg-1) ...
Paramétrage de libqdbm14 (1.8.78-5+b1) ...
Paramétrage de php5-common (5.6.14+dfsg-0+deb8u1) ...
/usr/bin/dirname: ligne 1 : .: nom de fichier nécessaire en argument
. : utilisation :. nom_fichier [arguments]
/usr/bin/dirname: ligne 3: -z, : commande introuvable
/usr/bin/dirname: ligne 4: --help : commande introuvable
/usr/bin/dirname: ligne 5: --version : commande introuvable
/usr/bin/dirname: ligne 7: Examples: : commande introuvable
/usr/bin/dirname: ligne 8 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 9 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 10 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 12: erreur de syntaxe près du symbole inattendu « newline »
/usr/bin/dirname: ligne 12: `%s online help: <%s>'
/usr/bin/dirname: ligne 1 : .: nom de fichier nécessaire en argument
. : utilisation :. nom_fichier [arguments]
/usr/bin/dirname: ligne 3: -z, : commande introuvable
/usr/bin/dirname: ligne 4: --help : commande introuvable
/usr/bin/dirname: ligne 5: --version : commande introuvable
/usr/bin/dirname: ligne 7: Examples: : commande introuvable
/usr/bin/dirname: ligne 8 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 9 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 10 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 12: erreur de syntaxe près du symbole inattendu « newline »
/usr/bin/dirname: ligne 12: `%s online help: <%s>'
dpkg: erreur de traitement du paquet php5-common (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de php5-json :
php5-json dépend de phpapi-20131226 ; cependant :
  Le paquet phpapi-20131226 n'est pas installé.
  Le paquet php5-common qui fournit phpapi-20131226 n'est pas encore configuré.

dpkg: erreur de traitement du paquet php5-json (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de php5-cli :
php5-cli dépend de php5-common (= 5.6.14+dfsg-0+deb8u1) ; cependant :
Le paquet php5-common n'est pas encore configuré.
php5-cli dépend de php5-json ; cependant :
Le paquet php5-json n'est pas encore configuré.

dpkg: erreur de traitement du paquet php5-cli (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de libapache2-mod-php5 :
libapache2-mod-php5 dépend de php5-common (= 5.6.14+dfsg-0+deb8u1) ; cependant :
Le paquet php5-common n'est pas encore configuré.
libapache2-mod-php5 dépend de php5-cli ; cependant :
Le paquet php5-cli n'est pas encore configuré.
libapache2-mod-php5 dépend de php5-json ; cependant :
Le paquet php5-json n'est pas encore configuré.

dpkg: erreur de traitement du paquet libapache2-mod-php5 (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de php5 :
php5 dépend de libapache2-mod-php5 (>= 5.6.14+dfsg-0+deb8u1~) | libapache2-mod-php5filter (>= 5.6.14+dfsg-0+deb8u1~) | php5-cgi (>= 5.6.14+dfsg-0+deb8u1~) | php5-fpm (>= 5.6.14+dfsg-0+deb8u1~) ; cependant :
Le paquet libapache2-mod-php5 n'est pas encore configuré.
  Le paquet libapache2-mod-php5filter n'est pas installé.
  Le paquet php5-cgi n'est pas installé.
  Le paquet php5-fpm n'est pas installé.
php5 dépend de php5-common (>= 5.6.14+dfsg-0+deb8u1~) ; cependant :
Le paquet php5-common n'est pas encore configuré.

dpkg: erreur de traitement du paquet php5 (--configure) :
problèmes de dépendances - laissé non configuré
dpkg: des problèmes de dépendances empêchent la configuration de php5-readline :
php5-readline dépend de phpapi-20131226 ; cependant :
  Le paquet phpapi-20131226 n'est pas installé.
  Le paquet php5-common qui fournit phpapi-20131226 n'est pas encore configuré.
php5-readline dépend de php5-common (= 5.6.14+dfsg-0+deb8u1) ; cependant :
Le paquet php5-common n'est pas encore configuré.
php5-readline dépend de php5-cli (= 5.6.14+dfsg-0+deb8u1) ; cependant :
Le paquet php5-cli n'est pas encore configuré.

dpkg: erreur de traitement du paquet php5-readline (--configure) :
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u1) ...
Des erreurs ont été rencontrées pendant l'exécution :
php5-common
php5-json
php5-cli
libapache2-mod-php5
php5
php5-readline
E: Sub-process /usr/bin/dpkg returned an error code (1

J'ai tenté de me dépatouiller, mais sans succès Sad
Quelqu'un aurait une idée de ce qui se passe ?

Par avance, merci

EDIT (08/12/2015 à 14h43) :

Si je comprends bien, l'enchaînement des erreurs est à l'origine d'un problème de paramétrage de php5-common

Code :
[...]

Paramétrage de php5-common (5.6.14+dfsg-0+deb8u1) ...
/usr/bin/dirname: ligne 1 : .: nom de fichier nécessaire en argument
. : utilisation :. nom_fichier [arguments]
/usr/bin/dirname: ligne 3: -z, : commande introuvable
/usr/bin/dirname: ligne 4: --help : commande introuvable
/usr/bin/dirname: ligne 5: --version : commande introuvable
/usr/bin/dirname: ligne 7: Examples: : commande introuvable
/usr/bin/dirname: ligne 8 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 9 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 10 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 12: erreur de syntaxe près du symbole inattendu « newline »
/usr/bin/dirname: ligne 12: `%s online help: <%s>'
/usr/bin/dirname: ligne 1 : .: nom de fichier nécessaire en argument
. : utilisation :. nom_fichier [arguments]
/usr/bin/dirname: ligne 3: -z, : commande introuvable
/usr/bin/dirname: ligne 4: --help : commande introuvable
/usr/bin/dirname: ligne 5: --version : commande introuvable
/usr/bin/dirname: ligne 7: Examples: : commande introuvable
/usr/bin/dirname: ligne 8 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 9 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 10 : fg: pas de contrôle de tâche
/usr/bin/dirname: ligne 12: erreur de syntaxe près du symbole inattendu « newline »
/usr/bin/dirname: ligne 12: `%s online help: <%s>'
dpkg: erreur de traitement du paquet php5-common (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1

[...]

Ça ne m'aide pas à avancer, mais peut-être que ça parle à quelqu'un... Smile
Répondre
#2

Tu as peut-être un souci avec un paquet qui ne s'est pas bien installé précédemment.
Tu peux essayer:
Code :
apt-get update
dpkg --configure -a
apt-get -f upgrade
Et ensuite, relance ton apt-get install.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)