Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Difficultés pour el parametrage de "tightvncserveur"
#1

Bonjour .

Toujours en phase de test et d'essais...
ma config:
1 raspberry pi B+ avec Raspbian installé.
Open SSH serveur installé. sur le Raspberry. Je peux lancer et arrêter le serveur
Mes deux autres ordinateurs (1 Mac et 1 Laptop sous débian 7.8) s'y connectent sans problème.
Mon routeur FREE écoute SSH sur un autre port que le port 22
Mon fils à 100 km se connecte et a accès au terminal du Raspi ... et tout va bien..

Donc une fois tout cela positivement testé, je décide de passer au serveur VNC que j'installe.. sur le Raspi
Je peux arrêter et lancer le serveur VNC sur le serveur...
Et là il y a deux cas.

Cas favorable:
Sur la console du serveur VNC (Raspi) si je tape
Code :
vncserver :1
... le serveur se lance et affiche dans le terminal:
Code :
Starting applications spécified in /home/pi/.vnc/xstartup
Log file is /home/pi/.vnc/raspbian:1.log

Et si je me connecte depuis le mac et/ou depuis le Laptop, j'obtiens bien la fenêtre du Raspi, mais dans un format différent (en echelle Longueur x largeur... Le bureau est tronqué à gauche comme à droite... et je n'ai pas accès au bouton "menu" du tableau de bord qui est hors champ....

Et au centre de la fenêtre du Raspi qui apparaît sur l'écran de l'ordi client, un message d'erreur qui dit un truc curieux: GDBUs.Error.orgfreedesktop.PolicyKit1.Error.Failed: An authentifiation agent already exist for the given subject

Cas défavorable:
Et quand je lance le serveur avec le paramètre "-geometry 1360x768" (propre au moniteur) il m'affiche qu'il ne peut lancer le serveur..... "Couldn't start Xtightvnc; truing default font path. Please set correct fontPath in the vncserver script"

Je pense (peut-être à tord) que la solution doit se trouver dans le fichier xstartup que j'édite...

Code :
#!/bin/sh

xrdb $HOME/.Xressources
xsetroot -solid grey
#x-terminal-emulator -geometry 80x24+10+10 ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
# Fix to make GNOME work
export XKL_XMODMAP_DISABLE=1
/etc/X11/Xsession

et là le papé il est perdu..
je ne comprend pas la relation entre le -gometry de ce fichier, et le geometry 1360x768, et le pourquoi de cette erreur...

Merci de vos lumières...

Lenovo Legion Y520 SSD 128 + HHD 1 To - LMDE4
FreeBox V6  -  RaspBerry Pi 400
Peintures, Voyages et Photos
Association Ordifacile17
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)