Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Deluged, RPI monitor
#26

Le sftp, c'est du transfert de fichier via SSH...

Donc si SSH est activé, normalement le SFTP doit fonctionner Wink.
Répondre
#27

apparemment j'ai lu que dropbear ne gère pas le sftp et puis je n'arrive pas à acceder a mon rasbperry depuis le sftp via filezilla cf erreur données précédemment....
Répondre
#28

Étrange, normalement SFTP marche bien si SSH est activé...

Sur mon RPI, un SFTP sur le port 22 marche très bien.
Répondre
#29

Oui pas de sftp avec dropbear. Pour mon serveur j'ai du repasser à openssh

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#30

J'ai installé raspbian (avec openssh) maintenant j'aimerais accéder à /media/usbdrive/ mais le filezilla me dit permission denied ...
idem lorsque je veux ecrire dans /home/pi/ ....
Code :
[== Indéfini ==]
Erreur :    /home/pi/working/SourcE v1.4.zip: open for write: permission denied
Erreur :    Echec du transfert du fichier
bon c'est résolu avec un chmod 777
Code :
[== Indéfini ==]
sudo mkdir /media/usbdrive/partage
mkdir: cannot create directory `/media/usbdrive/partage': Operation not permitted
je peux même pas faire un fichier
meme après avoir chmod 777 /dev/sda2
Répondre
#31

Tu peux pas faire ce genre de commande. Il faut travailler dans le fichier fstab dans les options de montage pour donner les droits à chaque boot
Tu montes manuellement ta partition en étant root
Tu fais un chown -R <ton user>:<groupe de ton user> /media/usbdrive
Tu vas dans le fichier /etc/fstab et tu ajoutes une ligne genre :
/dev/sda1 /media/usbdrive ext4 force,rw,uid=<ton user>,gid=<groupe de ton user> 0 0

<ton user> sera propriétaire et pourra tout faire sur le point de montage.

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)